Another case of dead throttle after LC install

I have posted all over the forum.. Have a ticket opened. Opened it 6 days ago with zero response..

As so many others.. I installed the CSL Loadcell brake to my CSL 2 pedal set up.. It has fried the throttle.. Updated firmware. Removed load cell and throttle still inop.. Triple checked wiring.. reinstalled drivers.. all to no avail..

Someone from Fanatec please help

ddpro, PS5..

there will a obviously a QC issue here..


  • Have you tried connecting it to your PC to see if it works?

  • Yes.. and it does not. LC is fine, and Clutch is fine.. Zero for throttle in Fanalab

  • I finally got a response from support on my ticket that I opened on March 30th. It wasn't any help...just told me to make sure it was hooked up properly. Waiting again...Fanatec really needs to invest in their support structure.

    I am a new customer with Fanatec and was really enjoying their products but now I have a sour taste in mouth. I do hope they will make this right and that I won't have any other issues. Pretty safe to say that I won't be buying any additional products from them now. Part of me wishes I could just get a refund on everything and move along...

  • I have been reading so much about their customer service that maybe i should delete the Fanatec forum from my favourites bar.

    I am not going to buy anymore Fanatec products if I have the option I think. Not at least until their customer service is better.

  • Alex StudilcoAlex Studilco Member
    edited April 2022


  • I have the same issue , throttle won’t work at all now . Have you had any luck ?

  • yesterday I got my new DD PRO bundle with CLS brake paddle and boost kit and I have the same problem that the throttle did not work!

    I try everything but also with the original brake paddle the throttle did not work.

    If I connect the brake paddle to the clutch, the CLS brake and the clutch work but the throttle not.

    New Firmware is installed, and the connections are correct.

    It seems that there is a technical problem with the throttle accelerator!!!

  • Did anyone here have the pedals plugged into the PC and base at the same time? Shame to see yet another throttle issue related to using the load cell.

  • Not doubting peoples experiences at all but I got my DD Pro in Feb, ordered & installed the load cell a few weeks ago and everything works great.

  • You are NOT suppose to plug into your base and PC at the same time.

    Are all these problems relating to the throttle issue, due to customers connecting to both the base and pc at the same time? And the resulting fry-ups?

  • Same problem here I had the gt dd pro over 2 months now all working great but I held off to get the gt3 mclaren wheel and load cell pedal together just to save on the shipping costs

    I was really happy with the sim just needed a new wheel to play f1 with

    I opened and connected everything just as it said in the video and leaflet , personally I felt a electronic smell once I powered it up and connected it to my pc I got nervous as if I had done something wrong but it was all perfect

    proceeded for hours trying to figure it out online , really regret getting the lc pedal as an add on I was more than happy with the break that comes with really hope I don’t have to wait long to get this sorted , just like many others I’m disappointed as I’ve invested a lot into this brand and I did it with the knowledge that this was an expensive brand because it was good but this happening baffles me with the cost involved hope it’s sorted

  • I hope not. It really should be able to handle usb and rj12 plugged in at the same time. Makes me thing the circuitry is weak AF

    Mine were DOA without the load cell in the equation.

  • David ChiengDavid Chieng Member
    edited April 2022

    Do agree with you there as it is an error that can happen quite easily.

    Maybe Fanatec should have made it with a slider door such that you cannot plug in both at the same time.

  • Or maybe people should pay more attention and read the manual/instructions.

  • edited April 2022

    I'm sorry, I love my Fanatec gear, but that doesn't mean it's not without flaws. The location of the inputs on the pedals and handbrake are just terrible, and the fact that you have to swap these cables on the pedals to do firmware updates is just silly.

    If you have a load cell then you most likely have them bolted to a rig of some sort and that's can be a serious job, just to plug in the USB.

    The warnings, the manual, all of this is not user friendly and this issue is not a unique issue. We've seen it time and time again. Reading these forums told me not to do that better than the manual did. I think i even asked at one point because I wanted to make it easier to update firmware for myself.

    That should be enough info for some updates to their pedal workflow.

  • David KarlinDavid Karlin Member
    edited April 2022

    I did not plug the pedals into the PC and they stopped working within hours of installing the load cell just going to the wheelbase. Then I tried unplugging from the wheelbase and going to the PC and still dead.

    I don't think this is it. Seems more like something coming from the load cell to the throttle fries the throttle in certain situations. It's not happening to everyone, so it's not 100%, but it's happening to enough people that it's not like a 1% chance of happening either.

    I'm getting my CSL pedals replaced but I just straight up returned the Load Cell pedal and ate the return shipping cost. Not that I wouldn't have minded keeping the Load Cell, but until the issue is identified, there's no reason to not expect the next set of replacement CSL Pedals to get fried and die again and I'm not taking that chance after how long support has taken to respond and replace the CSL Pedals (which I'm still waiting on).

  • I also plugged mine in correctly… not into 2 devices at once.. I can read instructions.. and after spending a grand on them, I read them very carefully.. This isn’t a user issue.. this is a QC issue.. And customer service turn around time is awful.. They will respond at first with a question acting like you are the only one having this issue.. It’s a known issue.. and a high level of the last batch of Loadcell are frying the throttle.. Fix it Fanatec..

  • My comment was directly towards David’s slider door suggestion. I never said anything about them not having flaws. I have a load cell brake, and have to do the same thing that others do. But as far as the issue with the load cell possibly frying the throttle, that sounds like what’s going on. It seems the jump into their new line of products has just been…..well…..not positive with a great number of users. No ifs, ands, or buts about it.

  • Yo tengo el mismo problema desde el 18 de marzo que llegó el pedido dd pro con freno célula de carga todo conectado correctamente sigue sin funcionar se queda acelerado y muchas fluctuaciones el soporte técnico nefasto .ahora me dicen que se pondrán en contacto conmigo

  • I’d recommend ringing them between 2-4pm Central European time it took about 30 rings but finally got someone and he was super nice and helpful and emailed me straight away

  • I got a response from support on my ticket asking to perform some basic troubleshooting which I had already done. I had also included that information in the ticket that the throttle no longer works in any configuration. Now I am over week out without another response. Really frustrated and regretting my Fanatec purchases at this point.

  • 20 days in.. Finally got an RMA.. first tell me where to send it🤷🏻‍♂️, No Prepaid labels.. Tell me they will send out replacement or repair after they receive mine..

  • This is all very disappointing. I also really wondered if people are plugging in RJ12 and USB at the same time. But it seems like there are a lot of people who confirmed that they did not do that. Like David said, either way, it is way too easy to do accidentally so I'm sure many did. For the people that didn't, it's a straight-up textbook QC issue on the side of Fanatec. I got all my parts and everything is hooked up and working properly(after doing my own troubleshooting), but I'm scared as hell that something will go wrong and I'm gonna have to get on the waiting queue of hell. I haven't been this disappointed in a company since CD Project Red released Cyberpunk. I'm still in shock that FANATEC is the one doing this. I'm always making excuses for them in my mind. Like "there's a high call volume". But no, they need to step it up. Refund every single purchase if necessary. Take the hit to sales numbers which you can recover from with a fixed product later. Or take a hit to your reputation which is like living in exile for a very long time if not forever.

  • This is a joke, I have the same problem, throttle dead. Two days ago I wrote to Fanatec, no response yet, this is not admisible for the prices and shipping costs that they have. I had for 8 years a Thrustmaster T500 and 0 problems.

    They have to improve a lot.

  • May 3rd.. still no replacement pedals.. this all started April 1st.. Fanatec needs to step up it’s game

  • Had the same issue and went through the whole process. Response time by Fanatec was usually around one week between emails. Fanatec (Germany) received my defective pedals on April 27th and today I received a package from them. I can report that at least in my case they didn‘t send me new ones but instead repaired my old pedals. They didn‘t provide me with any info on what they have done to fix it. I tried the pedals with both the regular brake and the LC and everything worked liked charm. Tried it with a couple of games and throttle functionality is back.

  • same experience for me. throttle stop working after load cell installed. Open Ticket on 7 April, on 22 April Fanatec answered with RMA procedure, 5 May new throttle (new serial number) arrived and it works fine. I don't plug in Load Cell again, i don't want to open new rma nightmare. it is not necessary for me use the Load cell, it's too stiff for me and i don't have rig.

Sign In or Register to comment.