CSL DD Not Powering Up

Hi All,

My CSL DD won't power up. The power supply shows a green light but the unit doesn't turn on when connected. Does anyone know how I can test whether the issue is with my power supply cable or the DD unit itself? The only other power supply I have with the right kind of connection is the PSU in the PC, but I am not sure what to expect if I try this given Fanatec only recommend using their branded power units.


  • Hey mate I’m having a similar problem , I’ve just waited months for my csl dd 8nm , which I got last week , within 30 mins of setting it all up and playing my power went . No light on the power pack , changed the fuse and again nothing . 30 mins of play and it’s stopped , I’ve contacted fanatec several times and I’m getting nowhere . Is yours a new power pack ?

  • Had the same issue as well, my feel failed after a couple uses, i made a ticket on April 8th, tofay is 10th of may, still no solution. The wheel is in the factory since previous weel. Had to wait 21 days for the first answer. So the best of luck, 5 weeks am i waiting to race. 😅

    and still no wheel.

  • Wow mate that’s totally unacceptable . That’s not fair. I’m so angry that this has broke , 30 mins racing and now dead , I’ve had one reply saying they will pass my issue over to the technical department . I can’t believe they have taken the phone line and live chat away to catch up on emails . If I had known about the bad customer service I would have gone elsewhere

  • I've had mine for months. Everything was working fine until a couple of days ago. I emailed Fanatec right away to ask about repair jobs but haven't heard back yet, though given Melvin didn't hear anything for 5 weeks I am not surprised. I am also a bit shocked, and very unimpressed, that they have taken down their phone number, seems counter productive. I'll wait a few more days to see if I hear anything further from them, fingers crossed.

  • Yeah good luck mate ! Let me know how u get on ! I’ve a feeling this gonna take ages to sort !

  • Yeah I have the same issue now, was playing F1 and everything was ok, after a quick game of ACC I went back to F1 and the steering was all over the place. I connected it to my laptop and it said wheel base V2 not CSL DD and then it crashed and I can’t turn it back on!

Sign In or Register to comment.