FanaLab 1.64.5 - Post your Feedback here



  • edited June 2022

    So far there are only 3 reports of this full device freeze.

    And hundreds / thousands of users where it's working fine.

    You know that only people are complaining when something is not working. When "only" 3 people complain, then it's fine for the majority of other users who usually dont write that everything is fine. There was someone here though who pretty much only plays AMS2 and he doesn't have the issue. I have now played 13 hours AMS2 with BME since Friday without a full device freeze.

    So it's clearly not affecting everyone and therefore most likely the root cause is not really FanaLab but something else.

    Question is just what is causing this... And as said this could be a driver issue, a firmware issue, a communication issue between BME and Hub, a communication issue between Hub and Base or a general hardware issue.

    Is it also freezing completely when not using FanaLab but the native LED and Display integration directly from the game? Or is it ONLY freezing completely when using FanaLab?

    I dont speak for the support or Fanatec in general but I would say you can contact the support at any time so they can analyse affected units. Every bit of analysis will help to find the root cause as nobody internally can reproduce the issue so it otherwise could not be investigated.

  • edited June 2022

    I can understand your position even if I'm not completely agree with 😉.

    "Is it also freezing completely when not using FanaLab but the native LED and Display integration directly from the game? Or is it ONLY freezing completely when using FanaLab?"

    At this question, here what I can say : Freezes happens only when fanalab is running and only on AMS2 and with an extreme majority of times while using ITM (no matter the page or auto-switch feature settings, that's why as users we often suspect a fanalab issue). Playing with disabled ITM will mostly solve the issue.

    This issue is present from previous drivers/firmwares (for the time I bought the PBME 6 months ago)

    I'll be curious to know if others users who report freezes are in that pattern.

    Hope this help !

    "I dont speak for the support or Fanatec in general but I would say you can contact the support at any time so they can analyse affected units. Every bit of analysis will help to find the root cause as nobody internally can reproduce the issue so it otherwise could not be investigated."

    I'll probably take the time to contact the team to see what I can bring to help (logs or other things) 😏

  • bringing this back to confirm that this is mostly not working. Was in a race yesterday, and the "position" telemetry is set to "C", the screen shows nothing, then randomly all of a sudden it shows me I am "P05" and then 30 seconds later the screen goes blank again...

  • edited June 2022

    That is a limitation of the iRacing Telemetry API.

    Dont know exactly but It either only updates the position every sector or even only every lap but not in realtime.

    Nothing FanaLab can do to show the position in realtime.

    Therefore Position or Lap is not really the Telemetry data which should be used as "constant" in iRacing, better use Gear or speed for constantly showing and then Position and Lap as Priority triggers.

    The screen btw goes blank after a value on the wheel is shown for some time without changing because that's the screensaver feature to prevent burn-in.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks for the information, then we need to check out page 4 and the telemetry it contains.

    Is it maybe happening whenever you have a new best lap which overwrites a previous one or might it have to do with the distance to other cars?

  • Marcel PfisterMarcel Pfister Member, Administrator

    Does the wheel ever freeze when not using FanaLab/ITM?

  • Maybe. But I've not noticed a pattern - it certainly doesn't always crash on a new best lap and as distance to car ahead and behind is always fluid I'm not sure what the trigger there might be. Hopefully the dev team can identify cause and resolve.

  • Gagaryn .Gagaryn . Member
    edited June 2022


    EDIT: As some are jumping to the assumption that this must be a hardware fault as they have not been able to reproduce, I have contacted support about this in the past. Wheelbase, Podium hub and PBME was all returned for investigation. From memory I think the hub was replaced - the PBME and wheel were returned - assuming no work was done on either. The fact that the lock ups only happen with Fanalab running lead me to believe that the assumption this is a hardware fault is incorrect. I'm disinclined to return all my hardware again though just to have it returned with no modification.

  • Heinz GlanzerHeinz Glanzer Member
    edited June 2022

    V3 with Firmware V1.34

    Connected via USB

    Connected via RJ12

  • I have been driving AMS2 almost exclusively for 2 years now. With the podium DD1, PBME, Porsche Rim and always FanaLab active. In addition, still runs TrackIR5 and Simhub. But a freeze I also never had. 

    However, I do not use Fanatec pedals (Meca Cup1) and also the shifter (MME Motorsport) is from another manufacturer.

  • For me it started 2 or 3 updates ago. I also don't see how it can be hardware related when it works fine without issue on raceroom, rf2 and ACC.

  • Hello,

    I've tried to open Fanalab and it just crashes on startup. I've tried to use the included hotfix but no success. I also uninstalled and reinstalled the driver several times.

    Would appreciate any guidance on how to get it back up and running as I miss my shift lights.


  • edited June 2022

    I have trouble with iracing! i have a dd2 and now I find that if I hypothesize the huracan gt3 to use and load the corresponding profile on fanalab this completely gets me off the steering degrees. I used to set my 1080s in the game before and everything was fine. now as you touch the steering wheel the in-game steering wheel clicks and in a few degrees reaches fonod corsa. the problem disappears if I select the default x iracing one in the fanalab profiles. is anyone in my situation?

  • edited June 2022

    Did you copy-pasted the hotfix exe file into the install directory or did you just loaded the file and tried to start that exe on its own without overwriting the original exe? Thats essential and will fix the issue.

    Alternatively follow the steps given on page 1:

    "Create a new folder named "xml" in the following directory: C:\users\[YOUR USERNAME]\AppData\Local\Fanatec\FanaLab so that afterwards both a "settings" and a "xml" folder are there and then start FanaLab again".

  • Hi Maurice, I have the same issue as Damian described in his post but in ACC as that's the main sim I'm on. I'm on the latest drivers for everything as well as the latest version of FanaLab. This was a big problem for me in previous driver versions and I'm happy to say it doesn't happen nearly as often, but I am still experiencing this here and there.

    I actually just had it happen 10 minutes ago so I came to the forums to see if anyone else is experiencing it.

  • edited June 2022

    @Gagaryn, @Paul Hartl, @Anthony Joulin: the Freezes were investigated more and, as I already thought, there is a "big possibility" that the root cause seems to be in the firmware. The Freezes are just excessed when a lot of stuff is going on (E.g. ITM updates combined with a lot of LEDs) but from the investigations it seems the freeze is still happening because of a firmware issue.

    As Firmware is developed by a different Team than FanaLab, investigations will now be shifted to that Departement who then need to start their own investigations.

    Obviously no ETA when to expect a fix but unfortunately surely not extremely soon as those investigations need a bit of time and now the Summer-break season starts.....

  • Nope still on 440, 442 was not rereleased last time i checked.

    will check dpr channel - but what is it? sorry for stupid questions...

  • edited June 2022

    DPR channel is the DPR (Damper) setting in the Tuning Menu.

    Set it to OFF when you are still on driver 440 and included FW and the issue is gone.

  • Glad that some proper testing has finally been done and that some progress has been made. Strange that it is identified as a firmware issue when you say that the cause seems to be ITM and LED change overload which are both Fanalab functions and but I'll leave that to the experts to resolve.

    Glad we can now stop the speculation that everyone who is affected by the issue has a hardware problem. No surprise that nothing will be fixed quickly - I expect everyone that frequents this forum knows that everything takes an age to fix. Like two years for the new firmware jolt fix which, surprise surprise, introduced its own set of issues. Patience is getting frayed...

  • Hi. I am having this same problem.

    Maybe updating to be able to choose the led color for the flags might be a temporary solution. It seems like something simple to do.

  • Hi, just updated fanalab to 164.5 from 163.6 and now the itm keeps enabling itself every time I start a game. Didn't happen with the previous 163.6 version . Any ideas ? driver is 440

  • Thanks for the heads up Maurice, I was sure it wasn't a hardware issue. I am just glad that it is now confirmed and will be sorted out in due course, cheers.

  • Fanalab Game Profiles launch

    Hi guys,

    Fanalab run automatically the default game profile for games , if fanalab is not runninig???

  • No, FanaLab HAS TO run in the background for everything profile related.

  • Ok Maurice,

    Thanks for reply

  • edited June 2022

    I am trying to add a custom game and I enter all the information and the "ADD" button never becomes selectable. Please help! Let me know if you need me to share any other details. I have just updated to this build of Fanalab and it still won't work. Thanks!

  • edited June 2022

    You forgot to add the Exe detection where you have to direct FanaLab to the correct Exe so it gets recognized when you load that exe file.

This discussion has been closed.