CSL Elite Pedals V2 Brake pedal not working! Reached out to support but not sure if it went through.

I've only had the pedals for about a week and a half or so and I went to play some GT7 today and noticed it was reading around 20% brake input when I wasn't even touching the pedal. I then plugged it into my PC to recalibrate it and then the brake pedal just stopped registering input.

I then unplugged the pedals from the wheelbase and unmounted them from my rig to plug them in via USB to my PC, then update and flash the firmware but it fixed nothing. I unplugged the brake pedal from the pedal box and plugged it back in and still nothing. The load cell seems to have stopped working entirely. I let it rest for a while and tried it when I woke up in the morning and it was still not working.

I reached out to Fanatec support, attaching a video but I received no confirmation that my support request had gone through.

Anyone else with V2s had any similar issues or maybe guidance? Any help would be appreciated :)


Sign In or Register to comment.