clutch pedal

i got a set of pedals the clubsport v3 and are working fine, i bought a new direct wheel base from fanatec plugged in my pedals and the clutch pedal doesnt work properly. tried to get in touch with fanatec and they are no help. i just want to tell you all fanatec are a waste of space. all my pc stuff is fanatec which i thought were the best, but i wont be buying from them again. nobody seems to be talking about the clutch or how to solve the issue


  • What do you mean "doesnt work properly"?

    Have you calibrated the pedals again?

  • yes i did and when i go to test them my brake is working it shows the red line and the acceleration is the same but the clutch doesn't show anything, but i stripped it and cleaned them the magnets on the sensor. on utube it says maybe the magnet is back to front but i took it out cleaned them and it right. i also connected my pedals directly to my pc and still not working correctly. but thanks for replying

  • i did not get any help to fix my clutch pedal, but i took my time and worked how to fix the clutch pedal myself. if anybody needs help let me know and i tell them what i did

  • I have a CSL DD 8Nm with CSL Pedals. After updating firmware, driver v454 and fanalab v2.01.12 games recognize clutch as a button instead of pedal. There is no traveling in games but on Fanatec APP it works just fine. Couldn't find any solution for days. How did you fix it?

Sign In or Register to comment.