V3 Pedals not detected in Win10! Pleeeease help

Carl HermezCarl Hermez Member
edited April 2020 in Pedals

Hello everyone,

I'm desperate for some help as I can't get this to work. Quick recap of my situation, I run a CSL Elite (2017), Formula Wheel and V3 pedals. I previously had this kit installed on my gaming PC (Win7 Pro), had a lighting strike hit the house and obvious power surge about 18 months ago. The PC was a total loss along with tv's and such, surge came in from the cable box (digital tv and modem assembly). I had not built a new tower until a week ago, custom -MSI Z90A carbon MOBO-I5 9600k CPU-twin NVIDIA 1070 GPU and Win10, no choice on the OS with modo compatability...

At the time of the surge the insurance company sent a crew to come in and collect the items to assess the damages, the pc was totaled but they sent all the Fanatec gear back and said it was ok. Made nothing of it and left everything in the box until last week, bored out of my mind with the stay-at-home orders so I built a new rig!! The wheel base was acting weird and after a few exchanges with Fareed from customer support, very nice guy BTW, we convened the the PCBA on the wheel base was defective and needed repair, I sent that out to the Cali repair center today and waiting for an estimate. The pedals however are ok but I can not for the life of me get them to work in Win10. I've tried EVERYTHING I could think of, all proposed drivers 328-340-356, power save options, USB drivers and now I'm out of ideas. I've proof tested the pedals on my work laptop (Win 7 Pro) and they work perfectly, updated fine, calibrated, perfect: working.

They are not detected by Win10 for some reason, no audible sound when connecting, no displayed errors for undetected devices, nothing. I'm new to Win10 so I'm sure it's a config issue, hating it BTW, can anyone offer anything... PLEEEEEASE I'M DESPERATE AT THIS POINT! ;0(((




  • If the pedals connect fine on a different PC and not on the Win10 PC, with no USB connect sound, I would suspect a USB port issue.

    Does a different USB device connect properly to the same USB port?

    Did you try different USB ports?

    Did you try a different USB cable?

  • Hey Remco,

    Yes, I've tried multiple USB 2.0 ports and even 3.0 even if they're considered problematic. Other devices work fine in any of the ports just not with the pedals. Not sure if its a question of voltage supply when the device is connected...

  • That's a strange issue for sure. Maybe you could start with this tool, to see if there's anything funny with your USB ports and/or driver: https://www.majorgeeks.com/files/details/microsoft_windows_usb_troubleshooter.html

    I guess you did try different USB cables with the pedals as well?

    For diagnosing USB voltage issues, I myself have a USB meter like this, if the problem persists then maybe you might consider getting one:

    Maybe it's a sign of the pedals' PCBA having been damaged in some way after all, and your new PC is more sensitive to it than the old PC. Do you have a third PC you could test on?

  • Hey remco,

    I've had the same issue and tried 2 windows 10 PCs and still they re only recognised on a windows 7 for some reason.

    All USB ports 2.0 and 3.0 accept any other devices including cswv2 base.

    Very strange issue indeed

  • Maybe one of the mentioned fixes in this article helps? It's not exactly the same problem I think, but maybe one of the mentioned possible solutions does the trick.

  • Dominic BrennanDominic Brennan Member, Administrator

    This could be related to a recent Windows update, we're seeing a few reports about this. I suggest running the Fanatec driver installer and using the Repair function. If that doesn't work, please read this thread: https://forum.fanatec.com/discussion/1758/symptom-fanatec-driver-does-not-install-uninstall-correctly

  • I have tried the solution on that forum with no success

    How do I use the repair function in the fanatec driver?

  • Carl HermezCarl Hermez Member
    edited April 2020

    Hi Remco,

    Thanks for the input, after confirming all usb ports and drivers check out and are problem free. Yes I have tried many USB A/B cables and actually ordered 2 more which are scheduled to arrive today, I'll obviously give them a go... I agree there might b something with the PCBA, although unlikely considering the fact everything runs good in Win7, hopefully the Service Center calls or emails me when they diagnose the wheel base and I can ask them to also send me a replacement... I'll get another laptop from my office and test just to be sure. Again the problem isn't recognition, the device isn't even detected so it's like it wasn't even connected.

    Hi Dominic,

    Thank you for jumping in to this! Like Brenton mentioned, "Repair" isn't an available option in the Apps & Features only uninstall, is there another way to do this that I don't know about? I did complete the steps in the link you suggested but only till step "5) Right-click the Fanatec device and select 'Game controller settings':" the controller isn't visible as Win10 doesn't detect it. I've also tried "Reset to default" on the working Win7 pc but it wasn't clear if the reset was completed successfully, no confirmation or evidence clicking the actuation icon has done anything.

    FYI: I did download the Win10 install data directly from the Microsoft website about 7-10 days ago so I can only imagine that the latest updates were applied directly to the image I used. Wait a minute, that might be to smart for Microsoft, I have no idea!! ;0)))

    If it is a Win10 update issue, do you anticipate a correction driver rollout to be in days, weeks, months? I ask simply because otherwise I could TRY and find an older install ISO and do fresh setup and not update!?!?

  • Carl HermezCarl Hermez Member
    edited April 2020

    Dominic, after your input I decided to try and manually roll back the updates that were applied and was only able to remove 4. I tried to connect the pedals again but still nothing. These are the updates I was not able to remove:

    Hopefully this gives someone a starting point...

  • edited April 2020

    Did you try to uninstall the Fanatec driver completely, reboot, and then connect the CSP v3 to see if that results in any connection? Because if that doesn't work either, it's definitely not related to the Fanatec driver.

    Regarding the driver repair function, that is not available in the Apps & Features menu in Win10 (only in Win7), you'll have to run the Fanatec installer (the Fanatec_xx_driver_yyy.msi file) and then you'll be given the option to uninstall or repair.

  • Remco,

    I had not tried that, I agree it makes complete sense.

    So, in Win10 I still get absolutely nothing when connecting with drivers removed, no sound, no unidentified device. Tried the exact same thing on the Win7 laptop and I get a connection, it's even identified in devices as Fanatec ClubSport Pedals with logo and as an HID-Compliant game controller. Windows loads Microsoft Driver 6.1.7601.24386 from 6/21/2006 and test and calibration work correctly, obviously not as Clutch-Brake-Gas but responsive in the X-Y-Z axis.

    Repair function yielded the same result, no detection.

    At this point I think I'll try and install a VM in Win7 and see what happens I guess... If that works then it surely will be a Win10 update issue as Dominic suggested but I will take no chances and have the Service Center sell me a replacement PCBA for the V3s.

    Will let you guys know how the VM test plays out...

    Thanks again!

  • Thanks for keeping me updated carl, seems like we have the exact same issue.

    Let me know how you go :)

  • Hi Carl,

    I tried your idea if installing a vm running win 7. Again the pedals were completely unrecognised, yet every other devices were fine.

    Seems like it could be the PCBA that is the issue

  • Maybe your win10 delivers just a bit less voltage on the usb ports, and your CSP v3 PCBA has been affected by the power surge after all, or maybe not and your win10 pc's mobo is just a bit weird :)

    I would suggest to contact Fanatec Support and discuss whether you can get/buy a new CSP v3 PCBA to test.

  • Carl HermezCarl Hermez Member
    edited April 2020


    So, Win7 in VM was a fail because of multiple incompatibilities with system drivers so I quickly abandoned that project since it would have been inconclusive and more of a headache than anything else.

    I decided to do a fresh OS install using an older version of Win10, build 1809, without applying updates but unfortunately this still didn't fix the issue.

    I agree with both of you that the PCBA is probably at fault here but I had to run these tests to know for sure. Because of my nature and professional background, I am very curious to also test it with the pedals connected thru the wheel base as I believe it would regulate voltage in this case?!? I don't know what the wake up sequence is when an actual device is connected to USB and what happens during the handshake...

    My only question now is why would Brenton and others also be experiencing the same issues, do you have the same problem whilst going thru the base or only in direct connection?!?! I would imagine many if not most users are connecting as a package and not stand alone pedals as I'm doing now.

    Dominic was mentioning a rise in similar cases, I'd be intrigued for demographics on those?

    As I said I'll definitely reach and have the Service Center send me a PCBA when they return the wheel base which won't take to long I hope... :0((

  • I actually can't get my pedals working through the base with an rj12 cable in windows 7 or Windows 10

    I'm wondering whether the previous owner had damaged the pcba in someway and that's caused a similar issue to perhaps the lightning you had.

    I actually just purchased a new pcba before. Finally got in contact and they agreed I could buy a new one. Fingers crossed this is the last of it. Been too many headaches for one week!!

  • Morning Brenton, ohhh I didn't know that you couldn't connect thru rj12 in Win7 or 10, interesting.

    I guess it's surely the board in that case, anxious to get your feedback. Just for fun, how much did they charge you for the replacement parts?

  • It came to $57 Australian dollars including shipping, cheaper than I expected to be honest.

    So if you're in Europe, I assume shipping will be less :)

    Il keep you updated in regards to the pcba.

    If you happen to find a solution without it, is love to hear what you find.

    Happy easter

  • Carl HermezCarl Hermez Member
    edited April 2020

    Brenton, I'm in Canada at the other end of the commonwealth! My wheel base is at the US service center in California I FedEx Air shipped it with and included the return waybills cause I want this here ASAP!! Good to hear the part was reasonably priced.

    Will definitely keep you posted...

    Happy Easter to you as well and stay healthy!

  • The CSP can be connected through USB or through the wheel base (but not both at the same time!). Both connections have their own circuitry, so it is possible that one doesn't work (e.g. has been damaged) while the other does. There are some functional differences between the two methods (as explained in the manual), but otherwise there is no significant performance difference.

  • I'm extremely happy to report that after both pedal and wheelbase PCBAs replaced everything is installed and working correctly.

    Thanks for everyones help and hopefully you're all sorted as well Brendon!

  • Hey carl,

    My PCB board arrived yesterday and after spending last night replacing it I'm also happy to say that everything is working as it should!

    Thanks again and happy racing

Sign In or Register to comment.