Fanatec Driver installation Windows 10 ARM

Had some issues with my LC's calibration so I had to get Fanatec Driver to recalibrate, I'm running a M1 Pro Macbook with Parallels and Windows 10 ARM (21H1). I can't get the Driver to install properly, keep getting the error message "There is a problem with this Windows Installer package." (Screenshot below).

Tried several versions, 423, 410, 402, no dice. Fanalab installs w/o issues. Tried with and w/o wheel plugged in, can't seem to get it through. Had to revert to my Mid 2012 MBP and Parallels with normal 64-bit Win10, where it installed first try, unless its a problem with just this Virtual Machine, Parallels should work. So my question, will this work on an ARM Windows? It should run it fine with its own emulation, anyone have any experience with this?


Comments

  • I would love to know if there is a answer to this also? Im trying to do the same.

  • edited November 2021

    +1 I was having the same issues running parallels windows 11 arm, and I got the same error in crossover too. However, in crossover, I was able to get it to run by using a 32 bit bottle... the only problem being that I couldn't get any of my games to run in this 32 bit bottle.

  • Same problem here. I recently replaced an Intel-based Mac with Bootcamp, but now must run Parallels with Windows 11 ARM. Is there a solution for us?

  • Same issue here. Hope someone has resolution soon for us to try. Thanks.

  • Same problem and still no answer...

    Please Fanatec, we are so many players with the issue and we need a solution.

  • edited December 2021

    +1 - also having the same issue. Would be perfect to have a solution to fix that issue. Thanks in advance.

  • Rob FordRob Ford Member
    edited January 8

    +1 I have the same issue. No physical PCs in the house so virtualisation is my only option for updates. Any news or workarounds been found?

Sign In or Register to comment.