HELP! Can't calibrate DD Pro in IRacing

So let me start by saying I am no computer genius so I apologize in advance. I did search for this issue and was unable to find a solution, so here I am.

Just purchased a DD Pro to use in IRacing on my PC. I have the current driver, Firmware is current as well. In the Fanatec software, the wheel is smooth watching on the screen from left to right on the scale bar. Once I load the recommended settings into the Fanapro and go into Itunes, I go to the options to calibrate the wheel there. Everything is super jumpy. When the wheel is at rest in center, it shows all the way to the left. I rotate left to right in the calibration screen and it is super jumpy and notchy and wont calibrate as I should. I get an error saying it requires two axis. I messed around for hours with no result. PLEASE HELP! I cant be the only one this is happening to. Thank you in advance!


  • Update.. Seems as if my pedals and steering wheel are fighting each other. If I unplug the USB for my pedals (simjack), the wheel calibrates perfectly and works as it should. As soon as I plug the pedals back in and try to calibrate them, they wont calibrate and the steering wheel goes back to freaking out. If I unplug the wheel, then the pedals are fine until I plug the wheel back in. Has anyone seen this? During calibration of the steering wheel, if I press the throttle, the calibrate bar moves. So they are for sure over-riding each other. PLEASE HELP!

  • There is one thing I always write when I read about a crazy DD. I try to explain why I am not an English speaker.

    There are 3 items in your setup.

    Wheelbase, you can replace it with another model, but that's expensive.

    Pedals, you can replace them with a different model, but this is also expensive.

    PC, you can replace the PC, but it looks even more expensive.

    Luckily, you can try tweaking your PC just enough to fool two others.

    Go to Amazon and order a PCI Express card with extra USB ports. I bought an Inateck model for 20 € and it solved my problem. Connect the wheelbase to one of the new ports and pedal to old ports. If it doesn't work do the opposite, if it still doesn't work connect both to the new board.

    If it still doesn't work, put the card back in its box and get a refund from Amazon, or keep it and agree to have a few more USB ports on your PC.

    If you don't want to put your hand inside the PC, there is a small device called a USB isolator. It might work. Always on Amazon, always 20 €, always to be returned if it doesn't work.

    Or buy some ferrite clips to attach to the usb and power cables.

    However, I recommend the first solution.


  • Awesome! Thank you for your help!!!

  • Update..

    So it was basically all interference. I ended up using a better surge protector to plug everything in, ran the USB cables into opposite sides of the machine and I used rubber washers between the pedals and the wheel base to insulate them from my rig and everything is working great as of right now

  • Very good.

    You've isolated everything.

    I did the opposite, I connected all my rig to the ground of my electrical system with cables.

    Both ways work.

    All these weird things that happen are interference. The wheelbase is a big motor, the pedals and many shifters have magnetic sensors, and the USB ports on our PCs and consoles are sensitive to eddy currents.

    But these tips should be given to us by Fanatec customer service, not to ask for useless and very long RMAs every time. A lot of these problems are caused by EMI, no wonder their customer service is on the verge of collapsing, if they don't know how works, the things they sell.

Sign In or Register to comment.