New Podium hub + PBME not recognized


I just got the Podium Porsche 911 GT3 bundle wiht Podium Hub, APM and BME

But Fanatec Control panel does not recognize that a wheel or button module is atached to my Podium F1 DD1 wheelbase.

PC Driver 447


Wheel Base:

Wheel Base Motor:

Wireless QR: 6

Base is in PC mode, i have turned the base of numerous times with and without the wheel attached, but it's never found.

My other wheels, RD, F1 2.5, Universal Hub v2 are all recognized just fine.

Any ideas ?


  • I had this issue with my new podium this week. While it's still plugged in to the pc remove the v2 rim and replace. Hopefully the podium will ask you to confirm something by pressing x on the wheel. If this happens you should be able to confirm the remaining functions of the wheel and attached devices. Good luck.

  • It ended in a support ticket and it's being sent back for repairs.

    I have tried this:

    • Downgrade firmware via options in newest 447 driver, on both base and motor, and upgraded back to newest again.(have tried multiple versions)
    • Recovery mode firmware flash (power button 8 sec into auto firmware flash)
    • Re-install latest driver on seperate PC, uninstall, reinstall, several times on both
    • Swap wheelside QR1 from existing well functioning ClubSport RS wheel.
    • Unplug base-side quickrelease-stem, unplug /replug the cables, and tighten it up, making sure to press the stem all the way in, to allow the QR1 to reach with the wheel's pins.

    Even after all this, the ClubSport Universal Hub v2 has these symptoms:

    • Continues to only work 75% of the times i power on the wheelbase.
    • For the remaining 25% of the times, It will either freeze the base display, and not show up on the PC, even thoug the wheelbase and pedals etc show up fine. or:
    • Show the error message: "Warning Steering Wheel not supported! "Please update the firmware"
    • Firmware is shown as "1" and up to date in the firmware update status in Fanatec Control Panel.

    The Podium Hub with BME and APM has these symptoms.

    • No wheel connected in Fanatec Controlpanel
    • No contact with base, no reaction from tuning menu, or anything
    • Unplugging the BME does not improve or otherwise change anything. 

  • My Black Friday bundle Podium Hub behaves exactly the same way.

    The Podium Hub with BME and APM has these symptoms.

    No wheel connected in Fanatec Controlpanel

    No contact with base, no reaction from tuning menu, or anything

    Unplugging the BME does not improve or otherwise change anything.

  • Hello.

    Does anyone have a solution to this problem?

    I will receive my podium hub tomorrow. I'm afraid in advance that it won't work with the dd1 base.

  • Nothing you can do except test and verify if you have this issue... Mine is already back in Fanatec....

    Poor quality test since there was a lot with this issue or similar

  • The universal hub v1 and v2 as well are simply not made to work with the Podium F1. Every time I read the same here. Mine doesn’t work too. On the CSW 2.5 no problem. I think after RMA, Fanatec test it on the CSW 2.5 and that’s why they say that it is working fine. They will not recognize the problem at many of their customers. If they continue like this they will many customers.

  • I just posted a thread asking for help before finding this one, and it sounds like I'm having the exact same problem - other wheels work fine but the podium hub with BME and APM aren't recognized at all.

    Support have asked me to send in both my hub and my wheelbase for inspection and repair, but sending the whole wheelbase in seems overkill - has anyone had success with just getting the podium hub replaced?

  • Seem to be having the same issue... Podium Hub not recognized by F1/DD1 wheelbase. The Podium F1 wheel is recognized and actually the Podium Hub is recognized by a GT DD Pro wheelbase I have on hand before upgrading to the Podium F1 wheelbase for Black Friday.

    Based on this sequence of testing for me, seems like the Podium F1 and not the Podium Hub is the issue, which I agree, would be inconvenient to send back considering the size. By now and judging from the number of people having the same issue with Podium Hub and Podium F1/DD1, I would hope Fanatec are able to pinpoint the issue and come up with a targeted fix...

  • I have the Same Problem. I will contact fanatec tomorrow

  • Update: Fanatec RMA both the Podium F1 wheelbase and the Podium Hub... Tried explaining that the hub works on a different wheelbase (GT DD Pro), but they seem to want both parts back. Kind of inconvenient taking apart an assembled wheel and modules, but ideally everything comes back in working order...

  • Any update here? How long did they have your wheelbase for? Did it work when it come back?

  • same issue. I really DO NOT want to send the base to Fanatec...

  • Sorry to say, you are most likely going to have to send it back. I opened a support case and went through a bunch of testing with support. After that, they had me make a quick video showing the issue. Then they issued an RMA and shipping labels for the Podium Racing Wheel F1 and the Podium Universal Hub. I did not have to send the ClubSport Pedals in. I boxed everything up in the original boxes and shipped them to Fanatec. They are currently there for repair. I will update the outcome once I have the units back.

  • Looking forward of your feedback. I issued a support case, too. They didn't ask me to do any test or videos, so they know this issue. But they said it is still under investigation. I'm wondering whether they can fix it.

  • Here's an update on the situation. My units went to California and I received no communication about what they were doing, what tests were run, etc. Last week, I randomly got a notice from FedEx that two packages were shipping from Fanatec. Packages delivered yesterday and I opened them up. They sent out a brand new Podium Hub and a brand new Podium Racing Wheel F1. New in box, serial numbers totally different from what I sent in. I checked the numbers against what I had on file and the new wheelbase is about 2,000 production units later in production than what I originally had.

    Now for the test. I starter by testing out the F1 wheel that came with the wheelbase. Works great, no issue. I shut the wheelbase off, removed the F1 wheel and swapped on the Podium Hub and PBME. Fired up the wheelbase and all was good. Then I tried hot-swapping. I can pull the Podium + PBME off and put the F1 wheel on and it works great. When I tried to go hot-swap back to the Podium Hub + PBME...nope...doesn't recognize. Turned the wheelbase off and then back on and it immediately recognized the Podium Hub + PBME.

    Soooo...I'm calling this a 75% win. My Podium Hub + PBME now consistently works and is recognized by the wheelbase BUT it is not hot-swappable which (I thought) was supposed to be a feature of Fanatec's ecosystem. I'm glad I at least can use both wheels, but Fanatec really needs to figure this out. Completely unacceptable at the price point this is at.

  • Hi David, thank you for your feedback.

    It's good, but not perfect. It seems like they didn't found the root caust of this problem.

    Are the parts they sent to you totally new? I know they are new ones according to serial number. Do you think they already test the "new" parts?

  • I know this thread is a bit old. But, I've been searching for an answer and the internet brought me to this thread.

    I have the Podium F1 bundle. When I got it in early December I got the base up to date. Also the F1 wheel up to date. Then plugged in my universal Hub V2 and everything worked fine.

    After about 2 weeks of daily iRacing it simply stopped recognizing it. (the universal hub) says there isn't any wheel connected. The first thing I did is put the F1 wheel that came with it back on. It turned on after cycling the power on the base.

    I've been using the F1 wheel ever since. But, it made me crazy that the universal hub wouldn't work. I like that wheel better. (its the alcantara D shape wheel)

    I decided to plug my old CSW 2.5 into another computer and load the Fanatec software. long story longer the universal hub showed up no problem. All buttons and functions worked like they're supposed to.

    I then tried putting the wheel back on the DD1 thinking maybe I tricked into working. : ) Nope. it simply acts like there isn't a wheel connected.

    Doing a whole thing with reverting drivers and firmware isn't really a thing I wanna mess with and take a chance on having nothing work at all in the end. : (

    Is there any proven semi easy fix for this?

    Thank you for any input.

Sign In or Register to comment.