PLEASE HELP CSL pedals not working after adding LC

I will do my best to keep this short. Also, I know there have been some other posts somewhat similar to my issue but they were posted some time ago and don't represent my issue exactly. Here goes:

So, I bought the CSL two pedal set. They worked great, I should have left it at that but I decided I wanted the load cell. Once I received the load cell, I installed it. Everything worked great.

About a month later the LC just quit. Nothing changed, I didn't touch it. One day I just started up my PS4 and the LC didn't work. So I dismounted my pedals, trying to locate an issue. I never found anything wrong but when I hooked it all back up, the LC was working again.

This went on for a few weeks, where the LC would work, then not work then work again. After about a month of mounting and dismounting the pedals, I decided I no longer wanted to use the LC. So, I took it off and went back to the 2 pedal setup I started with. That was 7-8 months ago and I was the using the 2 pedal setup ever since.

That is until I spoke to a friend. He mentioned that the issue with the LC may have been my fault, as I may not have updated the firmware. While I could vaguely remember doing so, it was 8 months ago so I couldn't be sure. As a result I decided to check for a firmware update. There was an update, so I installed it. In order to even get the update, that meant my PC had to acknowledge that the LC was present. So the PC agreed that a LC was connected to it.

I get the update done, and I update the driver to 447 and any firmware updates available for my DD pro base were installed as well. I didnt even think to test pedals, I just disconnected them from my PC and back over to the PS4. Gas pedal worked....LC did not. After screwing around with it, making sure everything was connected correctly for about an hour. I gave up. I decided after all that, I will just go back to the two original pedals (again).

So I disconnect the LC. Now I can't utilize the PC because the CSL pedals (without the LC) don't connect to the PC. So, I connect them back to the PS4, without the LC. Simply connected the gas pedal to the brake then the DD pro to the gas pedal. Now the non-LC brake doesn't work either. In conclusion, by updating the LC firmware and trying it again, it somehow seems to have destroyed the non-LC brake as well.

I'm not and engineer by any stretch but I am computer and electronics savvy enough to know that the connection process is a simple one, where it would seem, not much could go wrong. So how has some much gone wrong? And why does a LC pedal that was purchased brand new, for a decent amount of money only function correctly for 1 month and how could it brick other pedals in the process. This shouldn't be this complicated and for what Fanatec charges for their products, they should work. Has anyone else gone through this? Is there a simple solution I am missing? I'm really at my breaking point with this set up. If you read all of this, thank you. Any assistance or insight would be greatly appreciated.

Sign In or Register to comment.