CSL Load Cell Stopped Working

Today was really the first day that i had the time to dedicate a few hours to trying the set up out. I had a couple of hours maybe mid afternoon, and all was working well, as it should or as far as i could tell. Then tea time came around, took the dog out a walk and returned to switch the CSL DD on. Managed a 15min race at Monza. 15Min at Paul Recard, then went on to Zandvoort and about the last 5 or so minutes of the 15 min race, i was going straight on, thinking i was doing something wrong, hitting Clutch instead of brake (Load Cell). This occured a few more times, not stopping, going straight on, so i called it a day/night. Open Fanatec Control panel. Pedal tab and checked Accelerator, working. Checked Clutch, working. Tried Load Cell......NOTHING. Tried the manual force firmware, didnt do anything I also updated the load cell on unboxing and the firmware manager concurs that it is the latest version.

Quick search online, and between Fanatec Forum, Redit etc, this seems to be a knowen issue? I only received the Base, wheel &pedal bundle on 14 August. 5 days old, no more than 5 hours of use and i can no longer use it.


  • On initial set up, i followed Will Ford, Boosted Medias video on the correct connections. I assume it was right as it has been working ok, apart from whatever happened earlier on this evening.

  • Allan LehtlaAllan Lehtla Member
    edited August 19

    how about the throttle pedal? i needed oil that like one day after first usage, it started make funny sound what i never hear before in my 20 years off experience at sim racing at different wheels.

    i skipped buy the Load Cell because i have also other pedals. sounds like i todo right choice.

    some say that you need ground the pedals for avoid static electrics, maybe that what is caused your issue, dunno really.

    you to still have warranty aswell if you not figure out self why it not works anymore.

    no one can help you about this in here as that sounds like hardware issue

  • I saw a post about "Grounding" but this was due to the brake % bar in the Fanatec control panel flickering, if thats the one you were reffering to?

    I have submited a support ticket.


  • static electrics could also burn out devises, its similar like thunder hits something. but i not know if that caused this, it could be that you just had some faulty product

  • Plugged them all back in again and i did notice a flicker in the brake % bar in Fanatec CP, so i tried the "grounding" idea and still nothing. Pulled the Load Cell off the Base plate and put the standard brake back from clutch to brake and it is working. So something to do with the LC Pedal i think.

    I will try the standard brake for now, if it at least allows me to get used to the DD.

    Thanks for your input 👍️

  • Ended up doind a RMA, sent away on the Friday and returned on the Monday all working.

  • good for you, it sounded like you had faulty product first place

Sign In or Register to comment.