Please help!!

While racing in Iracing (everything worked perfectly) my Steering wheel was disconnected. What to do?

I have a brent new CSL DD and a Podium steering wheel Porsche GT3 suede.

Everything is connected properly and all the latest drivers are installed.

My steering wheel says:" warning Steering wheel no supported! Please update the Firmware"

When I do update the Firmware, the countdown starts, 3-2-1 and then 1 second my steering wheel is connected and then it is disconnected.

note: Everything worked fine for weeks.

What to do? Any help is [email protected]


  • Sounds like maybe your wheel isn't securely connected to the base? Make sure that you give it a good, firm shove (it took quite a bit more force than I originally anticipated) once you've got the pins lined up to attach the QR. Also make sure that the QR is securely fastened and that there isn't any excessive play.

  • Thank you Gregg! I did exactly what you wrote and it worked!! I gave it a firm shove and yes, the Wheel was connected again!

    Thanks for your help!

  • Glad that's all it was. Happy racing!

Sign In or Register to comment.