Fanatec Beta Driver V345 for CSL, CSW and Podium Bases (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator
Hello Everybody,

Changelog of V345:
1. Fixed Driver freezes when UHX or UHX+APM gets attached.
2. Fixed manual pedal mode not working with PHub attached.
3. Fixed pedal vibration buttons missing with PHub attached.
4. Fixed CSW V2.5 Tuning Menu parameter SEN 900 degrees and AUT not displaying correctly.
5. Fixed Tuning Menu SHO and SetupID inconsistent output when Map Sequential Shifter is checked.
6. Fixed the button mapping of APM Paddles (Top Left and Top Right) based on PHub Firmware version 2.
7. Add official PHub and PHub+APM image in Control Panel.

Changelog of V344:

A. Driver 
1. Fixed issue that McLaren GT3 v1.0 able to select "ENC" as MPS Mode.
2. Added Tuning Menu settings page to the Driver UI.
3. Added functionality for upcoming products
4. Firmwares included:
   - CSW V1 Base : CSW_Base_V662_rev1681_app     (NEW)     
   - CSW V2 Base : CSW_V2_Base_V662_rev1681_app    (NEW)
   - CSW V2.5 Base : CSW_V2_5_Base_V662_rev1681_app   (NEW) 
   - CSL E Base  : CSL_E_Base_V662_rev1681_app    (NEW)
   - CSL E Base PS4 : CSL_E_PS4_Base_V662_rev1681_app   (NEW)
   - DD Base  : PDW_DD_Base_V662_rev1681_app    (NEW) 
   - EBLDC   : CSLEWBPS4_CSWBV2.5_EBLDC_V22_rev335_app 
   - EBLDC DD10  : PWBDD1_EBLDC_V30_rev356_app    
   - EBLDC DD20  : PWBDD2_EBLDC_V30_rev356_app    
   - RMCL  : RMcL_V30_rev38_app       
   - RFORMV2  : RFORMv2_V28_rev113_app
   - PHub   : SW_P_Hub_V1_rev113_app
   - WQR   : PWBDD_WQR_V6_rev65_app

B. Firmwares:
- Podium DD: Reworked Power Button behaviour
   FFB dis-/enabeled by short press <1sec
   >1 second press switches base off (with message on display)
- Added functionality for upcoming products

Known Issues:
  • Some with 4k resolution or changed DPI / Zoom settings might have a wrong view of the Tuning Menu page. We try to solve this for the next version and are still investigating so feel free to send us feedback about it. 
  • Sorry the "notchy" issue of CSW V2.5 and CSL E PS4 which some testers experienced is still under investigation and couldn't get fixed yet. I've attached motor firmware V20 which has less coil whine than V18 and less notching than V22 according to some testers. 
If you report a driver or firmware issue, please make cross checks:
0. Update driver and FW separately to isolate an issue. Most likely it will be driver OR firmware.
1. Which driver OR firmware does show the issue
2. Which driver OR firmware does not show the issue
3. Check if you can reproduce the issue again if you go back to the version which seems to have cause the issue
4. Post the answers gathered from the questions above + a short description of the issue including the following information:

Wheel Base Model (product ID): ....
Steering Wheel Model (product ID): ....
Driver Version: ....
Base FW Version: ....
Wheel FW Version: ....

Thank you very much!

We hope for your positive feedback! 
«134

Comments

  • When going from Tuning Menu Page back to Function Test I still experience freezes sometimes. (Windows Shell Common DLL has stopped working error message pops up).
    DD2 with Driver 345 and FW 662, happening with all kind of wheels.
  • If I update the driver on. Do I need to unistall it first or can I just install it over the current folder? Just something I thought bout. 
  • What I recommend for both the BETAS and the officers is to uninstall everything, restart the PC, install the new BETA and finally restart the PC. It's how I do it and I make sure I won't have any problems. Regards! :D
  • Thank you. Test mode activated! 
  • edited September 2019

  • Rinus HuismanRinus Huisman Member
    edited September 2019
    Wheel Base Model CSW 2.5
    Steering Wheel Model: CS Formula Black
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version: 20

    Tjhe chirping when turning is lots less then before, even the FFB even feels better in rFactor 2. It's amazing. Also I've now is that I cannot calibrate my wheel with the 2 buttons anymore. I've to use the button on the driver page.

    I think there's something wrong in the code that communicates with the dampening/drift mode or so. Cause I am sure the noise when turning the rim is an driftmode issue. 

    Good work. 

    Edit: Oh no. My tinnitus is now repeating that chirping sound. lol. 

  • F**K! Still the same problem! I wonder if any one @ FANATEC reads the thread at all ...No one from FANATEC has given my advise or help here anyway.

    I had the same problem with my CSL Elite once before.... With the DD1 it´s every single time! COM3 Error ... Can it be that I have to move the USB around untill I manage to find COM3?? Or is there something wrong with the DD1, set to "read only" or something?


  • edited September 2019
    F**K! Still the same problem! I wonder if any one @ FANATEC reads the thread at all ...No one from FANATEC has given my advise or help here anyway.

    I had the same problem with my CSL Elite once before.... With the DD1 it´s every single time! COM3 Error ... Can it be that I have to move the USB around untill I manage to find COM3?? Or is there something wrong with the DD1, set to "read only" or something?


    You got an official answer in the driver 344 thread to contact the support because base to motor communication seems to be broken and needs a repair from the service
  • Wheel Base Model: Podium Racing Wheel F1
    Steering Wheel Model: McLaren GT3
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version 30

    After updating the PC driver to 345 and the latest FW to the Wheelbase, iRacing won`t recognize my hardware and shows the message "Failed Tech"


  • Wheel Base Model: Podium Racing Wheel F1
    Steering Wheel Model: McLaren GT3
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version 30

    After updating the PC driver to 345 and the latest FW to the Wheelbase, iRacing won`t recognize my hardware and shows the message "Failed Tech"


    Make sure you changed back to PC mode because after Firmware Update it auto-defaults to Xbox mode when using a Xbox compatible Wheel like the McL.
  • Wheel Base Model: Podium Racing Wheel F1
    Steering Wheel Model: McLaren GT3
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version 30

    After updating the PC driver to 345 and the latest FW to the Wheelbase, iRacing won`t recognize my hardware and shows the message "Failed Tech"


    Make sure you changed back to PC mode because after Firmware Update it auto-defaults to Xbox mode when using a Xbox compatible Wheel like the McL.
    Yes, i recognized that it automatically switches in XBox-Mode. I started iRacing in PC-Mode and it still shows that message.
  • Wheel Base Model: Podium Racing Wheel F1
    Steering Wheel Model: McLaren GT3
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version 30

    After updating the PC driver to 345 and the latest FW to the Wheelbase, iRacing won`t recognize my hardware and shows the message "Failed Tech"


    Make sure you changed back to PC mode because after Firmware Update it auto-defaults to Xbox mode when using a Xbox compatible Wheel like the McL.
    Yes, i recognized that it automatically switches in XBox-Mode. I started iRacing in PC-Mode and it still shows that message.
    okay, I see now. Failed Tech means that your Setup failed to verify tech for that track. This has nothing to do with either FanaLab or Fanatec in general. Try a different in game setup and it should work.
  • Wheel Base Model: Podium Racing Wheel F1
    Steering Wheel Model: McLaren GT3
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version 30

    After updating the PC driver to 345 and the latest FW to the Wheelbase, iRacing won`t recognize my hardware and shows the message "Failed Tech"


    Make sure you changed back to PC mode because after Firmware Update it auto-defaults to Xbox mode when using a Xbox compatible Wheel like the McL.
    Yes, i recognized that it automatically switches in XBox-Mode. I started iRacing in PC-Mode and it still shows that message.
    okay, I see now. Failed Tech means that your Setup failed to verify tech for that track. This has nothing to do with either FanaLab or Fanatec in general. Try a different in game setup and it should work.

    #-o sorry, my fault...
  • Bug report

    Driver: 345
    Wheelbase: DD1 FW662
    Motor FW30
    Wheel: F1 2019 FW28

    After swichting on the Wheelbase, there was no reaction on quitting the warning message for high torque mode (no reactions on any buttons or 90° left steering). Fanatec property page crashed (not able to load). Switching off the wheelbase via powerbutton not possible -> no reaction.

    Disconnected the power supply, reconnected and startet the wheelbase again and anything was fine (base works as usual).

    If you need a video or more informations, just let me know.
  • How do i roll back wheel SW FW on my Formula V2 rim from 28 to 20 ? I have rolled back base FW from 344/662 back to 340/658 but SW FW is still on 28 !
    I installed FanaLab with latest FW but lost all rev lightsa and LED display in rF2 , the only Sim i play so i rolled back but SW FW wont roll back ! 
    HELP !!!!
  • How do i roll back wheel SW FW on my Formula V2 rim from 28 to 20 ? I have rolled back base FW from 344/662 back to 340/658 but SW FW is still on 28 !
    I installed FanaLab with latest FW but lost all rev lightsa and LED display in rF2 , the only Sim i play so i rolled back but SW FW wont roll back ! 
    HELP !!!!
    There was no official FW20 for the Formula v2 Steering wheel. Driver 340 still contains SW FW 28 for the Formula v2, not possible to roll back.
    FanaLab has a known issue with rF2 as you can read in the introduction thread.
    Wait for the next version and rF2 should work fine again.
  • Thanks for the reply , i guess i wait .
  • edited September 2019
    How do i roll back wheel SW FW on my Formula V2 rim from 28 to 20 ? I have rolled back base FW from 344/662 back to 340/658 but SW FW is still on 28 !
    I installed FanaLab with latest FW but lost all rev lightsa and LED display in rF2 , the only Sim i play so i rolled back but SW FW wont roll back ! 
    HELP !!!!
    Click Disable Led support in Fanalab's Game Profile page to disable it and it will be back to rF2 defaults.
  • Great, I will try that! Thanks
  • edited September 2019
    Is it normal that you can't update the firmware of the CSL Elite Pedals LC if they are connected to the wheelbase?
    I had to connect my pedals directly to my computer via USB to find out I was running older firmware.

    Is that the same way it works for CS pedals V3 or do these get updated when connected to the wheelnbase?
  • edited September 2019
    Is it normal that you can't update the firmware of the CSL Elite Pedals LC if they are connected to the wheelbase?
    I had to connect my pedals directly to my computer via USB to find out I was running older firmware.

    Is that the same way it works for CS pedals V3 or do these get updated when connected to the wheelnbase?
    yes, thats normal. You cant update either the Pedals or the Handbrake or the Shifter when they are connected to the Base.
    Also, there are no newer firmwares for CSP v3 pedals available since their release so you shouldnt even try to update the pedals firmware as you would just flash it with the exact same firmware again...
  • So the handbrake and shifter can be updated as well?
    How do I do that? By connecting them to the pedals instead of the wheelbase?

    Or is it also possible by connecting them to the Fanatec USB adapter? Seems easier as all my wires are routed through my stand so I could easily connect the adapter with another wire to the back of the handbrake and shifter.
  • So the handbrake and shifter can be updated as well?
    How do I do that? By connecting them to the pedals instead of the wheelbase?

    Or is it also possible by connecting them to the Fanatec USB adapter? Seems easier as all my wires are routed through my stand so I could easily connect the adapter with another wire to the back of the handbrake and shifter.
    in theory the Handbrake and Shifter can be updated when used with the USB Adapter, yes. But there was NO newer firmware since their release a lot of years ago, same for the CSP v3. It is mentioned in a driver changelog when a new Firmware is contained in the driver, and public this was not the case for all these product for years (in fact, never since their release). So dont waste the time, they all dont have newer firmwares available and most probably never will ;-)
  • Ok thanks Maurice!
    I just started wondering since I found a new update for my CSL Elite Pedals LC.
    Went from v1.8 to 1.9.
  • edited September 2019
    This new driver for the McLaren rim makes the analogue paddles glitchy. As in, they register inputs when no input is given. Tested this with all the other firmwares that come with this driver. I also tested it all the way back to the firmwares from driver 311 (but kept the McLaren RMCL  : RMcL_V30_rev38_app for testing purpose). 

    To make al long story short: the RMCL  : RMcL_V30_rev38_app update makes the analogue inputs on my McLaren wheel glitchy. They register tiny inputs when no input is given.

    Hope this helps you guys to make the Fanatec products even better.
  • Wheel Base Model: CSL Elite PS4/PC
    Steering Wheel Model: CS Formula Black
    Driver Version: 345
    Base FW Version: 662
    Wheel FW Version: 20

    Sensitivity/Wheel Angle AUTO doesn't work in rFactor 2 (Callaway Corvette 410deg, doesn't set to 410 but keeps it at 1080).
    Works in 3.44.

  • Podium DD1
    Formula V2 Wheel
    Driver: 345
    WBF: 662
    WBMFW: 30
    SWF: 28
    V3i pedals connected to the DD1
    SQ 1.5 Shifter connected to DD1
    CS Handbrake connected to DD1

    I have the "Map sequential shifter to paddles" box checked but in iRacing it the SQ doesn't do anything. In the driver Function Test I see a red message that says the SQ  is mapped to the paddles but the SQ still lights the SQ lights and not the paddles. I assumed that the SQ would start sending the paddles controller button #4 & 5 instead of the SQ #28 and 29. I tried mapping the SQ in Project Cars 2 to see what it is sending to a game and it still sends 28 and 29. Is this feature supposed to work? How should it work?
  • edited September 2019
    Podium DD1
    Formula V2 Wheel
    Driver: 345
    WBF: 662
    WBMFW: 30
    SWF: 28
    V3i pedals connected to the DD1
    SQ 1.5 Shifter connected to DD1
    CS Handbrake connected to DD1

    I have the "Map sequential shifter to paddles" box checked but in iRacing it the SQ doesn't do anything. In the driver Function Test I see a red message that says the SQ  is mapped to the paddles but the SQ still lights the SQ lights and not the paddles. I assumed that the SQ would start sending the paddles controller button #4 & 5 instead of the SQ #28 and 29. I tried mapping the SQ in Project Cars 2 to see what it is sending to a game and it still sends 28 and 29. Is this feature supposed to work? How should it work?
    good catch, its also not working for me.
  • edited September 2019
    Wheel Base: CSP v2.5
    Sheel: CS Formula Carbon
    Pedals: CSP v3
    Driver: 345

    So I updated to the 3.45 beta drivers. With that I updated the firmware to both the wheel base and the pedals. Both are plugged in via USB. I have an issue what when I try and open up the driver settings for the pedal, it opens the screen for the wheel base, even they are not plugged into each other. 



    I have been getting this issue which is why it is important to be able to edit the pedals. I was hoping that the new drivers and firmware would fix it. 
    image
  • Wheel Base: CSP v2.5
    Sheel: CS Formula Carbon
    Pedals: CSP v3
    Driver: 345

    So I updated to the 3.45 beta drivers. With that I updated the firmware to both the wheel base and the pedals. Both are plugged in via USB. I have an issue what when I try and open up the driver settings for the pedal, it opens the screen for the wheel base, even they are not plugged into each other. 



    I have been getting this issue which is why it is important to be able to edit the pedals. I was hoping that the new drivers and firmware would fix it. 
    image
    This is an issue since a long time... But, why aren't you connecting the Pedals directly to the Base? If you connect them to the Base everything will work just fine, everything stays calibrated. And you get access to the brake force setting in the tuning menu which is not possible when they are connected by USB... Resolution is the same and you only need 1 USB cable. So to connect them to the Base only has positive aspects
This discussion has been closed.