FanaLab introduction

124678

Comments

  • How many percent processor power does Fanalab need on your PCs? Running with 30 percent with a game on is.... ridiculous.
    Seems to be a bug we have to look into, it never was that demanding. Don't be too harsh it's the first release of a new software, it's not that we on purpose want to make your PC slower....
  • Marcel Pfister said:
    We are always open for feature requests so instead of just complaining it would be nice to get some constructive criticism which contains suggestions. 


    I am not complaining I am just happy you guys are trying to tackle stuff, but I do not like the fact you're trying to re-invent the wheel with the leds, and the dynamic FFB is tricky. However, here's lots of other opportunities that the app can fullfill. I am curious what FanaLab will turn out to be, tho.





  • edited September 9
    still cannot get it to work witj F1 2019 PC edition. CSW 2.5 F1 2019 steering wheel beta drivers installed
    sw keeps saying telemetry data not working

    even after set with both buttons for telemetrie and hardware etc.

  • Hi. I have a Elite PS4+Mclaren GT3 wheel and V3 pedals. I installed Fanalab and in Assetto Corsa I got the leds of the elite base and the vibration motors of the pedals working... but lost the information of the LCD of the steering wheel.

    Anyone can help how to get that back? It's an issue with Asseto Corsa only. It was working at first try but I tried to put the gear displaying constantly and disapeared the LCD information. Already set to default and tried to close Fanalab but the LCD information doesnt show in AC...

    Thanks in advance for any help.
    Did you click on both green buttons of the Game Profile page before starting AC? If you want to go back to using the game data instead of FanaLab you have to click on the red one. If the rev LEDs work I don't see a point why the display shouldn't, maybe you can send some screenshots? What you can do as well is go to settings and then on the bottom click on "View Telemetry Feed" to see if telemetry from the game is received by FanaLab. 
  • edited September 9
    No Support for the CSL Elite...  :(
    unofficially there is support. Only the Tuning Menu is not working on CSL E, CSL E v1.1 and CSW v2. Everything else like Dynamic Damping, LEDs and Display as well as vibrations *should* work.
    And how exactly the dynamic damping will work with CSL Elite V1.0 knowing that DRI OFF applies constant maximum force damper? 
  • You should definitely uninstall Fanaleds as it can (and most probably will) get in conflict with FanaLab when both programs want the telemetry data from the game at the same time. 
    If FanaLab is interfering with other Telemtry Software (SimHub, SimDash, Sim Commander, SimVibe, etc.) FanaLab is a NoGo.
    If you get the data from shhared memory I see no reason for interference.
    UDP-Stream is a completely different story. In this case (F1-2019 e.g.) there should be / must be an option to either:
    a.) Select the listening port in FanaLab
    b.) Enable Port Forwarding in FanaLab
    c.) Both above options (Optimum).
    Regarding a conflict between FanaLab and FanaLEDs it's more about what gets send from each software to the wheel base, if both are running parallel and both sending display and LED commands to the steering wheel, they will interfere with each other.
  • Could we have a section of the forum where we could upload .pws files to share settings?
    Or maybe there is somewhere else this is allowed? I tried as a test to upload such a file and it appears to not be allowed here.
    It would also be nice if you could post files in the recommended settings section, so we could just download and import those settings.
    Put it in a .zip file.

    I'm running Simvibe and Fanalab simultaneously without any issue Paul. All I do is start the game first (through Fanalab), then start Simmcommander after it has begun booting up. That way, Simvibe attaches itself to the already running game and everything runs just fine.
    Should work the other way around too, in FanaLab you can launch the games but you don't need to, you can also just have it running in the background and start games via Steam or so. 

    I can't get the LEDs and display to work on F1 2019, anyone else? DD2 and FV2
    I cant get the leds in f1 2019 to match my csl v1.1 or formula v2 rim
    Every car in the game uses a different RPM Range. Adjust the FanaLab RPM LEDs to match your specific car you are actually using.
    Rather the led data just come from game then. It seems pointless to adjust for every car you get in. Spend more time adjusting them than you would driving
    you can save a profile for every car and then load it when you are in game. But, yes, you need to invest quite a bit of time to adjust the LEDs one time for every car. (btw, not just in F1 but in every other game, too).
    Maybe fanatec could consider an option to use game data for rev lights then. Whilst it's good to be able to adjust the flag lights for different things the rev lights seem pointless to me as surely most people would want it to just match the car in game. I've played a lot with settings this morning with it on f1 and whilst I can get it close I cant get it exact and it seems to vary in different gears slightly means shifts are bit all over the place
    Games don't offer separate output of LED or display, either you enable or disable all of it, there for it would interfere if you want to use part of one thing and part of the other, there are technical limitations. So like Maurice described already you have to either rely completely on the game regarding LED & Display or completely on FanaLab and that you decide with the red and green buttons in the game profile. 

    I´d love to be able to change the my steering Wheels and be able to define the button-layout via a future fanalab Software version. Example: I define "e" as the key to start the engine in the game. I then define the "e" button via Fanalab onto the leftmost button on the porsche rim, but on the the Formula rim I assign the "e" to the middle blue button. 
    You can use the free software Joy2Key for that.

    HI Guys, Good looking software . I am running Iracing on V 2.5 base BMW rim And and V 3 pedals . When running on the Fanalab software I feel a lot more from the wheel , however I lose the brake pedal vibration . Sometimes it is grayed out on the adjustment page of the software , some times it shows active but no in game vibration from pedals . If I exit the Fanalab software brake pedal vibration returns . Also the brake force slider will go back to zero some times when making adjustment  when near the 50 % range . I know this is Beta version just giving feed back. 

    Keep up the great work .
    The problem here is that FanaLab can activate the vibration motors triggered by game telemetry data, this deactivates the old tuning menu feature where it vibrates on specific brake forces. We are working on a solution that this can coexist. 


    Hello,

    Finally try FanaLab tonight and I have to say that the user interface is nice and easy to use. Really faster to make profile for each car with the tuning menu and save it in FanaLab. 

    - Is it possible in the future to add an 'Export all' button with the profile name as the saved filename?
    - Or is it possible in the future to make a selection of profiles (CTRL for multiple profiles, or SHIFT for a list) to export with the profile name as the saved filename?

    Thanks!
    The only way right now is to go to C:\Users\*username*\AppData\Local\Fanatec\FanaLab\settings and save all folders if you for example want to send someone all at once or you want to back them up for a fresh install of windows. 
  • When loading a profile from someone else and saving it, the same set used by the creator of the profile will be used. Can not change this by the software recognizing which set you have just activated and saving it for this set? Or at least so that you can assign a profile to another set later.
  • Will post a tutorial how to get SimHub + FanaLab working together in F1-2019 later in the evening.
    As well as some suggestions for the devs to take to get this issue solved once and forever.
  • Just for info (running F1 2019 on Win 7, Intel 4770, NVidia 980ti
    and CSL Elite + PS4 with Formula V2):

    There was a problem that the leds won't go off after leaving
    the pitlane. I had to reduce the UDP sending rate to 20hz
    to make it work. No more problems so far - great software!


  • edited September 9
    Marcel Pfister said:
    "You don't have to setup any ports, all you need to is go to the "Game Profile" tab of FanaLab and click on both green boxes. Some games need you to do something manually so keep an eye on the message which appears afterwards, it will either tell you instructions or that it was successfully edited." 

    This is what I´ve done yesterday. I´ve seen the two messages. But it hasn´t worked as I have described it in my last post. The UDP-Transmission-Mode has been still enabled (with my Simhub-settings) - FanaLab has shown the message "Telemetry uninitialized" all the time and your software hasn`t worked in F1 2019 until I´ve disabled UDP-Transmission-Mode, set Fanatec-LED to „ON“ and UDP-Telemetry to „OFF“ manually. Than I´ve closed F1 and FanaLab and restarted them (clicked on the two green buttons again).              Finally FanaLab has worked and I´ve done some time trial. After a while I´ve recognized an increasing delay for the LEDs on my V2 e.g. spinning wheels at the Flag-LEDs has shown up a while after ingame spinning (noticed it with the activated throttle rumble motor) or the Rev-LEDs have lighten up a while after I´ve changed a gear.

  • Marcel Pfister said:
    "You don't have to setup any ports, all you need to is go to the "Game Profile" tab of FanaLab and click on both green boxes. Some games need you to do something manually so keep an eye on the message which appears afterwards, it will either tell you instructions or that it was successfully edited." 

    This is what I´ve done yesterday. I´ve seen the two messages. But it hasn´t worked as I have described it in my last post. The UDP-Transmission-Mode has been still enabled (with my Simhub-settings) - FanaLab has shown the message "Telemetry uninitialized" all the time and your software hasn`t worked in F1 2019 until I´ve disabled UDP-Transmission-Mode, set Fanatec-LED to „ON“ and UDP-Telemetry to „OFF“ manually. Than I´ve closed F1 and FanaLab and restarted them (clicked on the two green buttons again).              Finally FanaLab has worked and I´ve done some time trial. After a while I´ve recognized an increasing delay for the LEDs on my V2 e.g. spinning wheels at the Flag-LEDs has shown up a while after ingame spinning (noticed it with the activated throttle rumble motor) or the Rev-LEDs have lighten up a while after I´ve changed a gear.

    When you use some other telemetry software (SimHub, SimVibe, etc, pp) you have to mess with the ports!
    Using FanaLab on it's own, it is more or less straight forward.

  • I don't think I'm alone here when I ask for support for maybe the oldest Sim but the best Nascar Sim ever Nascar 2003 Season by Papyrus, please ^:)^
    If you are really not the only one we can take a look at it ;-)


    I thought maybe my post had got lost with all the more important stuff...But thanks if you can look, I guess people need to post in here to get the numbers up, I do know that I'm not the only player left in the whole world with this game that also uses a Fanatec wheel :)
    So, where are you guy's hiding!! ??
  • How to get FanaLab and SimHub work together in F1-2019

    Just finished my tutorial how to get SimHub and FanaLab work together. 
    There are also some suggestions to the devs at the end of the document how to cope with UDP-streams and more than one listening app.


  • How to get FanaLab and SimHub work together in F1-2019

    Just finished my tutorial how to get SimHub and FanaLab work together. 
    There are also some suggestions to the devs at the end of the document how to cope with UDP-streams and more than one listening app.


    Where is it?
  • How to get FanaLab and SimHub work together in F1-2019

    Just finished my tutorial how to get SimHub and FanaLab work together. 
    There are also some suggestions to the devs at the end of the document how to cope with UDP-streams and more than one listening app.


    Where is it?
    Simply click on "How to get FanaLab and SimHub work together in F1-2019"
  • I can't get the LEDs and display to work on F1 2019, anyone else? DD2 and FV2
    I cant get the leds in f1 2019 to match my csl v1.1 or formula v2 rim
    Every car in the game uses a different RPM Range. Adjust the FanaLab RPM LEDs to match your specific car you are actually using.
    Rather the led data just come from game then. It seems pointless to adjust for every car you get in. Spend more time adjusting them than you would driving
    you can save a profile for every car and then load it when you are in game. But, yes, you need to invest quite a bit of time to adjust the LEDs one time for every car. (btw, not just in F1 but in every other game, too).
    Maybe fanatec could consider an option to use game data for rev lights then. Whilst it's good to be able to adjust the flag lights for different things the rev lights seem pointless to me as surely most people would want it to just match the car in game. I've played a lot with settings this morning with it on f1 and whilst I can get it close I cant get it exact and it seems to vary in different gears slightly means shifts are bit all over the place
    You can get the correct values for every car in F1-2019 from this *.xlsx:
    https://1drv.ms/x/s!AngnWwGMubK9opgzJw3-pnw9dKu0cQ?e=JbtPk5
    I made it for my SimHub F1-2019 Dash hosted at RD:
    https://www.racedepartment.com/downloads/f1-2019-dashstudio.27461/

    And yes, a possibility to set the LEDs per car with automatic change is mandatory.
    And it is possible, I do exactly this in the above mentioned SimHub Dash as well as in my ACC SimHub Dash.
    But be warned, to get the proper values is a long and boring task as the devs don't communicate the numbers.

    Just recognized that  Fanatec has only 9 LEDs on the wheels and the rim :-(
    F1 has 15 LEDs on the wheel / dash.
    F2 has 10 LEDs on the wheel / dash.

    In this case I stick in regards of LEDs to SimHub.

    Am I missing something or is that XLSX only listing 2017 (and older) models?

    In any case, more info than I had so far, so thanks!!
  • The values are from the 2018 and 2019 specs.
    As I did the exactly same spreadsheet for 2017 I was just to lazy to update it completely
  • edited September 9
    The Telemetry Application 9.1 doesn't work on wireless connection when FanaLab is opened because it needs a different IP than the main 127.0.0.1 and the port number 20777 only. So,I cannot use both in the same time.
  • edited September 9
    The Telemetry Application 9.1 doesn't work on wireless connection when FanaLab is opened because it needs a different IP than the main 127.0.0.1 and the port number 20777 only. So,I cannot use both in the same time.
    This is exaclty the task for the Fanatec devs (as well as the dev of Telemetry Application 9.1) I described in the  "How to get FanaLab and SimHub work together in F1-2019"
  • edited September 9
    Hi. I have a Elite PS4+Mclaren GT3 wheel and V3 pedals. I installed Fanalab and in Assetto Corsa I got the leds of the elite base and the vibration motors of the pedals working... but lost the information of the LCD of the steering wheel.

    Anyone can help how to get that back? It's an issue with Asseto Corsa only. It was working at first try but I tried to put the gear displaying constantly and disapeared the LCD information. Already set to default and tried to close Fanalab but the LCD information doesnt show in AC...

    Thanks in advance for any help.
    Did you click on both green buttons of the Game Profile page before starting AC? If you want to go back to using the game data instead of FanaLab you have to click on the red one. If the rev LEDs work I don't see a point why the display shouldn't, maybe you can send some screenshots? What you can do as well is go to settings and then on the bottom click on "View Telemetry Feed" to see if telemetry from the game is received by FanaLab. 
    Hi Marcel.
    Yes, I did click on both green buttons before starting Assetto Corsa throught Fanalab. I believe it worked the first time I tried it.
    I think it stopped working after changing the gear constantly in the LED TAB and saving the profile in the game profile tab.
    Now, even if I start AC without Fanalab running I dont get any info in the Mclaren GT3 LCD. If I press both paddles I get the double clutch bite in the lcd but that all I get there...

    You can see print screens of LEDs and Game profile tabs:

    image

    image

  • Sorry man, I was reading on the phone, I didn't notice it was a link...
  • Sorry man, I was reading on the phone, I didn't notice it was a link...
    No problem ;-)

  • edited September 10
    Hi, 

    any news regarding the updated version?

    no pressure intended... :D
  • I have a question about changing the LEDs.
    If I change those in the FanLab can I then use the change on the Xbox One X as well?
  • I have a question about changing the LEDs.
    If I change those in the FanLab can I then use the change on the Xbox One X as well?
    No.
  • still cannot get it to work witj F1 2019 PC edition. CSW 2.5 F1 2019 steering wheel beta drivers installed
    sw keeps saying telemetry data not working

    even after set with both buttons for telemetrie and hardware etc.

    Can you upload a screenshot of that message? You can also check the telemetry feed under settings to see if data is coming in. When you hit both buttons, did it say that the process was successful?
  • No Support for the CSL Elite...  :(
    unofficially there is support. Only the Tuning Menu is not working on CSL E, CSL E v1.1 and CSW v2. Everything else like Dynamic Damping, LEDs and Display as well as vibrations *should* work.
    And how exactly the dynamic damping will work with CSL Elite V1.0 knowing that DRI OFF applies constant maximum force damper? 
    Yes you can't deactivate the motor damper on the CSL E 1.0 but still the dynamic damper should work, it just has less of an advantage on your base. The default damper is always there but it is not the maximum damper the base can do. 
  • When loading a profile from someone else and saving it, the same set used by the creator of the profile will be used. Can not change this by the software recognizing which set you have just activated and saving it for this set? Or at least so that you can assign a profile to another set later.
    I have problems to understand what you try to explain in the second half. 
  • No Support for the CSL Elite...  :(
    unofficially there is support. Only the Tuning Menu is not working on CSL E, CSL E v1.1 and CSW v2. Everything else like Dynamic Damping, LEDs and Display as well as vibrations *should* work.
    And how exactly the dynamic damping will work with CSL Elite V1.0 knowing that DRI OFF applies constant maximum force damper? 
    Yes you can't deactivate the motor damper on the CSL E 1.0 but still the dynamic damper should work, it just has less of an advantage on your base. The default damper is always there but it is not the maximum damper the base can do. 
    Thanks for the answer!
This discussion has been closed.