Fanatec Beta Driver V373 (372 before) for CSL, CSW and Podium Bases (all wheels)



  • Thanks. I see that now.

    I would assume that fanatec sdk access is only available to developers that have an existing app. Not someone like me that just wants to tinker around making my own ITM pages?

    The TC, map and abs values are right next to the engine oil temp in the iRacing sdk. And the lap times are available earlier than the current ITM implementation. So I feel like it wouldn't be that hard for me to build out our own little pages with custom data. Sounds fun.

  • I had the issue with a DD1 / PS4 F1 Rim - experiencing the shifters and buttons stopping working periodically. As I said before it has to be a software / firmware issue as going back to the prior beta software makes the problem go away. So clearly some wheel freezing issues still do exist in v373 of the software / firmware.

    • Wheel Base Model (product ID): ... podium dd1 ps4
    • Steering Wheel Model (product ID): .... all (maclarem)
    • Driver Version: .... 373
    • Base FW Version: .... 674
    • Motor FW Version: .... 40
    • Wheel FW Version: .... 31 (maclaren
    • FanaLab Version: .... 1.47

    everything was fine ! - I updated all firmwares - and everything was always good! I play only on the McLaren steering wheel and today it just stopped working, but the problem is that I tried to rearrange another formula steering wheel (which came with the base, it was also updated to the latest version 35) but the base did not see it ... then I overloaded the base with the help of a keel switch - and the base recognized it, but then I decided to change the steering wheel to a Porsche steering wheel that was also updated to the latest version, but it also did not help the base did not see it ..., then I overloaded the base again and the base saw it but when I tried to change the steering wheel it all happened the same ...

    I again returned to McLaren - and overloaded the base, the base saw it, but after 5 minutes it became unavailable again ... if you put on a different steering wheel, then everything is the same ...

    What could it be?

  • So the jolts can only be fixed by not running ITM? That's a bummer. I hope that gets attention soon. The ITM screens are so cool and can be useful. But the wheel was literally just ripped out of my hands and I crashed because of it.

  • Hey Daniel,

    have the same problem. Where did you get it / where can I get it so I can give it a try?


  • Hi Daniel,

    Same gear, same story here but no happy ending.

    I am thinking of getting a new wheel before sending back the Formula V2 for "repair".

    May I ask what rims you have been using without issues with your Podium wheelbase ?


  • edited October 2020

    Have you solved this one yet?

    Have the same issue for a while now especially on ACC. Although support has sent me a video that the MPS selection on tuning menu should be set to encoder mode for the MPS switches to work (they actually tested on their rig and it was working on their video), I am doing the same but doesn't work.

    In the PBME cant assign the top paddles (there is a limitation there) but MPS switches should be set to encoder.

    Try and let me know cause I think the next step will be RMA my PBME. 😇

    F1 wheel you can assign each and every button, rotary MPS even the to paddles above the shifters, which is strange.

  • I am still having pretty major issues with my 2.5 and v3. Both have been updated to most recent software.

    The first issue is I cannot look at and calibrate my pedals when looking at the properties page. No matter what option I choose, it will show the Universal Hub.

    Second issue is my wheel will lost FFB periodically, and during that time none of the buttons or paddle shifters work. IT will come back after 3-5 seconds and then does it again within the next minute

  • First is because of a driver issue since forever. Power off the base, then you can open the property page of the pedals. Or alternatively, and even the better solution, connect the pedals to your base, not to the PC.

    Second is because of flex or another loose connection and you need to contact the support.

  • I have all the latest drivers and firmwares.

    Never had this issue before.

    The wheel just stops for no apparent reason.

    It then flashes in PS4 mode.

    I have not touched any buttons just drove and it has done the same.

    A reboot and set back to pc mode brings it to life again 

    Re installed drivers.

    Tried a different usb port.

    Reseated the rim and checked the pins.

    Out of ideas.....

  • Hi guys, new user here, I have the DD1 and f1 v2 rim, I managed to get the latest drivers installed but after calibrating the motor (v40) there is a very distinct notch when you rotate the wheel 90 degrees right and then turn it slowly left, the only solution i have found is to erase the calibration and use as normal.

    Not sure if this is known, its a lot of pages to scan through but if not well there it is, i would rather just leave it uncalibrated than jump through hoops to install an older driver as it does not always go easy.

    Besides that its been amazing, im very happy.

  • Hey Alexandros, no I haven't and nobody provided any explanation here yet. Maurice, can you please shed some light on this for us?

    Being on DD1, BME doesn't seem to be mappable on PS4. APM cannot be assigned, rotary encoders or toggle switches are not working. Same on F1 wheel works 100%. Is this current limitation? It is bloody super expensive wheel for not it to work with same features as all other wheels which work.

    PS: Is there also an intent to have ITM working on PS?

    Thank you guys

  • I have CSL Elite PS4 base with esports F1 wheel - running on PC and with the latest v373 driver + base and motor firmware.

    In ACC with recommended settings I'm getting some very fine "grainy" feeling when cornering and even at high speed in the straights (tested on Bathurst track) even with FEI around 30-40 it did not reduce it. I did not experience this with the previous v346 firmware and motor firmware V20.

    I'm not sure if this is coil whine or something else?? Thoughts? I might try with motor firmware V20 tonight which is supposed to be the smoothest motor fw

  • Forza Motorsport 7 - PC

    Beta drivers 372 / 373 do not work with CSL Elite PS4 wheel base in Forza Motorsport 7 on PC.

    • Wheel Base Model (product ID): ... CSL Elite PS4
    • Steering Wheel Model (product ID): .... P1 and eSports F1
    • Driver Version: .... 372 & 373
    • Base FW Version: .... 674
    • Motor FW Version: .... 22
    • Wheel FW Version: ....
    • FanaLab Version: .... 1.47 (also tried without Fanalab installed)

    Symptoms with beta drivers:

    • FM7 can map buttons and axis (manually), but does not 'know' the wheel is a Fanatec CSL Elite
    • No FFB what-so-ever
    • CSW V2 compatibility mode is partially recognised by FM7, but still no FFB
    • Huge dead zones


    • Revert to last non-beta driver - 328

  • ITM is not working on PS4. It is limitation from the console because I think you have to have Fanalb working in the background. So only Legacy mode for PS.

    APM shifters are working on PS4 ACC but the 2 top paddles are not. Same was confirmed by the tech team.

    The MPS switches which doesn't work on ours seemed to work on the test facility in Fanatec using their rig and equipment and was told that I needed to switch to "encoder". They sent me a video as well. But have tried and still not mappable. So now waiting again for a reply.

    Fingers crossed.

  • Update.

    It seems that if I change my rim the fanalab won't detect it until a reboot.

    Also in iracing with 0ffb it still goes to PS4 mode using the P1 Xbox rim.

    It happens whenever any contact is done, but not everytime, just randomly.

  • Erich KlingerErich Klinger Member
    edited October 2020


    a question, there has been no released new driver from Fanatec for the DD1 and DD2 for ages, we are still on the Fanatec_64_driver_335.

    When will there finally be a driver that works and will be released, because with every beta driver I have tested so far, there are always only problems.

    It would be better to make a driver ready and release it than to keep adding new features that don't work anyway and always get stuck in beta status.

  • Hey!

    I too have experienced freezes with the Podium DD1 with Formula V2.

    I bought an adittional wheel (Porsche), in the first 20h I had no freezes what so ever but then I started having some again.

    So the problem might be in the firmware / base or maybe some loss of connection between base and wheel after a period of usage.

  • Hello Edgar,

    Thanks for sharing, I was hoping the Porsche wheel wouldn't have this issue. I have one on the way so will be testing this on my end.

    Yesterday I had a formula V2 wheel freeze few minutes after entering qualifying. I exit the server, reboot everything and was able to run a 50mn race without freeze. It does not seem to be duration related.

    According to Fanatec the issue is with the hardware but they do not provide specifics. They are asking me to ship both the DD2 and the Formula V2 back for repair which will leave me with nothing to race with for weeks.

    I will ship the Formula V2 back first when the Porsche wheel gets here.


  • Hey Alexandros, I understand the ITM might take some time but should work. You can get telemetry out, you should be able to do ITM display. It was more of a question. The other is more pressing as half of the wheel is not functioning.

    Yes, top paddles of APM don't work, rotary also don't work no matter what they are set up to. My toggle switches also don't work. Did you get these to work?

    Can someone shed light on this please if it is hardware and we need to RMA or it is current software limitation?

  • So i thought this driver had rectified the Freezing issue.

    Has anyone from Fanatec confirmed if these are hardware or firmware related.

    Also why is there not more discussion or feedback from Fanatec with the issues that users are having within this forum.

    It all forms part of customer service so it may help to have some more communication on current issues and likely release of official drivers etc etc .....

  • Blue Circles are the ones not working even in Encoder mode for me + the top paddles (which apparently is a limitation of some reason although in F1 wheel everything get registered).

    ITM works in legacy mode as advised earlier due to console limitation.

    Everything works in the fanatec pc application for the drivers.

    Waiting to hear back from support what to try next.

  • Hello all, I have recently downloaded v373 to my clubsport wheel w/xbox hub and unfortunately none of the xbox buttons on the wheel work. Well the start button will bring up my xbox and B work however no others work. I need to use my actual xbox controller to navigate. I have searched for a fix and cannot seem to find what to do. Any help would be greatly appreciated.

  • Hi guys. I asked this question awhile ago now, but got no reply, so I'll ask again. I have a CSW 2.5 Wheel base and since updating to Firmware 373,

    1) I only have 880 degrees of rotation instead of 900. No big deal, but wondered why this would be.

    2) The fan in the the unit never seems to come on, even after hours of use.

    Hope someone can shed some light on this. Thanks

  • Ok, I'd like to have a clear answer to this since nothing is really clear when it comes to Fanatec drivers. I got the v334 installed since it's the newest driver under downloads of the Formula V2. I use this with the CSW 2.5.

    I wanna get the ClubSport Magnetic Paddle Module as an upgrade now. And it shows the v373 as a normal driver download without 'Beta' or anything else in it.

    So people still having trouble with this driver and the official driver on the CSW 2.5 and Formula V2 are damn old. But when I get those shifters the v373 is the offical driver to use?

  • 373 is a beta driver but the only driver properly compatible with the MPM.

  • Thanks for letting me know so quickly. So if I'd stick to the 334 the MPM wouldn't even funktion?

  • Dont know for sure but its not recommended to even try an old unsupported driver so go with 373 which is currently the only certified driver for the MPM.

This discussion has been closed.