New CSL Elite 1.1 Base + WRC Wheel issues

Just received my Fanatec stuff in the mail today. Base + Wheel + Handbrake + Shifter and already had my SimLab GT1 and monitor set up and ready for the arrival of my Fanatec equipment. Unfortunately I can't get the base+wheel working. Haven't even tried the other equipment. I've contact their support already. I'm just going to copy + paste my email to Fanatec support. I'm not expecting them to reply any time soon so hopefully one of you all can help!

I am having similar issues as this forum post:

I have followed all the steps. I've removed old drivers, restarted, installed new drivers. Tried v. 336, 373, 374. Base firmware up to date as well. Unable to update firmware on wheel

When I turn on the base with no steering wheel attached, it rotates back and forth a couple times, the rev lights get to the third red light but don't make it to the blue lights. The wheel stops off center. The power indicator stays red.

When I put my wheel on, the power indicator flashes red.

the Properties page does not recognize a steering wheel.

The light on the steering wheel blinks red when I power on, but immediately turns off. No buttons on the wheel work.

I've also tried using different USB ports, different computers, old drivers etc.

I've also tried using compressed air in the holes below the rev lights.

Any help would be appreciated!!


Sign In or Register to comment.