CSL Elite F1 Set Wheel base does not turn on at all anymore

Hi, I have bought CSL elite F1 Set for black Friday last year, but due to personal reasons i did not use it until yesterday, when i tried to set it up. Initially i was able to start up the wheel normally but when i tried to update the firmware i got an error. I tried to update the firmware a few times but every time i got the same error. so i tried to reset the PC reinstall the fanalab and try again but after that my PC did not recognise the wheel. So i tried different USB ports but nothing changed. Meanwhile my wheel was still stuck in update mode (different light colors flashing on the wheelbase) and i was not able to turn it off. So i went on this forum to try and find solutions and someone suggested if nothing works unplug the power adapter, which i did and to my surprise after re plugging the adapter wheel did not turn on anymore. I also tried holding the power button for 10 seconds but nothing happened except the fan starting up..

So i am here to see if anyone had this kind of problem and if there is any solutions to it.

Comments

Sign In or Register to comment.