DD2 not working after installation...

Hi everyone.

Order for a Fanatec Podium DD2 placed on 02/14 and broken down upon receipt.

"Wireless Quick Release Update Mode. Error: Connect device failed (Error: Initial ping failure: No response received for ping command).

I have tried EVERYTHING and even applied the few procedures on the forum. Nothing works.

S *** t ! I'm good for service ... unless you have a solution?

Fortunately, it is guaranteed for 5 years...


Comments

  • edited February 19

    My DD1 did this after the 381 update. Keep swapping the usb slots in the pc and run firmware again. Eventually mine took. I think I turned it off and on a couple of times as well...I assume it's searching for feedback from the usb port. If it doesn't receive the signal, it shows ping failure. Once you've tried all the slots and the firmware takes, you can actually plug it back into its original pc slot and it'll work as normal.

  • OK. Let’s go !

  • Unfortunately no. Not working. I tried all the usb sockets again. The base is... dead.

Sign In or Register to comment.