CSL DD / McLaren v2 in-game controls lock-up - RECURRING ISSUE

This is an example of a recurring issue that I've been having with my CSL DD / McLaren v2 combination. I'm curious how many people have been experiencing similar issues and if anyone can offer some guidance or suggestions regarding how to fix it.

More info, copied from the video description:

-----------------------------------------------------------------

My system specs:


Intel(R) Xeon(R) CPU E5-1660 0 @ 3.30GHz 3.30 GHz

Installed RAM 16.0 GB

Radeon RX570, driver version 22.2.1

Dell 08HPGT motherboard

Fanatec Clubsport v1 pedals, connected to base via RJ-12

Fanatec Driver v439, all firmware up to date

Fanalab v1.63


What happens is the following: I'll be driving along normally, when suddenly and without warning, the wheel will stop responding. It appears to stay locked at whatever input it was receiving at the time. The throttle goes wide open, and stays stuck there even though I'm completely off the pedals. Obviously, this inevitably results in a huge crash and the end of my session. The only way to remedy this is to power off the wheel base and restart my PC.

This has happened across multiple games, including Assetto Corsa and Dirt Rally 2.0. I'll be testing more games in the future to verify.


Things I've tried to fix the problem:

• ensure that Windows USB power settings are not inadvertently powering down ports

• switch the wheel base to different USB ports on my computer

• ensure no other input devices are connected via USB (aside from mouse and keyboard)


Nothing seems to have worked. This problem is random, and the amount of time between incidents can vary from several minutes to several days, making it incredibly frustrating to try and troubleshoot.

For the record, this is my second CSL DD base that I've experienced this issue with. My first one, I received in August of 2021 and it exhibited this exact same behavior. I tried all the things listed above, and never was able to figure out the root cause. After a few months, it somehow just cleared up seemingly on its own, and never came back. I had to return that base for a separate issue I was having at the time, and received in its place the base which I currently have right now. Ten minutes out of the box, and the new base also started exhibiting this same exact control freeze problem. I've used it probably a dozen hours or so since, and it's done it two additional times (shown here is the most recent occurrence).


Ideas and suggestions (other than throwing my Fanatec gear in the trash) are welcome.

«134

Comments

  • TL;DR -

    My CSL DD / McLaren v2 wheel locks up intermittently while driving, and does not respond to input, while the throttle is stuck wide open, causing me to crash. Only fix is to reboot both the wheel and the computer.

    Occurs randomly, and across multiple games. Running Win 10, v439 Fanatec drivers, Fanalab 1.63. I'm curious how many others have experienced similar, and if anyone has suggestions or has found a solution.

  • Update: it's now done it in AMS2 as well, after about 2 hours of hotlapping. So it's 100% confirmed that it's not game-specific.

  • I suspect this is a connectivity issue. Could be caused by various things, USB controller in the PC, EMI, bad cables or could be faulty Fanatec hardware.

  • It does seem to be connectivity-related. If it's my PC's USB controller, I don't understand how I'd be able to use the same USB ports with my friend's Thrustmaster wheel for an entire weekend with no issue, yet I can't seem to go more than an hour or two without my Fanatec gear acting up.

    I don't really know much about how to detect EMI or how to combat it if indeed that is what's happening. I suppose it's possible, as I'm using a steel wheel stand and the CSL DD is bolted directly to it. I then have the wires running down the vertical pole, secured with velcro straps. The Thrustmaster's base is plastic, and I was using the plastic table clamp to secure it to my stand (since the bolt patterns didn't line up). But...like I said, I wouldn't really know where to begin to attempt to start testing if it's EMI.

    Bad cables I guess could be the cause, but the fact that this issue has happened on two different wheel bases, each with supposedly brand new cables from Fanatec, it seems to be an unlikely culprit.

    My money is on faulty Fanatec hardware. If you have any suggestions for testing if it might be EMI, I'm certainly willing to give it a shot as a last-ditch effort. I think if that doesn't solve it, I've about had my fill. It's getting mighty close to being time to throw in the towel on this whole mess.

  • Gregg DomainGregg Domain Member
    edited March 12

    Here's a picture of my setup, if that helps at all. It's pretty basic, I don't have any additional shifters or a handbrake or anything like that. Just the wheel with power cord and USB cord being fed down the black center pole and under the pedals which are resting on the aluminum runners. Cable for the pedals runs up that same pole to connect to the base via RJ-12.

    When I used the Thrustmaster, I used the same pedals, but had them connected to the PC via USB. Maybe that has something to do with it somehow...?

  • It's a tricky one to troubleshoot. I have occasionally had similar issues with buttons stopping working, ITM freezing, shifters not working etc. EMI can be caused by lots of things so it gets complicated. What is that big white box, dehumidifier? If could be a cause of EMI - any electrical device near by could. Also try to keep power cables and USB cables as far from each other as possible.

  • Yes, it's a dehumidifier, but it's not even plugged into the wall, so that shouldn't be doing anything, I wouldn't think. I'll see what I can do about trying to separate the power and USB cables as much as I can. Thanks for the tip.

  • You are not alone!

    My husband and I are BOTH on our second CSL DDs here, and both have experienced what I've collectively referring to as "USB Crazies". SOMETHING happens and causes the CSL DD to go absolutely crazy in spamming/overloading the USB bus.

    In fact, it can influence the system even outside of driving games - playing Valheim (mouse/keyboard) all of a sudden my character starts spinning in a circle and attacking, which stops as soon as I power off the CSL DD. It has also taken over the Steam UI at times.

    Like you, I've also had the CSL DD lock up with full throttle and fixed steering angle in game (ACC) also.

    Again like yourself, I've removed windows power management from all my usb controllers (similar vintage pc to yours - Asus Z97 sabertooth mk 2 with an i7-4790k), and also moved the CSL DD off the ASMedia USB 3 controller (which appears to be bugged, many VR users report issues with it) onto some of the Intel USB 2.0 ports.

    Given the number of reports of interference/emi/esd issues, particularly involving the shifter I'm pondering if it is that, or in fact related specifically to the pedals. I'm doing some tests on different things to try to help (and considering adding some ESD drain). So far with a couple of changes I have (touch wood) had no problems now for a couple of weeks and managed a 90 minute league race without issue last sunday.

    Ultimately I suspect that some of my issues might be EMI pickup on the pedal cable (I have CSL LC pedals connected to the base) - the source of EMI in my case could be our gas boiler which is about 5ft away (on the wall downstairs directly beneath where my sim rig sits). I'm trying some things to mitigate it.

  • There is a thread somewhere where someone connected something to the pedal base. Possibly grounding it.

    I know, not much help there but you have to trawl through the library... i remember there were pictures as well.

  • Thanks for the suggestions, guys! And good to know I'm not the only one losing my mind over this!

    I've separated the USB and power cables as best I can, but there's only so much I can do since they've eventually got to converge at the back of the base. I'm thinking maybe I should look into buying some extra ferrite beads to attach to the cables. Can't hurt, right?

    I wonder if there could be EMI coming from an electric baseboard heater nearby? It runs most of the length of the wall in the picture above, behind the dehumidifier. Not sure what could be done about that. I mean, I theoretically could just keep it turned off, but I'd be freezing my butt off for a good part of the year, so... not exactly ideal. 😕

  • Hello!

    I have the same problem, it happens frequently.

    I use Fanatec Podium on PS5 with F1 steering wheel and Mclaren GT3 V2.

    Games F1, GT7 and Assetto Corsa Competizione.

    I don't understand the problem and it's frustrating.

    Any solution?

  • Nothing concrete. I've separated the wheel base's USB and power cords as much as realistically possible. Made sure the base is plugged into a battery Back-UPS to protect against any minor power fluctuations that might occur. I've plugged my mouse and keyboard into the computer's rear USB ports, and the CSL DD is the only thing plugged into the front ports. I purchased some ferrite beads that should be arriving sometime today which I'll try attaching to the various cables to try and alleviate any remaining EMI, if there is any.

    I tried playing last night after doing all this, and in the roughly 2 hours I spent playing, I had no issues. But that's not to say that that couldn't change at any moment.

    I'll update once I get the ferrite beads installed, or if the issue pops up again.


  • Thanks for answering.

    But I don't use PC, I only play on PS5 (F1 2021, GT7 and ACC) and it's exasperating.

    I use a Fanatec Podium DD with CSL pedals attached to the base, with all drivers updated.

    All plugs are grounded.

    I will buy a Back-up battery and test.

  • Ok, so current status is this: I reworked the wiring of my rig slightly to try and keep some distance between USB cables, power cables, etc., making sure none of them were twisting around each other or anything like that. I also bought a big bag of ferrite beads (cores) of assorted sizes from Amazon, and clamped at least one or two on every cable going into or coming out of my computer. Finally, I plugged the power cord for the CSL DD into a Back-UPS in case any tiny power fluctuations may have been contributing to the problem (the computer itself is plugged into it as well, and had been from the beginning).

    I'm still extremely hesitant to say "problem solved"... but (fingers crossed)... I've been able to play for a good 8+ hours or so over the last two days, and it's been trouble-free. The longest I had been able to go prior was about 2 hours before the issue would recur.

    So... maybe it's fixed? Maybe it's something I did? Maybe it magically sorted itself out? Maybe it's Gremlins? 🤷‍♂️ All I know is my fingers are crossed everything stays how it is...I was beginning to forget what it felt like to have functional equipment.

  • Gagaryn .Gagaryn . Member
    edited March 16

    Good news. I am strongly inclined to believe that EMI is the cause of these issues. Fanatec are very proud that they use wireless technology on their wheels rather than a cable connection. Unfortunately this makes them vulnerable to this kind of interference. I've not tested enough to confirm this - that's Fanatec's job - not mine.

  • Well, it appears I spoke too soon. Just sat down to play some AC, and about 20 minutes in, the wheel just died on the back stretch of Sebring. I was hard on the brakes, downshifted into 3rd, went to turn in, and...nothing. Car wouldn't turn, no response from the pedals, couldn't shift, nothing.

    It seems that the USB controller is getting overloaded somehow, as there are lights above the usb ports on the front of my computer which are normally off during normal use, and when this issue occurs, they are all lit up and stay that way until I reboot. And I usually seem to lose keyboard and/or mouse functionality as well.

    I had the base (and only the base) plugged into a front usb port, and my mouse and keyboard plugged into rear ports. I'll try reversing them and see if that makes a difference. I also had a 3-ft usb extension cable on the keyboard, so I removed that as well.

    If this doesn't work, I'm out of ideas. More ferrite cores? It did seem to get better once I installed them, as I was able to play for longer. I don't know. The thought of just throwing in the towel and not being able to use this stuff anymore really sucks, as I do really like it when it all works.

  • ...aaaand it just happened again, in the space of about 20 minutes. I think I'm done with Fanatec. I just can't take this anymore.

  • Antonio, just to clarify, you say that you're experiencing this same issue of the wheel becoming unresponsive in-game? And you're on Playstation? When your wheel becomes unresponsive, are you able to use other controllers (e.g. gamepad) to control the console and navigate menus? Or do you need to completely reboot both the console and wheel?

    I was starting to lean towards my computer maybe having a dodgy USB bus... but if this issue is happening on console too, that kind of pokes holes in that theory.

  • I'm going to spend some time testing on Xbox and see if the issue happens there. (I know I said I was giving up but I figure I've got until June before the warranty runs out... so I've still got a little bit of time).

  • Probably worth noting that the warranty only obliges Fanatec to repair or replace the item. It does not oblige them to fully refund you. If your intention is to seek a refund I'd start that battle now. The longer you keep the wheel base the less likely you are to be successful.

  • Hmm yeah fair point. I just hate the thought of getting rid of it all, and then come to realize if I had just done this one thing, it'd all be fine. I think I'll test some more this weekend and then depending on my results, I'll see about getting the ball rolling on the refund.

    If Fanatec are unwilling to refund, and I can't get it working on my rig, I'm not sure how much I'd be able to get for any of it trying to re-sell it. 😕

  • Ive been having this trouble with my Gran turismo DD PRO (5nm) i got the wheel today, installed it and and in a few minutes my wheel and pedals dont respond. But the base still has power and moves the wheel parallel to the movement of the car crashing everywhere. I have tonpres the wheel power boton and put it back to blue and the log in to the PS to return playing and few minutes pass and everything happens again. Im so sad i havent had not even an hour of gaming! HELP MEEEE!!

  • I've been testing my CSL DD this weekend by playing some DR2.0 and F12020 on my Xbox (original Xbox One, Forza Motorsport 6 Special Edition, for the record). Puzzlingly, through about 7 hours or so of total play time so far, the wheel and base have behaved flawlessly. Why it seems to be fine with the Xbox but not my PC, I don't know. Maybe I just need to play longer before the issue occurs on xbox for me too.

    Yesterday I spoke with a friend from an old F1 league that I used to race in, who owns a DD1 and plays on Xbox. He said he experiences the same issue of the wheel and all button inputs suddenly becoming unresponsive while racing... at a rate of roughly every 10-12 hours or so of gameplay. Which lines up rather closely with what I've experienced with my CSL DD on PC.

    This, coupled with the fact that at least two other people in this thread are experiencing what appears to be the same issue on Playstation, makes me think: what is the common denominator?

    It seems to me that the answer lies somewhere in the Fanatec hardware itself. More specifically, the direct drive motors and/ or the technology that powers them. If I had to guess, I'd say it seems that something isn't being shielded properly and in certain situations and environments, the base's motor/ electronics either are emitting some kind of interference or are susceptible to interference from other sources. I would've thought that attaching the ferrite beads would work and would alleviate this problem if this was indeed the case, but what if the interference isn't happening due to the cords, but is perhaps due to the internal workings of the motor itself not being sufficiently shielded?

    Obviously that's just a guess, but if this problem is occurring across multiple games on multiple gaming platforms, across multiple pieces of gaming hardware (all of which use Fanatec Direct Drive technology)... to me, that seems to be a rather clear indication of where the problem lies.

  • I posted this somewhere else but my suspicion is that it is the wireless connection between the wheel and wheelbase that is susceptible to disruption from environmental EMI.

  • Well, only the steering wheel stops working. I have to turn the steering wheel off and on again and everything is fine again.

    The frequency in which it occurs is very variable, sometimes after 30 minutes of playing and other times after 2/3 hours.

    Now it has been 2 days without problems and I have not touched anything.

  • That sounds very similar to what my friend says he's experienced with his DD1 on Xbox. (Not sure which gen he's running).

    I spent about 7 or 8 hours on my Xbox One, and couldn't get the issue to occur... it all behaved perfectly. Of course it could be that I simply need to play longer for it to occur.

    But then I got to thinking: the wheel works fine with my Xbox but not with my PC, they're both in the same room, literally only a couple of feet apart. The only thing that changes when using one or the other is where the USB cable plugs into.

    I still have a couple of unused ferrite beads left from before, so I put two more on the wheel's usb cable (for a total of 4). I'm not expecting this to solve the issue, but I'm curious. Figured it was worth one last shot before I make the case to Fanatec for a refund.

  • It has happened again, after about 60 minutes of play, during an online race. It's a frustrating situation.

    I'm going to notify the technical service, the base is only 11 months old, and for the first 8 months everything was correct. I don't understand.

  • FWIW...I seem to be having pretty good luck after installing a few more ferrite beads on the USB cable connecting the base to the computer. I've gone a couple of weeks now with no issues, which is a huge improvement over the state of things when I initially got the wheel back from Fanatec. Fingers crossed it all stays this way.

  • Thank you for reporting this thread to me. I also have the exact same problem. And thanks for sharing your experience.


    I ordered the ferrite rings. But I have a doubt I wanted to ask you about. I don't know if I can explain myself in English. I have doubts about the cause, not the solution.


    I had first time 1 month after CSL DD purchase, then again, 3,2,1 weeks, then 6,5,4,3,2,1 days. Now every 10 minutes. This is failure behavior.


    I don't know anything about EMI, for me it has always been like woodoo, but maybe I should know why I work with protection and remote control of medium voltage power lines. When a power line has a fault, the start-of-line switch opens, and removes the electricity from the fault. So when the switch closes, after a very short time the line is live. Most people don't even notice that there is a lack of electricity. But the fault is there, and sooner or later it returns, because at that point the insulation is corrupted. Then it fails again, and then again, more and more often, until the line can no longer be under tension, and it needs to be repaired.


    This is for power lines, I have no idea for EMI, but sure is the behavior of an electrical fault that degenerates.


    So if I understand correctly, CSL DD generates EMI, but is it our PC USB port breaking?


    Because sure there is something broken, otherwise the failure would be accidental.


    I'm afraid that if I keep insisting on using CSL DD, my PC's USB outputs could be damaged forever.


    But do you think all CSL DD have the same problem? Or are ours that are faulty?


    If the latter were true, using ferrite becomes a great deal for Fanatec, which no longer has to replace CSLDD, but a bad deal for us, who keep our defective CSLDD, with a patch.

  • Great questions, I wish I had some insightful wisdom to share, but I don't. Like you said, it's kind of like voodoo magic to me.

    All I can say is that when it happens, it seems like the wheelbase is spamming/overloading the USB port, which as a result causes all connected USB devices to stop responding correctly. I suspect that the problem has something to with the wireless QR technology that is being used. I'd guess that there may be some sort of latent EMI present in our homes and those of other users afflicted by this problem, which for whatever reason, bears the characteristics necessary to interfere with our wheel and/or base. I'd guess that there is some characteristic of the EMI that is common amongst all of us but is not present among users who aren't experiencing this problem. Either that, or there is some sort of manufacturing defect common to only our equipment (perhaps an unusually poor quality cable supplied by Fanatec, lack of sufficient shielding around the wheelbase's internals, etc.)

    Either way, I'm just happy that it's all been behaving normally for a while.

Sign In or Register to comment.