DD1 Powers off Immediately After I Power it On.

I put in a support ticket for this but no one from Fanatec has gotten back to me. So I am really starting to get worried especially since I am brand new to simracing and buying all of this equipment from them.

Here is my problem"

When I power my DD1 on by pressing the white power button on the back of the podium, the front LED displays turns on and shows the "Fanatec" name on the display and the steering wheel rotates once and then the DD1 powers off afterward (please see attached video upload). This happens no matter if I have it connected to my PC or XBox or not having it connected to anything. I even tried detaching the steering wheel and Universal hub and the DD1 still powers off after rotating once. The white power light will remain lit after the DD1 powers off and the power supply green light stays lit. I have even tried switching electrical outlets and disconnecting everything and reconnecting everything to make sure all the cord connections are fitting into their sockets well. 


This is a new problem that I have encountered today after not using my Fanatec setup/DD1 for a week. When I last used my Fanatec setup, the DD1 powered up without a problem. I used it for short periods of time for about 2 weeks and the podium operated fine (by fine I mean it wouldn't randomly power off). When I first began to use my DD1 podium, I updated all firmware to the latest firmware including the latest firmware for the DD1 and Clubsport Pedals. 


I installed an older firmware from 2019 due to Forza Horizon 5 always crashing. In order to see if it was a Fanatec firmware issue, I tried a firmware version from 2019. This did not fix the Forza Horizon 5 from crashing so I reinstalled the most up to date Fanatec Firmware and was still able to play Project Cars 2 without issue but I would only play Project Cars for about 10 minutes at most since I have owned it. 



Below is a summary of my problems and associated findings. 


1. The DD1 podium powers off immediately after I power it own. 


2. When I power it on, the "Fanatec" signs is displayed briefly and the steering column rotates once then the display turns off and the podium turns off and it bot detected by my PC or Xbox. 


3. When the DD1 briefly starts up, my PC makes the sound a Windows PC usually makes when a device is connected by USB port. However, the Desktop Fanatec app gives a message that the connection failed. 


4. The Fanatec desktop software/app does not detect the DD1 after it powers off even though the white power button is lit. 


5. The white illuminated power button on the back of the DD1 stays lit despite the podium powering off own its own. 


6. The green light on the power supply stays lit even though the DD1 has powered off on its own. 


7. I have tried using different electrical outlets but this does not help. 


8. I have tried detaching the steering wheel from the base but this does not help. 


9. I have tried disconnecting the podium from the PC and Xbox but this does not help. 


10. I have tried unplugging all peripherals such as the Pedals but this does not help.  I have checked all connections to make sure everything is flush.


11. My firmware was updated last week to the latest firmware at that time. 


12. I have PC driver 439 


13. No lights or LEDs are shown on the Universal hub while the DD1 is powering on and neither do they show when the DD1 powers off.


  • No help at all? All of these other threads has at least some feedback. I have called Fanatec but there is never anyone available. I have tried the Live Chat feature but no one is ever available. I even tried calling during the time period they say someone would be available but no one is. I have responded to old support emails but no response there. Of course, I have even tried here. I have lost hope that I will get help.

  • "However, the Desktop Fanatec app gives a message that the connection failed. "

    What is the error message?

    You could try hold the white power button on for ~10seconds which will put the base into bootloader mode. and a window should show up on your PC to flash the firmware. Click flash firmware. Once the firmware is flashed the wheel base should show up in the Fanatec app. The fans may run at full speed until you update the motor firmware.

  • I really appreciate the tips, man. I tried this but unfortunately it did not work. I was able to flash it but it immediately went back to the problematic behavior afterward. The Fanatec app went immediately back to not detecting it.

    I just want my money back now.

    This Fanatec equipment isn't worth all of this headache and pain. In retrospect, it kills me that my wife bought me a nice Thrustmaster wheel for my birthday but I told her that I already ordered this Fanatec equipment. I had to choose between the two. I obviously made the wrong choice. After losing so much precious time with dealing with all this, I wouldn't be surprised if I wake up in the morning to find out she has thrown all of this stuff out the window. I wouldn't blame her one bit though.

  • What's the error message?

    If it's WQR ping error then you need to start RMA process and get a replacement.

    If it's something else then you may be able to get it working without having to ship it back.

  • Yes, I get the WQR ping error message. I started a RMA but I have not heard from anyone in over a week. even though I also took the other steps above including posting on this forum.

    I give up. Life is too short for this. I will now focus on going through the steps to get my refund. Thanks again for your help.

  • That's unlucky.

    There are delays with support at the moment. Hopefully they get back to you soon and you choose to stick with the DD1 as it's fantastic when it's working.

    I have the same WQR issue and can't wait to get it fixed and get back to racing again.

  • Made the same mistake.. decided to take the Gt Dd over the thrustmaster.. wrong choice it seems. 4 weeks of using it and it fails already. No power, nothing. My T300 thrustmaster worked lind 4-5years, the difference. Just want the money back as well and move on

  • Right... All I can think about is getting my money back now. Usually, when something is not working right with any tech or gadgets that I own, all I would do is work on it and research it until I figure out what is wrong so I can fix it. However, this time it's different. The lack of support has just completely turned me off.

    It is crucial for us consumers to stick together when it comes to things such as this. We don't get a prize or an award for jumping in with an S on our chest to protect "the man." Our problem can and will be another consumer's problem at one time or another.

Sign In or Register to comment.