Another Disappointed Customer

Another disappointed customer here. Just received my GT DD Pro wheel base, Clubsport F1 Esports V2 wheel, CSL Pedals and Load Cell Kit. My PC does not recognize/find the devices whenever the wheel is attached. When the wheel is off, everything else works and I was able to update the firmware on all but the wheel. But when I attach the wheel, all of the devices get disconnected and the wheel just runs left and right indefinitely. Seems like this person is going through the same thing https://forum.fanatec.com/discussion/25631/clubsport-f1-esports-v2-with-gt-dd-pro-base

I've put in a support ticket but if I don't hear back soon I will most likely start the refund process since I've only got 14 days to do so. Was really looking forward to using these products but now I'm just frustrated and stuck with $1000 of product I can't use.

Comments

  • Tomas HelmsTomas Helms Member
    edited May 15

    Do you have another PC you can hook it up to and try to see if it is the PC or base? Have you tried another USB port for the base? Have you tried another cable from the base to the PC? Do you happen to have access to a PS4 to test it there. My shifter was going in and out, the new cable in the box was bad. This seems like some PC related issue to be honest.

  • I dont have another PC to try it on and it didnt work on PS5. Tried new ports and cables, no luck. I wouldn't say it's PC related as everything seems to work until I attach the wheel to the wheel base. Using the Fantatec Control Panel PC app, my PC detects the base and pedals and I can observe real time changes in inputs when I push the pedals and turn the wheel base shaft. I can also update the detected devices firmware. However, the issue is when I connect the wheel to the wheel base the control panel can no longer detect the devices. To me this implies an issue with either the wheel or base. Added pics below - first shows the setup without the wheel where devices (base and pedal) are detected. Second shows how no devices are detected once the wheel goes on. It just spins back and forth indefinitely and never gets detected.


  • IMO, I don't think this is something you're going to be able to solve without tech support. Current Customer Service response time is running somewhere in the range of 2 to 3 weeks. And that's just for an initial response. If they need more information from you, it could be another 2 to 3 on top of that. Then figure another 3 weeks or so for the return process and shipping times. And then there's the grim thought of, what if you then need support with the product they send back to you?

    If you're seriously considering returning the items for a refund, I would put that request in immediately so you're not stuck with something you regret.

  • J0ergJ0erg Member

    I have the same problem, exactly as described..

    But for me it happened after 1 month.. :(

  • I'm having the same issue. When I take the QR off the wheel and carefully allign the pins into the DD, the wheel turns on and I can update the firmware, see that button presses work, etc etc. But as soon as I screw on the quick release, and put on the wheel, the whole base disconnects as you describe. It's almost as if the quick release is causing a short or something.

  • Interesting, I haven't tried it without the QR. That will be my next experiment.

  • Maybe try to remove and reseat the shaft?

  • Mine would do this, I would have to redownlo

    Mine would do this. I would have to re download the driver and select repair files. I hope this helps

  • Same issue, GT wheel is fine, all updates done but F1V2 wheel seems dead and does the random movement in a loop. I have had luck where is did recognize everything but the update fails for the V2 wheel and everything goes dead. Different cables, reloading software and repairing.

  • OP update: I got in contact with support who had me send a video (see below) after I removed and reseated the shaft. They also sent me the latest beta driver to try but nothing worked. They want me to send in the wheel and the wheel base to repair it but I told them that I want to return all of my products for a refund. Really bummed but from what I've read on this forum, getting it repaired doesn't always solve the issues and they may come back further down the road.

    (https://drive.google.com/file/d/16hdOCIApsrL0zcS7Bvq9NrUmSuN5Gy8w/view?usp=sharing)

  • Ye spent £2000 on all this Fanatec stuff and have now regretted it. Shocking Support and hope this is bumped regulary to get it out there to people thinking of buying their products.


    All they do is attempt to send you drivers to fix all the time and it doesnt work....then they go silent

Sign In or Register to comment.