Brand New Fanatec Podium Racing isn't recognized please help

So I just bought this new wheel base with the blue f1 wheel and the fanatec control panel says no device detected and the fans on the wheel base is going at a 100 percent. PLEASE HELP ME

Comments

  • Marcel PfisterMarcel Pfister Member, Administrator

    Hello Kietkong Ketsiri,

    sorry that you are having this issue but the explanation below should help you to solve it.


    Solution:

    1. uninstall your current driver
    2. install the older driver linked below
    3. start the base by holding down the power button for 10seconds, this will force a firmware update
    4. after that the base should be working normally, just with oler firmware
    5. install driver 447 from the website or 448 beta from the forum
    6. flash firmware through the automatic process


    May I ask how you ended up in this situation?

    • Did this happen after a firmware update?
    • Which driver did you use?
  • I was using the driver 447 when this happened after a firmware update

  • I have another problem after the wheel restarted from the flash. None of the steering wheel buttons seem to work for some reason

  • Marcel PfisterMarcel Pfister Member, Administrator

    Both should be resolved when following my solution guide.


    Do you have other Fanatec hardware attached like ClubSport Pedals V3 via USB for example?

  • I have the Shifter and the Pedals connected through the fanatec podium

  • Although the fan stopped working at a 100 percent at this point

  • Marcel PfisterMarcel Pfister Member, Administrator

    Did the instructions and driver which I give about work for you to get the base functional again?


  • I bought a new Podium Wheel Rim Porsche 911 GT3 and it’s not even getting recognized smh brand new. All drivers are installed connections are reseated, reinstall drivers and still irresponsive.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Which base do you use?

    Which driver do you have installed?

    Is the firmware of the base up to date?

    Does the driver show no wheel at all or does it show only the hub but not the button module?

  • i am having similar issues as well. New Podium DD2 isn't being picked up by the control pannel. Installed the old driver, started the base like marcel said. installed the new driver 447, followed the steps of installing, restarted my computer like it says to do, and I'm back to square 1.

  • Marcel PfisterMarcel Pfister Member, Administrator

    With holding the tuning menu button and pressing the D-Pad/FunkySwitch down you can enter the System Info screen, can you make a screenshot of which versions it shows?

    Have you already tried the trouble shooting steps which get shown when opening the Fanatec Control Panel and no device is detected?

    There is also a driver repair button in the bottom left.

    Does the base show any other weird signs like the fan running at 100% the hole time?

  • I am attempting to repair my driver in the control panel because my dd1 isnt being detected and its just showing "Please wait while Windows configures FANATEC driver package" while the green bar is not moving at all. its been at least 30 minutes.

  • Hello Marcel,

    I had the same issue as all of the above. Mismatched firmware between the motor and the base. I'm so glad that I found this thread. I was about to contact Support because I thought I bricked it. I did exactly what you posted, and it worked. I knew I had to upload an old firmware and driver, but I didn't know how far back to go. I deleted the driver (477) in Windows and then reloaded it using the driver 336.zip file. I am so relieved.πŸ˜…

    Thank you very much!


  • Yup… same exact problem here. Glad I found this post since I thought I was the only one having this problem, apparently not. Hoping I can resolve it soon since I just got my DD1.

  • Marcel PfisterMarcel Pfister Member, Administrator

    An alternative way to access it is to use the driver installation file to access the repair function. It could be that the driver is searching for it and can't find it.

  • Marcel PfisterMarcel Pfister Member, Administrator

    I'm glad my instructions helped, wish you a fun and trouble free time with the new stuff.

Sign In or Register to comment.