CSL DD (5 Nm) + ClubSport steering wheel F1® Esports V2 no connection to PC (Win 11 64Bit)

Hello everyone,

my new Fanatec Sim Racing setup arrived yesterday.

CSL DD (5 Nm)

CSL pedals

ClubSport steering wheel F1® Esports V2

QR1 Wheel-Side

Unfortunately, there were problems with the setup.

After I had installed the FANATEC-TREIBER 455. I wanted to connect the wheel base and the steering wheel to the PC. Unfortunately, the FANATEC driver could not find anything. It could only establish a connection when I disconnected the steering wheel from the wheel base. This allowed me to update the Wheel Base with the latest firmware.

However, I still have the problem that I cannot connect the steering wheel to the PC. As soon as I put the steering wheel on, the Wheel Base loses the connection to the PC (LED is still RED for PC mode). The steering wheel starts to turn (for calibration), then the LED jumps to YELLOW once. The turning stops and the whole process starts again.

Does anyone have the same problem? Or can you give me a solution?

A support ticket has already been created. However, the answer takes 5-7 days...


  • MadDog-ICMadDog-IC Member

    Go straight to Fanatec Driver 457 beta and its Firmware updates, may help fix some known issues.


  • Thanks for the answer, unfortunately it didn't help.

    I now suspect that there is no firmware on the ClubSport steering wheel F1® Esports V2. As I was able to recognize the steering wheel when I tried "Manuel Firmeware Update". But unfortunately he could not read out any firmware. 

    Does anyone know the name of the firmware for the ClubSport steering wheel F1® Esports V2?

  • I have an 8nm CSL DD base and upgraded to driver 457 but the base won't stay connected long enough to do a firmware upgrade. There is a manual firmware upgrade but that look scary, so I didn't do it.

    edited May 19

    I figured-out my problem. Just be sure . . . assuming you are using QR1 . . . with the wheel removed from the base . . . .did you loosen the black collar that goes around the steering column on the base, then press firmly on the steering column to make sure it is fully seated, then retighten the collar?

  • Thanks for the answer, but I had already tried this. 


Sign In or Register to comment.