Formula V2.5 won’t update

Got a new CS Formula V2.5 today, attached it to my CSL DD base. Went to update and it would not update, came up with ‘Update process is stopped by error’ at 2% and not it’s just stuck in a loop of trying to update when I attach the wheel but just fails.

is there a way to reset the wheel or is it toast?


  • Allan LehtlaAllan Lehtla Member
    edited June 10

    what is your current version off CSL DD firmware self?

    Maurice Böschen talked something somewhere that they have new chip inside v2.5. but that needed have minimum 455 firmware or something.

    i not know if that is a case that your firmware failed install

  • edited June 10

    wheel base firmware -

    Wheel base motor -

    Quick release -

    All say up to date

    currently don’t have a wheel connected

  • Allan LehtlaAllan Lehtla Member
    edited June 10


    is-int wheel base should be right now the

  • Downloaded 455 drivers and reinstalled them multiple times - still no luck.

    what’s it’s doing now is as soon as I connect it to the base in tries to auto update, failed then my base stops being registered to control panel and the light flashes all sorts of colours. Have to turn base off and on to get to the show back up.

    regarding the wheel base I’m not sure, it’s showing as up to date but I had massive drama trying to update that as well, went through the update cycle and then it stopped on with the hour glass just on screen. Base works with a different wheel attached to it just fine

  • i think you should install 457 and then try

  • where is 457? When I go on fanatec website, 455 is showing as latest?

  • Thanks I shall try this tomorrow see if it helps.

    I have opened a ticket with fanatec as well and have a GT DD base I’m going to try to update it on, hopefully it doesn’t break that base!

  • but you should stay away at 456. as that have some forever loop issues

  • I personally think the wheel is bricked anyway, none of the LEDs light up when the wheel is attached and now every time I attach it, it’s tries to auto update but just says:

    ERROR: Ping device failed(No response received for ping command)

    Manually dose firmware updater and reboot the Wheel Base.

    Disconnected from device!

    then I have to turn the base off and on

  • you say it happens with 457 as well?

  • I haven’t tried 457 yet, will try tomorrow, it’s late now in the UK and I’ve shut everything down to de stress lol!

    Will try 457 first thing tomorrow

  • Just an update mate,

    tried the 457 drivers on the CSL DD - Still wouldn’t update the wheel

    Took the wheel to a friends and tried it on his GT DD - Wheel updated straight away and is now working.

    unsure what was causing the issue, maybe something on my PC stopping it updating?

    anyway, going to now go try it on my CSL DD and see if it works

  • Allan LehtlaAllan Lehtla Member
    edited June 11

    could be drivers. perhaps fully uninstall and install them again.

    or perhaps shaft little loose what causing some connections losses between steering wheel what not allows update

  • I did multiple times, but on my CSL DD I was constantly getting a permission thing popping up asking if I wanted to allow this app to make changes to my device, I’d click yes, fanatec control panel would do some weird thing, then the permission request would pop up again!

    Do you think theirs something on my PC stopping the drivers installing correctly?

    The base works fine which a different wheel and hopefully when I try it tomorrow it’ll work with the V2.5

  • when that permission request pops up. you need always type yes. if you tell him no then some drivers would not work

  • I press yes, then it’ll say ‘optimising fanatec base’, then the permission request will pop back up. It just constantly does this on loop for some reason

  • Allan LehtlaAllan Lehtla Member
    edited June 11

    restart pc

    what windows. home edition?

  • I’m not sure mate to be honest

  • MadDog-ICMadDog-IC Member
    edited June 12

    1) You may need to put in an exemption for the Fanatec software with windows "Defender" or other Anti-virus software you may be running that interferes with the creation of the update FW file.

    2) Make sure Wheel base is directly connected to PC motherboard USB port with supplied short USB Cable, no USB extension cables and no USB Hubs in between PC and Wheel base.

    3) Windows "User Account Controls" settings being set to strict and protective.

  • I will try this.

    The V2.5 updated and worked on a different base and different PC.

    im starting to think its a firmware issue where the PC isn’t allowing the drivers to install correctly.

  • edited June 12

    Downloaded drivers from fanatec (455), after I installed the drivers, and opened control panel, it gave me a permission request which I press yes. It then did someone on control panel and gave me the permission request again. This was a constant loop until I unplugged the USB and plugged it back in. It then was showing the CSL DD in control panel fine.

    Did all the updates required and then plugged the V2.5 in.

    It started the update for the wheel but then stopped at 2% and said update stopped by error.

    After this when I now put the wheel on the base none of the Fanatec logos pop up on the wheel but control panel recognises it as a V2.5 but doesn’t recognise any button input.

    I took the wheel and tried it on my GT DD, updated right away and works perfectly fine.

    Thinking I’d cracked it, put it back on the CSL DD and control panel started recognising is at a V2 universal hub. Then changed the V2.5 and said it needed and update. Tried the update and then started firing errors at me again.

    So the V2.5 works on my GT DD but not the CSL. (So I know the wheel is fine)

    The CSL base works with the normal GT wheel attached but as soon as I attach the V2.5 it puts the base into update mode but won’t update the wheel. Have to remove the wheel and turn the base off and on.

    I’ve tried resitting the stem and uninstalling and reinstalling the drivers (tried 457 drivers as well).

    - Is this a stem issue connecting the the V2.5 pins?

    - a firmware issue? Drivers not installing correctly?

    - a PC issue? PC stopping the drivers installing?

    I’ve yet to tried the CSL DD on a different PC

    Occasionally the V2.5 will spurt into life on the CSL DD and the fanatec logo will show on the wheel and will detected button input, but then it’ll lag and stop detecting and you’ll hear the wheel disconnect.

Sign In or Register to comment.