ClubSport Wheel Bases discussion



  • @Vladimir Dobrosotskikh : You are wrong here!! Only Clubsport Base Support here!


    Have a connection problem with the CS DD and Formula Wheel F1 ESports V2.

    if I start the base the wheel was not recognized but if I pull out (with enough distance) and plug in the wheel , the wheel appear and works fine until power off the base.

    Is the Base broken or software error? Seems like WQR Chip Problem. Shoul I open a RMA Ticket?

    Installed latest Drivers on the Base, WQR and Wheel, and firmware manager says everything is up to date.

  • Hello everyone,

    I received my CS DD, Formula V2.5, QR2 Pro, and APM yesterday after I first ordered it with the V2.5X about 2 Months ago.

    After installing all the parts yesterday, everything worked well. Firmware updates worked without problems as well.

    Today the wheelbase isn't responding after pressing the power button. The power supply LED is still on, the wheelbase power button is NOT on after pressing the button, the wheel doesn't turn after startup, it is not recognized by the PC but the display on the attached Formula wheel is showing the Fanatec logo. Normally the logo should disappear after a few seconds but it is displayed continuously and the wheel doesn't respond to any inputs like the setup menu. The bootloader option doesn't work either.

    I am using the latest drivers (yesterday everything was up to date and working).

    I filled out the support form and submitted it a few times, but I didn't get a confirmation message. I hope they got it and someone can help me...

  • Gökhan OgulGökhan Ogul Member
    edited January 19

    today my CS DD now death too. My F1 Wheel eSports V2 has lost the connection for ever now. Seems to be a bug with the WQR chip. Can't connect it with the base. No Answer of Fanatec. I'll wait a bit then I will open a Paypal case.

  • THIS IS the same what happened to me. i dont have any update from them too . its been sitting for a month. i regret to buy their products in the first place

  • Now same problem with Power On. Can’t Power On the Base. Led ligt ist off and no rotation. :(

  • IT,s hurts that seeng my sel updating/deleting just solve the issue but hopeless&answered everytime.

    \I GUESS weve been curse in this CS DD 12NM unkown issue.. hunger to know the issue what cause, what solution can be.... once i get reund or RMA. i will never hesitate to post it on marketplace, traumatic experience that no one could.

  • the solution is to not buy fanatec, the best advice, it's absolutely inacceptable the CS DD issues

  • Gökhan OgulGökhan Ogul Member
    edited February 5

    got my new CS DD today back from RMA. Updated the Driver only on 454 and everything works fine now! :) I love it!

  • update: After update to 455 now same problems as before with my f1 wheel.

  • Gökhan OgulGökhan Ogul Member
    edited February 25

    Update: with driver/Firmware 456 my F1 Wheel issue is now fixed. Will alltimes recognized after cold start with attached steering wheel.

    only problem is now, that somtimes the wheel freezes and lost the ffb & connection to the base.

    so far, I‘m now more happy.

  • Set up my CSL DD with my CSL V2 Pedals and my F1 2023 wheel. Worked fine for the first day. Put everything away for the night and went back in the morning to race and my CSL DD won’t power on. Won’t show on my computer or any Fanatec software. When I press the power button there is no response. The power supply has a green light on it when plugged in. I’ve removed the QR2 base side and reinstalled to make sure it is connected. I’ve tried to power cycle the base. I’ve tried different USB ports on my PC. It just seems dead. Trying to be optimistic but I only was able to use it for 1.5 hours and here we are. Opened a support ticket last night but if anyone has an idea I’d appreciate the help.

  • edited March 11

    DD+, QR2 and a MClaren GT3 v2.

    Fanatec Manager says me that QR2 and steering wheel need an update. I click to do them with the auto update button. It ask me to unplug the steering wheel to upgrade the QR2, I do it and click OK, and finally it fail exactly like in this picture.

    I tried many times, tried other USB ports, tried again after PC reboot, tried after uninstalled & reinstalled the drivers... Fail, Fail, Fail.

    And I can't to upgrade the steering wheel Mclaren GT3 V2 until the QR2 is not up to date. GREAT.

    This firmware manager is a total garbage and a big shame about Fanatec which does nothing while many consumers have exactly the same problem.

  • Greetings, I have the same problem and after waiting 5 months for delivery, now it disconnects in the middle of the race, we must wait for the 457 to come out, maybe Christmas will arrive waiting for solutions.

  • They keep saying April release date for Driver 457. I guess they mean the very last day of April?Its been weeks now and nothing…

    Originally it was scheduled for late March.

    Bananas - brand new base to the market and people have to deal with all this craziness 🤷‍♂️

  • Can’t believe, after sending my bricked DD+ to repair center (Australia), the repair technician reset my DD+ to DD! It can only detect PC/Xbox mode now! So disappointed about Fanatec!!

  • edited May 2

    Hi everyone can someone help me with the clunky sound on my CS DD 12nm? The noise has suddenly appeared after about 1 week. The function does not seem to be affected. Does anyone else have this noise?

    Unfortunately, I have still been waiting for an answer to my ticket for over a week...

    I've made a video for you:

    My thread for this problem:

  • Hello sim racing friends, just a word on fanatec last month I upgraded from csl elite wheel and pedals to ClubSport dd plus extreme for the ps 5 gt 7 vr2 what a complete blast what a fantastic product!!!

  • Oscar PugaOscar Puga Member

    Enjoy it while it lasts Jon before yours is bricked along with everyone else's...

Sign In or Register to comment.