CSL Elite Wheel Bases (and Racing Wheels) discussion



  • hi guys good morning, I have the csl elite v 1.1 and I bought the universal hub v2. is it compatible with play 5? I can't even turn it on. I really need a hand, can you help me please?

  • Direct Drive Wheel for Gran Turismo doesn’t work with CSL Elite + as announced on the compatibility page. The four extra buttons do not do anything. Software is up to date. Can someone help if there’s a trick on it?

  • edited March 2022

    On console the 4 colored Dpad only work with the GT DD Base.

    They would only work on a CSL Elite PS4 Base on PC with the most recent driver 439.

  • @Maurice Böschen

    Bute the compatibility page says:

    “Hinweis: Das Lenkrad des Gran Turismo DD Pro bringt keine PlayStation®-Kompatibilität mit sich, wenn es auf einer nicht für PlayStation lizenzierten Wheel Base verwendet wird. Für die Verwendung auf PlayStation®4 und PlayStation®5 Konsolen ist eine PlayStation-lizenzierte Wheel Base (z.B. die Gran Turismo DD Pro Wheel Base) erforderlich.“

    So my Base of the „CSL Elite F1® Set - offiziell lizensiert für PS4™„ should be compatible.

  • edited March 2022

    That part does not tell you anything about the compatibility of the colored Dpads though.

    On PC yes they work on a CSL Elite PS4 Base, on console not.

    Could be written clearer in the webshop description though, Yeah.

    But they cant work on any other base on console as they need to be implemented to a game preset in the game directly and they are only coded into the GT DD PRO preset of the game.

  • Today I found out, that they work in GranTurismo Sport, in GT7 they don‘t. Both tried on PS5.

  • Thats because in GTS the wheel was hardcoded into the CSL Elite preset.

    In GT7 the GT DD PRO got its own preset and therefore the special GT Wheel is only coded into that preset and not into the CSL Elite preset anymore, only the P1 Wheel is properly coded into that preset, other wheels work with the same buttons the P1 has but with no extra buttons and switches like all the extra buttons and switches a Formula v2 for example has.

    Its just how the Game Developer has coded things into their game and its fully to them to add more wheels to more bases with more functionality.

  • William GreggWilliam Gregg Member
    edited March 2022

    I have had my GT DD Pro for almost a week. The center plastic part of the wheel (I think it is coming from there) is starting to creak. During turns, I hear a very distinct plastic creaking sound. It is not coming from the base, def from the wheel. I'm not grabbing the plastic part directly only the rubberized part at 2&10 o'clockish area. But it seems like just the twist from countering the torque is flexing the center plastic area where the spokes meet the logo and buttons. It is very distracting and annoying. Is anybody else hearing creaking on their GT wheel?

  • Mine is brand new and I am starting to hear a similar creak. Did you figure anything out? Or is that normal?

  • So I just tried a firmware update (to 439) from an older version, don't remember now how old, probably around 425 or so.

    Anyway, started the update, green progress bar moved about 5% and then hung. Waited for at least 20 minutes, clearly something had frozen and of course there is no elegant way to exit a firmware update. Trying to close the Fanatec software was just met with a warning, which is great if it hadn't already f'kn stopped working.

    Anyway, long story short I cut power to the wheel base in order to try the update again, there was really no other way.

    Now the wheel powers on, fans go to full speed and nothing else happens. Is the base bricked? Is there anyway to get it into a recovery mode?

  • Hi. I use a CSL elite 2.5 wheelbase and my force feedback works perfectly fine in every game except Forza Motorsports 7. Is there a reason for this? Is it not compatible? or is it supposed to work.

  • I need assistance. I purchased and received my Fanatec CSL DD-Pro Wheel Base, Steering Wheel, Load Cell Pedal set, and the 8nm box in late March of 2022. Upon setup I noticed that my steering wheel and Base Shaft was off center to the right by almost 1/2 inch. I thought calibration would fix issue but it did not. I been driving with it like this up to now because it takes so long to get one. However, I realize its a handicap having to steer one direction further than the other. So I'm asking if anyone has had this problem and if so what did they do to fix it. I texted Fanatec a few days ago but no response from their support team. Can someone help? I'm more than satisfied with the Load Cell Pedals, the steering wheel itself, and the 8nm box which all work beautifully, but the Wheel Base is a problem.

  • Good Morning.

    I would like to ask for advice. What wheel base do you recommend to play WRC generations? Should i buy the Gran Turismo DD Pro Wheel or the CSL DD 8Nm?

  • They are technically the same, only difference is that one PS compatible and the other is not. So take whatever you can get if you play on PC, doesn't matter.

  • Please can anyone help me, yesterday i was playing acc everything went fine for more then 30 min when suddenly i feel a knock in my steering wheel en from then on it was barely undriveble. The smallest steering movement i make had a huge impact on the steering wheel ( 1cm was enough to turn complete ) had to drive 30 min like this 🤬🤬🤬

    Anybody know the solution to this please ?

  • Bernd JankoBernd Janko Member
    edited January 2023

    Hello all. I am new here on the forum and hope my post is correct here. 

    I am the owner of a CSL Elite PS4 with McLaren Gt3 V2 wheel and the standard CSL pedals since 2019. 

    Now a few days ago a problem started. 

    I play iracing for 14 days. I have set the Fanatec recommended settings on the steering wheel and in the game and all drivers are up to date.

    No matter how I set the FFB (even at very low settings), my FFB goes off for a second after about 10 minutes after starting a race or when I'm driving on the training server and then rebuilds relatively quickly. I just can't explain where this can suddenly come from. I have never had this problem in other games. 

    It's a pity that the problem is there now, but I hope you can help me. I've already opened an official ticket on the Fanatec homepage, but I wanted to post it here on the forum because maybe more people will read it here and have ideas. 

    Thanks for any tips. 

  • CSL Elite Wheel Base + CSL Elite Steering Wheel P1

    Firmware 692

    Software 450

    Since updating to the new firmware and software, the FF can no longer be switched off completely. When switched on, the base constantly has an opposing force that is only gone when I switch off the base. After switching off, the steering wheel can also be turned very easily. When switched on, there is always a resistance.

    There are no more setting options in the software.

    In an old version I was able to turn off the FF on the steering wheel. Now it only goes to a minimum of "5"

    Does anyone else have this problem

  • You are in the (not so new anymore) Standard Tuning Menu with limited settings and ranges which was explained to you in a pop-up during the update process which you seem to have not read but just clicked away.

    To get back into the old Advanced Tuning Menu with all the settings and full ranges you need to press the Tuning Menu Button for 3 seconds while being in the Tuning Menu. Then FFB can also be disabled again (for whatever reason someone would want to do this...).

  • 216 / 5.000

    Even switching off the FF in the tuning menu has no effect on the resistance of the steering wheel.

    If you read and understood the message fully you would know that this is not the main problem....

    But to make you understand why it is essential to switch off the FF completely, try maneuvering a Fendt Farmer 900 with a drawbar with the FF constantly activated.

  • When you have a constant spring then the USB device driver is not installed properly.

    You need to uninstall the driver and reinstall it - with the base powered on (very important).

    Also the base should never ever be powered on before Windows has fully booted as then the constant center spring would also be active. So always let Windows fully boot and only then start the base.

    If none if this helped then you need to reinstall Windows.

  • Hello!

    Got my stuff 4/12 32023 Order :1087283

    DD Pro 8 Nm

    WRC wheel

    V2 pedal



    mm mm

    Have big problems with base and wheel


    The black clip was loose And before I discovered it was probably a bit of a USB C glitch.

    Bought a new 2 piece alu clamp, but the steering wheel loses contact with the base without the steering wheel hub and steering wheel separating/ sliding apart!

    Using 15 Nm

    Symptom: The steering wheel turns fully right atomatically several revulotion and loses contact with the base.


    WRC steering wheel gears 2 gears up on the paddle!

    I made a fault report 3 weeks ago but you don't respond to email, phone or chat!

    I can not drive????

  • edited January 18

    Hi everyone.
    I have a CSL v.1.1 in both Ps4 and Xbox and PC versions.
    The PS4 version has mechanical problems on the primary shaft (I think seized bearing).
    I ASK: can I "transfer" the motherboard of the PS4 version to the CSL xbox/pc to obtain a perfectly functional base?
    What kind of problems/attentions do you have?
    Thank you

  • Hi everyone!

    I have a quite strange question. Is there any way to make GT Extreme wheel work with CSL Elite v1.1? (i have replaced qr2 with qr1)

  • That`s a shame. Is there a list of compatible wheelbases for Extreme wheel somewhere?

  • Hi,

    i bought a CSL elite plus wheel base on eBay and use it with a P1 V2 wheel. It works normally with GT 7 on a PS4 Pro. However on a PS5 when I try to connect it, the wheel base disconnects after under one second while i am in the game. On the dash board it is connected longer but disconnects as soon as i turn the wheel somehow.

    Anyone got an idea?

  • CSL Elite ps4 connection issue

    Wheel base: 684

    Driver version: 455

    Problem description:

    Last time I used the wheel base a couple weeks ago it worked fine, a couple days ago the computer doesn't even show that it is plugged in. The base powers on and does it’s end stop learn but no output to the computer. Ive tried uninstalling drivers and re installing with no luck. Ive tried different usb cables and ports and windows doesnt even give the audible tone that a usb has been plugged in. ive cycled through modes and back to PC still no luck. the last thing i tried was to connect it to my ps4 and that also would not connect. I’ve taken the base apart and tested the board connections to the usb output and all have continuity. Any ideas it’s been a few weeks since I put a ticket in with no response

Sign In or Register to comment.