FanaLab 1.54.4 Download - Post your Feedback here



  • Todd MalekTodd Malek Member
    edited January 2021

    So since upgrading to the latest version of Fanalabs, it constantly crashes on me. It's been getting worse with each update lately.

    Here's the app crash log from my PC.

    Any ideas??

  • I am in the same boat, from 1.52 that I stopped working with Fanalab, it crashes after the first game launch. I have been trying all the versions and the problem remains. What GPU do you have? I have a RX5700XT.

  • So Fanalab is crashing here aswell.

    Hardware: podium dd2 wheelbase, formula V2 wheel, heusinkveld sprints

    Driver v400

    Firmware: wheelbase 684, motor 40, quick release 6

    Aditional software: crewchief, racelab overlay, heusinkveld smart control, trading paints

    The crash occures in iRacing and ALWAYS looks like this: everything works flawlessly in practice sessions, but as soon as i get to qualy or race sessions Fanalab simply quits. If i try to launch in again while in a qualy or race session it opens up and quits again after 3-4 seconds. Attaching the log so maybe one of you can help as this is getting very frustrating.

  • just today install this version. It came from 1.54.2, because in iracing, every time it started crashing, I have returned to 1.54.2 and perfect, I have the last driver. The car was the Kia.

  • Using 1.54.3. Also crashing a lot.

  • For people who experience crashes, please always upload your Fanalab Log Files and affected Windows Event Files. Otherwise it's hard to investigated because for me for example it's not Crashing..

  • Todd MalekTodd Malek Member
    edited January 2021

    Where can I get 1.54.2 or previous to that? Unfortunately in my cleanup exercise, I deleted all previous versions.

    I need something somewhat stable that will work.

    Edit: Actually I'll get 1.53 from the main site. That one worked better than either 54.2 or .3.

  • edited January 2021

    Hello Maurice,

    Since there are different RPM values for each gear on the P217, how do you translate it in Fanalad rev LED?

    Best regards,


    FYI 1.54.3 working perfectly without a single crash.👍️

  • Its not possible to make a P217 LED profile in FanaLab. You have to decide which gear you want to map or make some numbers in between each gears so they halfway match whats going on on screen.

  • Thanks for the swift reply Maurice.

  • driver : 400

    fanalab: 1.54.3

    fanalab crashes when playing iracing...

    I hope for an immediate solution soon..

  • 1.54.3,

    driver : 400

    crash here too on iracing /rtx3090

  • I rolled back to fanalab 1.53 and no more issues so far

  • Please also upload your Fanalab Logs and more importantly the Windows Event Log which shows the Crash. Otherwise the devs can not investigate because it's not Crashing internally.

  • To all who suffer from Fanalab crashing while playing iRacing:

    Most important is to have the Windows Event Log describing the crash.

    Please add them to the Fanalab logs and post them here.


  • Yep I too am using 1.53 now and it's been stable since.

  • DD1 Driver 400

    Formula V2

    CSP V3

    Below is from Win Eventlog:

    Name der fehlerhaften Anwendung: FanaLab.exe, Version:, Zeitstempel: 0x600aa123

    Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.746, Zeitstempel: 0x197b16c5

    Ausnahmecode: 0xe0434352

    Fehleroffset: 0x0012a842

    ID des fehlerhaften Prozesses: 0x3ef0

    Startzeit der fehlerhaften Anwendung: 0x01d6f4077fb37e3c

    Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Fanatec\FanaLab\Control\FanaLab.exe

    Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\KERNELBASE.dll

    Berichtskennung: 9a9bc99e-e458-4154-a6d1-a2bcce265e82

    Vollständiger Name des fehlerhaften Pakets: 

    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 


    Anwendung: FanaLab.exe

    Frameworkversion: v4.0.30319

    Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.

    Ausnahmeinformationen: System.ArgumentException

      bei System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializePrimitiveObject()

      bei System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32)

      bei System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeDictionary(Int32)

      bei System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32)

      bei System.Web.Script.Serialization.JavaScriptObjectDeserializer.BasicDeserialize(System.String, Int32, System.Web.Script.Serialization.JavaScriptSerializer)

      bei System.Web.Script.Serialization.JavaScriptSerializer.Deserialize(System.Web.Script.Serialization.JavaScriptSerializer, System.String, System.Type, Int32)

      bei System.Web.Helpers.Json.Decode(System.String)

      bei PodiumControl.PCThreadGameTelemetry.Run()

      bei PodiumControl.PCThreadBase.ThreadFunction(System.Object)

      bei System.Threading.ThreadHelper.ThreadStart_Context(System.Object)

      bei System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      bei System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      bei System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

      bei System.Threading.ThreadHelper.ThreadStart(System.Object)


    Name der fehlerhaften Anwendung: FanaLab.exe, Version:, Zeitstempel: 0x5fe3053d

    Name des fehlerhaften Moduls: GameTelemetryExtractor.dll, Version:, Zeitstempel: 0x5fe30536

    Ausnahmecode: 0xc0000409

    Fehleroffset: 0x00034efc

    ID des fehlerhaften Prozesses: 0x3714

    Startzeit der fehlerhaften Anwendung: 0x01d6f3fe501fdaaf

    Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Fanatec\FanaLab\Control\FanaLab.exe

    Pfad des fehlerhaften Moduls: C:\Program Files (x86)\Fanatec\FanaLab\Control\dll\GameTelemetryExtractor.dll

    Berichtskennung: 518d1bae-5292-43eb-b407-300248bbf52f

    Vollständiger Name des fehlerhaften Pakets: 

    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 

  • I’m haven’t an issue w the Fanatec popping up and then Fanalab crashes. So frustrating

  • i also get the fanalab closing error with iracing. event logs attached.

  • Hey, I'm having the issue where my wheel/wheelbase are not detected in the tuning menus. I have tried:

    • Repairing the driver using the installer
    • Uninstall driver, reboot, install driver, reboot
    • Change the installation path to the same folder as FanaLab (C:\Program Files (x86)\Fanatec)
    • Uninstall driver, reboot, install driver, don't reboot

    Not sure what to try next, any ideas?

  • Your wheelbase simply does not support this feature because it has too old electronics. Only the newer CSL Elite PS4 Base and v1.1 Supports the Tuning Menu in the driver and Fanalab, your older v1 not.

  • Rick WhitlockRick Whitlock Member
    edited January 2021

    Okay, I ordered the csl elite 1.1 wheelbase, how can I tell if that is actually what I received or if I got the wrong product? The box it came in indicates it is v1.1.

  • When your base looks like the one of the box and not with the mosaic front then you have the v1.1.

    I was wrong though, the v1.1 also does NOT support the Tuning Menu. Only the CSL Elite PS4 Base Supports the Tuning Menu function in the driver and Fanalab because of enhanced electronics.

    So unfortunately you can not use this function.

  • So this post regarding iracing settings in the tuning menu is impossible to follow then? It specifically has tuning menu settings for v1.1 and ps4 csl elite wheelbases. Sorry I'm just trying to figure out how or why this will or wont work.

  • You can still adjust the Tuning Menu through your Steering Wheel, just not through software like the driver and FanaLab. Therefore the iRacing settings still are valid also for your base.

  • I see, so this is done through editing an .ini file or something then? Where can I find this?

This discussion has been closed.