FanaLab 1.57.4 Download (Previously 1.57.2) - Post your Feedback here

Marcel PfisterMarcel Pfister Member, Administrator
edited October 2021 in FanaLab

FanaLab changelog since 1.54.4

  • Fixed: Steam game detection.
  • Fixed: RevLED issues.
  • Fixed: Crashes on GameTelemetryExtractor.dll.
  • Fixed: Crashes due to memory exemptions.
  • Fixed: Minimise windows function.
  • Fixed: Rounding and other issues of telemetry values for AC, ACC, AMS2, PCARS2, DR, DR2.0, F1 2020, iRacing, KartKraft, RaceRoom and rFactor2
  • Improved: Profile preview.
  • Improved: Memory consumption.
  • Improved: General performance.
  • Improved: Pop-ups now accept Esc and Enter key.
  • Improved: Increased minimum window dimension to prevent text overlaps.
  • Reworked: Brake Bias for ACC.
  • Changed display info "tc" to "[t]" when traction control is kicking in
  • Changed display info abs to [a] when ABS is kicking in
  • Changed P to [P] when in Pitlane for AMS2 and PCARS2
  • Added: CSL DD.
  • Added: Switching between Simple and Advanced mode of the Tuning Menu on CSL DD.
  • Added: F1 2021.
  • Added: More display telemetry data: the current ABS, TC, and brake balance settings for 7-segment and OLED displays.
  • Added: New telemetry values for AC, GRID, KartKraft and rF2
  • Added: Max fuel data on iRacing.
  • Added: Possible to use Enter key for saving Profile.
  • Added: New alternative images for Formula V2
  • Added: Support for iRacing ABS telemetry
  • Added: Added option to to adjust shift-point-brackets of the display function. Adjustable in raw RPM and %. Works like the RPM threshold for RevLEDs.

UPDATE: Changes of hotfix FanaLab 1.57.3

  • Fixed: CSL Elite WB 1.0/ 1.1 not detected.
  • Fixed: DD1 PS4 tuning menu support.
  • Fixed: FFS hint not updated to new name of setting
  • Added: Recommended profile for CSL DD wheel bases.
  • Updated: F1 2021 to use F1 2020 telemetry format for the meantime.

UPDATE: Changes of hotfix FanaLab 1.57.4

  • Fixed: Crash when starting FanaLab, caused by profiles from older FanaLab versions.
  • Updated: Some German hints which had spelling errors.
  • Updated: Recommended settings links for F1 2021 and F1 2020
  • Added: Links to compatible driver and FanaLab forum in the .zip instead of the readme.txt.

Known limitations of game telemetry and issues:

  • iR tyre temps sometimes differ from black box.
  • rF2 brake bias can differ very slightly.
  • R3E tyre temps slightly differ from HUD.
  • F1 2020 & 2021 tyre temp differs from dash to HUD.
  • Older profiles get converted and loaded with RPM instead of % enabled for the LED threshold. -> Toggle back to % and save again, then it works like expected.

Download (updated):

Link to compatible driver version:

How to report issues:

  • List which hardware, driver and firmware you are using
  • Cross check with other settings, games and wheels to see if it's a general issue or specific with to a game, wheel or setting.
  • Is it happening with just one game (which one) or all you tried.
  • Go into detail how we can reproduce the issue.
  • Post screenshots or videos if needed.
  • In case of a FanaLab crash, use the "Collect Logs" feature under "Settings" and upload them here.


  • Before someone asks: Yes, I already have my profiles updated and ready ;-)

    Here you go :)

    Changelog for my profiles (for DD2) since last release in December 2020:

    • Implementation of the new Display Settings TC, ABS and Engine Map according to what the car uses in game (e.g. TC, ABS and Engine Map Display settings enabled with Prio 1 for GT3 cars in ACC but only TC and ABS enabled for GT4 cars in ACC and none of them enabled in the Maserati GT4 car because the Maserati doesnt use any assists and GT4 cars doesnt use Engine Map except for the Merc where Engine Map Display setting is enabled etc.)
    • Implementation of the new Display Setting Brake Bias for games which support this new feature (so for games which use full BB values instead of .2 increaments or so (AMS2 and F1 2020)
    • Updated Base ITM auto-page-switch settings to adapt to the new Display settings, so only use auto-page-switch for features which the car and game actually supports
    • Adjusted RPM Ranges for pretty much all 133 profiles
    • Slight FFB updates to the AMS2 car profiles
    • Changed LEDs for AMS2 Ginetta GT4 and McLaren 720S GT3 car profiles as per latest game updates
    • Added new AMS2 car profiles for new Patch 1.2 cars: BMW M8 GTE, Chevrolet Corvette C8.R, Porsche 911 RSR GTE, Cadillac DPi-VR & BMW M4 GT4
    • Massive FFB update to the iRacing car profiles: 22 profiles were changed quite drastically to adapt to iRacings newest FFB updates which came with NTMv7 as most profiles were based on NTMv6 which had different FFB strength ( so you dont need to be Hulk anymore to turn the wheel of the Ferrari 488 GT3 profile (and others) anymore :D ). Also no profile exceeds FF80 (=20Nm Peaks) anymore to make conversion to DD1 easier (multiply FF with 1.25) without the need to also adjust the Max Force and Wheel Force values
    • Slightly adjusted RevLED RPM values for cars in iRacing which use different RPM ranges per gear to find a „middle way“ to get the Wheel LEDs at least somehow being accurate as best as it gets until FanaLab might support this special iRacing „feature“ properly sometime in the future so you can adjust the RPM values for every gear where needed
    • Adjusted RevLED RPM values for iRacings Porsche 911 RSR car according to Season 3 changes
    • Added ABS FlagLEDs for iRacing car profiles where the car uses ABS indicators in the car dash
    • Added auto-page-switch feature when Oil Temp above 125°C for iRacing profiles according to native Oil Temp warning implementation with iRacing Season 2 Build
    • Added new iRacing car profiles for HPD ARX-01c, McLaren 570S GT4, McLaren MP4-30, NASCAR Cup Next Gen Chevrolet Camaro ZL1, Porsche 911 GT3 R, Subaru WRX STI
    • Added F1 2021 profiles (because of a FanaLab issue temporarily disabled auto-page-switch feature for Best Laptime on page 4 though)

  • edited August 2021

    same problem here. fanalab won't detect wheelbase, wheel or pedals... any ideas?

    from the log:

    2021/8/17[15:52:47:554] [12228][12236] PCThreadDeviceWheelMain::PrivateDeviceWheelArrived | m_DeviceCollection.Add() failed!

    2021/8/17[15:52:47:554] [12228][12236] ==========================Device Detected==========================

    2021/8/17[15:52:47:555] [12228][12236] Wheel Base     : Not Available

    2021/8/17[15:52:47:555] [12228][12236] USB Pedal     : Not Available

    2021/8/17[15:52:47:555] [12228][12236] USB Shifter    : Not Available

    2021/8/17[15:52:47:555] [12228][12236] USB Handbrake   : Not Available

  • Make sure you also use Driver 410 and you dont change wheel base modes.

  • yeah i do. all other stuff works fine but only fanalab wont recognize anything

  • stays empty

  • edited August 2021

    You can try to uninstall Fanalab, reinstall Fanalab and in the installation process check the setting to reset everything to default. This will reset everything, maybe this helps.

    Otherwise the devs might need log files to investigate and You would need to wait for a fix then..

    Also make absolutely sure you are on driver 410, old drivers wont work anymore.

  • drivers are 410

    the log only says this:

                       ================== Fanalab V1.57.2 | Aug 16 2021 LogIdx: [0] ==================

    2021/8/17[19:11:15:564] [20440][20412] Driver Version   : 8.42.0

    2021/8/17[19:11:15:564] [20440][20412] Minimized at Start : False

    2021/8/17[19:11:15:564] [20440][20412] Path        : C:\Program Files (x86)\Fanatec\FanaLab\Control\

    2021/8/17[19:11:15:564] [20440][20412] ==================================================================================

    2021/8/17[19:11:17:575] [20440][20412] PCThreadDeviceWheelMain::PrivateDeviceWheelArrived | m_DeviceCollection.Add() failed!

    2021/8/17[19:11:17:575] [20440][20412] ==========================Device Detected==========================

    2021/8/17[19:11:17:575] [20440][20412] Wheel Base     : Not Available

    2021/8/17[19:11:17:575] [20440][20412] USB Pedal     : Not Available

    2021/8/17[19:11:17:575] [20440][20412] USB Shifter    : Not Available

    2021/8/17[19:11:17:576] [20440][20412] USB Handbrake   : Not Available

    2021/8/17[19:11:17:576] [20440][20412] ===================================================================

    2021/8/17[19:11:17:666] [20440][20412] Memory Usage: 216448KB

    2021/8/17[19:11:25:181] [20440][20412] Memory Usage: 219132KB

  • As said try Fanalab reset and also re-install driver 410 again with all your devices powered on during installation

  • yeah, i tried all this. but nothing work

  • edited August 2021

    to be honest.... that sucks really hard. i mean okay shit can happens, but how in that world is something like that possible. the only thing i wanted to have is f1 2021 support. and what i get is a complete fucked up fanalab. i mean the rest all works fine. the wheel and all stuff is recognized by everything.... but it's really shitty... i believe ithas something to do with the new ui stuff.... pretty sure because on a dd (does not matter if csl or podium) it seem like its working fine

    and it really feels like everytime there is an update something shitty wont work and it take a long time to resolve the issue

  • edited August 2021

    It can happen because you are the only one out of more than hundreds of Testers where it's not working.

    Those are things which just can happen. For sure it will be investigated and hopefully can be fixed if it's an issue from FanaLab and not from your PC.

    What Base, Wheel and Pedals are you using?

  • but where should be an issue on the pc? that makes absolutly no sense.... and before 410 all worked fine with 1.54.5 before

  • CSL Elite 1.1, Formula v2, CSP v3

  • Thanks, that's it.

    Unfortunately no Tester had a CSL Elite v1.1 it seems.

    I just grabbed my, connected it, updated Firmware and indeed I dont get active devices in Fanalab.

    CSL Elite PS4 Base and CSW bases are fine though so this only seems to affect CSL Elite v1 and V1.1 bases.

    Thanks for the issue report, forwarded and hopefully will be fixed VERY soon.

  • Okay Thank you Maurice, seems like we got the issue there :D

  • updated but now my tuning menu does not display on fanalab

  • everything else works fine, just no tuning menu display

  • David NorthDavid North Member
    edited August 2021

    Exactly the same for me. Using Podium PS4 on PC and the above fanalab 1.57.2 and driver 410.

    Also, all the default profiles for the games have gone. I've been relying on these as starters because I only got the wheelbase a week ago. All the ones people post are so specific, and the ACC and AMS2 default ones you had were working nicely for me :( (I now don't have any defaults for ANY game. Just the ones recommended on this forum by fanatec would be nice.

    I was using Fanalab 153 and driver 402 before and it was all quite nice being able to just push a default and play.

  • Are you all also on latest driver 410 or do you still use an old driver?

  • Michael SlotMichael Slot Member
    edited August 2021

    So this is absolutely an issue for Podium bases as well, not just CSL

    I uninstalled both drivers and Fanalab

    Cleaned the registry with CCC

    Re-installed driver 4.10 and FL 1.57.2

    So.. Now Fanalab can't open. Splash disapears, nothing further, logfile is empty.

    My CLS elite pedals can't be detected under properties unless they are hooked in the Podium. I normally use the USB.

    Willing to test if i can be at any help.

    Br. Michael

  • guys, could you please maybe try to repair the driver and reboot the system again. Im on a DD1 aswell and I got a tuning menu in Fanalab 1.57.2.

    If that would have been a major issue in beta testing we would ofc have waited for a fix...

  • Hi Maurice,

    Can these profiles be used with a CSL DD or CSL Elite? thanks for the help.

  • No luck with repair etc.

    Been through my 'list' of possible work arounds based on earlier experiences, but since not a single line of log is written by FL i'm a little lost.

  • I have exact same issue with empty tuning menu after updating firmware and Fanalab. I also have a DD1. Wheel is 911 Cup Podium with endurance module.

This discussion has been closed.