ClubSport Wheel Bases discussion



  • BLI = ABS, the name was changed some time ago, because it had nothing to do with the ABS of the cars.

  • Miguel PeresMiguel Peres Member
    edited January 2021

  • Hello,

    I sent an email to Fanatec but I just got my new CSW V2.5. I have had it for just 3 days and put only 3 races on it. I was in the middle of a practice and the base shut off and it won’t turn back on. I’m in a little panic cause I payed a lot of money for it and if it’s broke it’s been less than a week of owning it. I tried unplugging everything and reconnecting and nothing. It will not turn back on. Tried with universal hub on and off. I had no overheating issues. Just shut off and I cannot get it back on. Tried troubleshooting as well by holding start button and nothing. If anyone can help it'd be greatly appreciated.

  • Blue light should just be on right? Cause it is indeed on.

  • Yes that is all on. Which is why I am assuming it is in the base. I just dont understand what happen. Just annoyed and want an answer.

  • And I would like an answer soon so if I have to return it for another so I dont get screwed.

  • 5x motherboard?

  • Hello,

    I have a big problem recently. My force feedback on my CSW 2.5 is randomly cutting off on ACC on the right handers corners only, and comes back as the corner ends. I say randomly but I feel like the longest I leave both ACC and wheelbase on at the same time, the higher is the risk of the issue to happen. Firmware and drivers are up to date and I hear the fans of the wheelbase runing normally when they need to, and I don't have an excessively strong FFB, it's in fact actually quite low as I turned it down of 10% in game to try and avoid the issue. As an example, before I restarted my game and my wheelbase, I was on a specific car/track combo and everytime I turned to the right the ffb was cutting off completely and coming back again as the corner was ending. I then restarted both game and wheelbase, and the problem disappeared.

    But I am a top driver on ACC this has happened to me already twice in racing scenario as I was fighting on a top level race. And it also happened to me this evening on a practice session.

    I bought your wheelbase for 550€ plus all the other equipment I bought on Fanatec because I know you are a great company, but for that price I would like to not be scared of my FBB cutting off everytime I turn right on the racetrack.

    If that may help I have a Formula V2 rim and CSL Elite LC pedals.

    Thanks in advance for your help

    (I am putting this message everywhere I think it is correct to put it)

  • I just received my clubsport wheel base. Not even 2 hours into use the wheelbase has randomly shut off. i am able to turn it back on but only after i wait a few minutes after being unplugged. at that point its anywhere between 15 mins to 2 hours and then shuts off again. whats the issue? i have read it mat be the power supply.

  • Ok. Do you have the newest ryzen or perhaps a 3xxx CPU? There's an issue with 4xx and 5xx motherboards at the moment,. Some USB-ports won't work properly.

    r/Amd - AMD answered my ticket regarding the connectivity issues

    55 votes and 48 comments so far on Reddit

    Perhaps its this. But it could also be a Fanatec issue, ofc.

  • Hi, I have an issue with wheel base v2.5, my current motor firmware shows 0 and shows that is a firmware v22, when I try to update, receive message : A problem has been encounter while starting update mode (0). Please contact Fanatec supporter help

  • I hope you guys are doing well, but after 2 days playing Cars 2 and Assetto Corsa with no issues, the steering wheel and pedals stop working when I try to start a race. In Project Cars 2 I can move throughout the menu and with the Fanatec controller everything is showing up correctly but just does not work.

  • Hi all. New Fanatec user here. I have all Clubsport gear, including the CSW 2.5. It’s been making some pretty obnoxious clunking noises when turning off of the lock stop. Particularly when it changes direction quickly from being locked all the way to the right. Sometimes i can feel the clunking in the steering wheel as well. I have a video clip of this if it can be posted. Does anybody have any ideas or should i go ahead and start a support ticket? I should hope it’s not an actual issue, as it’s only about a month old and i only use it a few hours a day a few times a week. It seems to get worse with time and use though. Thanks.

  • Hello there I already submitted a query for my issue to customer support but I am going to ask here as well if anyone got a fix 😅 So downloaded driver 402 and installed it. Turned on my clubsport V2.5 on and I was prompted to update. Update gave an error and the start button was flashing blue. After that the base would not react to anything and will not power at all. Now if I hold the start button it just starts the fans and there’s no reaction at all. If I release start button it just stops and that’s it. I’ve reinstall and reconnected everything, disconnected the base from power supply for more than an hour and same thing

  • Is there a way to instal new firmware into and flat/empty base of boot loader ain’t working on mine and on another pc ?

  • When rotating, I feel and hear a slight vibration in some positions of the steering wheel, and this is when the base is off. This can be compared to the vibration during rapid rotation of csw v2. 5 on the DRI -5 settings - there is a slight vibration, the resistance of the motor, here is such a thing in my base :(

    Video: (do not pay attention to the clicks in the video, these are the buttons on the steering wheel.)

    UPD: Yesterday, strange clicks appeared in my base, which definitely can not be in a working base. I thought the base needed a run-in, but after a while the vibrations in the base only increased. Also, the friction in the base - when you quickly turn the steering wheel, the base whistles from the friction.

  • Hi, Does anyone know when the Clubsport v2.5 will be back in stock ?

  • Peter PenevPeter Penev Member
    edited May 2021

    Hello all, I already submitted a query for my problem to support but I am going to ask here as well if anyone has encountered this issue, fixed it, or had to inevitably send it in for RMA.

    I was playing Assetto Corsa, during a bad oversteer I was giving a hard counter correction and the wheel base shut off. The base is a CSW v2.5, less than a month old, and maybe logged just under 20 hours of play time. I tried to restart and when I did I noticed the rear fan juddering as if receiving an interrupted signal, NO light illuminated on the Start button, and the blue LED on the power supply was blinking. I attempted the basics disconnect power supply and wait for backup power to drain before reconnecting, same thing. Obviously with this issue the computer doesn't recognize the wheel base, but firmware was at 402 already I just un-installed and re-installed regardless, same thing. Disconnected the steering wheel and tried to start, same thing. Tried holding the Start button for 8-10 seconds(and longer) to see if it will go into boot mode, same thing. I restarted my computer and here is where things changed slightly. After restarting the computer, the blue LED power supply light is now steady, the rear fan does not Judder at all. Basically the wheel base is dead, I swapped power supplies with a buddies CSW v2.5 and omitted the psu as a failure. Any other direction that I can possibly be pointed in to try short of opening the unit since I assume it's still in warranty? I don't want to wait almost a month for an RMA on a product that I've had for less than a month, and less than 20 hours of play-time... Thanks in advance community

  • Hello...

    CSW V2.5, CS Universal Wheel Hub. Was in a race F1 2020 a pop up window says a cable came disconnected and steering cuts out , no buttons or leds work on the hub. The power button on the V2.5 after booting up has the led's blinking off in a clockwise motion around the center button. I don't know if it's the hub or the base. I did all the usual troubleshooting with drivers/firmware, cables and still a no go. Started a support ticket but so far heard nothing back. I noticed elsewhere here a person had the same problem a year ago but no solution was shown. My set up is only four months old and was working fine. If anybody can point me in a direction of a solution It sure would be helpful. Thank You in advance.

  • From what I just read on the blog the CSW 2.5 is no longer in production. Being replaced with the CSL DD and power boost kit.

  •   hello robin ...
    It happens that exactly the same 
    thing happened to me last night. 
    If you found a solution, could you share 
    it to see if I can solve my problem, 
    it seems that the people of Fanatec 
    do not care much about their clients.

  • Hello

    When my Fanatec Weehl Base V2 is cold, the fan speed always runs full. Only when it gets a little warmer it works normally again. Does the temperature sensor have a defect?

    Does anyone know what this is?

    Am grateful for any help

  • So when do we think CS DD will be coming out? Spring/Summer 2022? ;)

  • Bonjour,

    Voilà j'ai acheté une Base V2.5 en Décembre 2020.

    Hier ma base s'est arrêté en jeu, et maintenant impossible de la rallumer...

    Des solutions ? Ou une idée ?

  • Hello ,

    first of all sorry for my englisch

    i have a clubsport v2 en i bought a mclaren gt3 v2 wheel is it compatibel because i cant find it

    thanks guys

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Geoffrey,

    Yes it is. This is the Compatibility section from the McLaren product page:

    [Fanatec Community Manager]

  • Can you maybe help me how to install it?

    i dont know how


Sign In or Register to comment.