Fanatec Driver 423 for CSL, CSW and Podium WB (all wheels)



  • Has nothing to do with the Quick Release. It's a Firmware issue Fanatec cant reproduce and therefore cant fix yet.

    So yes if you have the issue then you have to downgrade the firmware back to 684 which is included in driver 402.

  • Maurice,

    DD2 here, there's something wrong with the UI on shifter calibration, the indication on the UI is different from what the base asks, and you need to respect what the base asks otherwise the calibration will be wrong.

    Another thing, I've never had issues with missing inputs or connection losses, but yesterday while on ACC, for some reason the wheel display and LEDs were working but all buttons suddenly were dead, all I did was remove the wheel and put it back in and everything got back working, this happened with a FV2.

  • Marcin PluskaMarcin Pluska Member
    edited October 2021

    Hello Maurice, I just investigate the problem. Because I’m facing low torque issue with BMW GT2 rim I have rolled back to 402 drivers and 684 fw. After rolled back fw I installed 415 drivers again but without updating the fw. Then the WQR fw is show 0 value but the comment is that the wqr fw is up to date.

    So the problem with WQR 0 occure when installed 415 drivers and old 684 fw.

    When Installed is 402 drivers and 684fw the WQR showing correct v6.

    When installed 415 drivers and 686fw also WQR showing correct V6 version. But in this case the low torque issue is persist with BMW wheel.

    can you also upload Fanalab 1.54 for 402 drivers because when installed 684 fw and 415 drivers then fanalab don’t recognise the wheel base and not working properly.

    thank you!

  • Upgraded to driver 423 from 402 and can confirm the issue with the low torque on the DD1 using a Porsche 918 RSR wheel. Went back to 402 for now until this issue gets resolved as it made Dirt Rally 2 nearly uplayable with how weak the FFB felt.

    I can provide more info as needed but I basically just updated the drivers without uninstalling anything so not sure how Fanatec cant reproduce this.

  • ------------------------------------------------------------------------------------------------------------------------

    CSL DD

    • Fixed issue where BMW GT2 funky switch had ghost inputs to all other buttons.


    Both me and a friend of mine who has the same setup (csl DD with BMW GT2-wheel) updated driver and firmware and still the same problem.

    Cant use the funkyswitch without opening the setup-mode and locks itselfs.

    Then you have to restart the csl DD to continue.

    Any ideas ?

  • Still have ghost issues with my BMW gt2 and CSL DD. They seem slightly better but still huge issue! Whenever I use the d pad after some clicks it opens the tuning menu and wont let me exit it! So I have to restart the base to fix the issue. Please fix this

  • DD1 PS4 with CSW V3, handbrake and shifter and driver 423, all firmwares updated.

    When I want to manually calibrate the pedals, I only get min-max buttons for the 3 pedals, not the handbrake.

    I did have those min/max buttons of the handbrake in version 415.

  • edited October 2021

    You did have the buttons in 415 but they didnt worked.

    The handbrake can not get calibrated when connected to the base or pedals. Therefore the non-functional buttons were intentionally removed from the UI.

  • Thanks Maurice, saved me time by not having to reinstall.

    The handbrake could be calibrated when connected to the base in the old "Game Controllers" settings I believe?

    Or is that just me remembering it wrong and I calibrated them when updating the pedals?

  • This was tested internally and no, the handbrake also couldnt be calibrated in the old UI when connected to the base.

    It can only be calibrated when used with the optional USB Adapter. When connected to the base it only works in an automatic Analogue mode where it automatically calibrate the axis when you pull the handbrake.

  • only idea is fanatec never tested a very popular wheel on a very popular wheel base hahah. Seems crazy that they never noticed such a common control to a wheel. leads me to believe very little testing..

  • now when turning off the base it is not necessary to press the button for 5 seconds, right? I have noticed that it turns off instantly when I press it

  • Can confirm with the new FW for the CSL DD I still have the random button activations even in the control panel with the BMW GT2 wheel, therefore the dpad function is only available in the setup menu, not even in the control panel. Also I can't get out of the setup menu once entered.

    The loss of dpad function in the control panel and in game is not limited to the BMW GT2 wheel, my old P1 also loses its dpad functionality.

    Had to roll back because I need the dpad for the pit stop menu in game, so I guess I will be stuck with the P1.

  • Which driver did you roll back to? If i do the same should my dpad work?

  • hello !! my god, the beta 423 version more force more sensations ????? dirt.2.0 asseto corsa ... how to put back the 415? thank you (ps4_ps5 podium) or put back in version 423😉😶

  • it was never neccessary to hold it for 5 seconds, 2 seconds were always enough ;)

    But yes, the display now goes off after 2 seconds to indicate you can let loose the power button ;)

  • CSL DD has had the same issue with the Hshifter calibration UI mismatch.

  • Andrew MorrisAndrew Morris Member
    edited October 2021

    Unable to update CSL PS wheelbase to FW 687. Keep getting this message

    EDIT: Uninstalled all drivers for Fanatec, re installed and updated fine.

    Also was hoping this update would include support for the podium button module on the CSL base :(

  • This has happened too many times since updating yesterday for it to be a coincidence. This never happened with 415 or any other version.

    DD2, Clubsport Formula V2. Updated to the latest firmware and drivers, rebooted, calibrated, no errors to report.

    Racing in ACC. I have Pause configured to use button 11 on the Formula V2.

    Middle of a race and all of a sudden Pause/button 11 stops working. Exit out of the game, open Fanatec wheel properties, and all of the buttons and paddles respond except for button 11.

    Two ways to get button 11 working again. Switch to Comp v2.5 mode and back to PC mode, or power cycle the DD2.


    If I pause ACC with the keyboard, go into Controls and reassign pause to a different button, the new button assignment works and I can continue racing.

    If I exit ACC, open rFactor 2 or any other game, prior to opening Wheel Properties button 11 doesn't work in that game.

    No other button functions are assigned to button 11, just Pause.

    It's like mid-race button 11 gets disabled and cycling the DD2 is the only way to get it to respond.

  • Just an FYI never tested this in the past so may have always been this way.

    Updated DD2 and ClubSport Formula V2 to the latest firmware and drivers.

    Open Fanatec wheel properties app, click any button/switch on the Formula V2 and you see the button/switch illuminate in the wheel properties app.

    Except for button 24, the one in the middle that changes the mode of the multi-function switch or whatever it's called. When you rotate switch 24 it updates on the DD2 display, changing from Clutch/Handbrake to Brake/Throttle etc. However, the button in Wheel Properties doesn't illuminate as the rest of the buttons do.


  • edited October 2021

    That's normal and intended as it cant be mapped in a game.

  • Neil ReubenNeil Reuben Member
    edited October 2021

    CSW V2, Formula V2, CSP V3, SQ1.5

    On Win 11, Install went fine, Wheel and base recognized. Full update only did the wheel, then prompted for more wheels to update. But I only had the one.

    Had to use manual to select the base. After update base is left in xBox mode rather than PC so UI disconnects.

    Pedals connected via USB did not activate the new UI, I guess because I only had pedals connected. But update worked fine with the old game controller UI.

    With the pedals connected to the base, the new UI displays all the functions/buttons/tests.

    Shifter calibrated fine

    Game testing not yet complete but not seeing anything notable yet

  • As Fanatec can not reproduce this low torque issue, are not willing to take up customers offers to test with their problematic hardware and have not solved this problem in over 3 months why do I get the feeling this issue is not been taken seriously enough..? All we read is it effects a low amount of users and it can not be reproduced however we are trying our best to fix it bla bla bla.. What is their best effort..?

    To me there seems to be quite a few users reports of this issue & secondly if you can not reproduce this issue and are not willing to take up customer offers what is really the plan to fix this problem..?

    It sure would be nice to know what is actually being done to rectify this issue rather than reading generic responses and this is nothing against Maurice & Co. Like others that have spent close to $10K with this company I think that 'somewhat' entitles us to little more information that what is currently been provided..

  • It also makes me think of the multitude of other users who don't have issues because they don't update their drivers and firmware regularly.

    I bet if all fanatec users updated their firmware then we would see a much larger number of users with the low torque issues or button issues.

  • 4.15. Deinstall 4.23, reboot, install 4.15, reboot, then flash the firmware back to the version in 4.15 and the dpad works again for me using the old P1.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Is the rumble working with the test button in the driver?

    Do you use a rumble feature of a game, FanaLab or the BLI setting?

This discussion has been closed.