DD1 Unknown issue (video clip)

Hello i got a issue with my DD1. if somebody knows what to do in my case i'll be happy to take your advices.

Here is the video :

Thanks for your time and your help 🙂


  • Contact the support. That motor is dead.

  • I've contacted the support already since last Friday but it will take something like one week for them to anwser. Last time, (Last month) it took something like 6 days to anwser on another issue...

  • Not what you want to hear, but if it only takes 6 days for a response, consider yourself lucky. There have been many reports recently of it taking up to 2 weeks or longer. Nothing to do other than to wait, I'm afraid.

  • I was just related what happened i know that there are situations more complex indeed.

    After searching a bit on the web and discords some guys told me to try to downgrade the firmware. i have currently this :

    Any idea how to find older versions of those?

  • A downgrade will not help with the issue you have.

    It's clearly dead and ca not be resurrected by the user.

    You have to wait for the support. There is nothing you can or should do or try at this point.

  • I recently had an issue with a DD2 (after 2 1/2 years) that needed to sent back. From start to finish it took 6 weeks from initial ticket to receiving a new DD2. There was a one week delay for me as where I live there is no parcel pickup service so had to ship it to them myself. Which meant a trip to the post office that I couldn’t do straight away.

    The fact you have sent a video clearly showing the issue I suspect the next time you hear back it will be asking you to return the item.

    I know the time it takes is a little frustrating but once the item was sent the process was very quick.

  • All right Gavin. Yes i had done the same thing last mounth be cause i had another issue. it took overall 4 weeks wich is not bad, i was satisfied with the service and happy with the repairs but to have another problem just when i receive back the DD1 is frustrating for sure :/

  • Fanatec service responded yesterday (friday), they advice me a fwew things but nothing changed.

    That being said i may have found the solution for my DD1 : i removed all the drivers in joy calib and also in the control panel (devices and printers). It seams like the old driver was there at the same time of the new. because when i was opening fanatec soft by opening "joy calib" the new page opened. But when i opened the fanatec menu by opening the usb DD connexion in the devices and printers path, it was the old one that pop up before having an error message. So when i had only the new driver, i reset all the sensors, recalibrate and for now i have no more this strange wiggling thing.

    In game also no problem anymore so far, it's time to test a fwew laps and see if the problem is really solved (fingers crossed)

    Keep you on touch

  • It works now problem solved.

    To summarize i followed the Fanatec support instructions (remomove all drivers etc.) and then i unistall and deleted the Fanatec usb connexion in "devices and printers" sexion. After That erased the sensors, calibrate again and it's done

    Thanks for you help, and also to the support of Fanatec🙏

  • Well my DD1 is dead again.... Same problem again, Maurice was right since the begening. It happened again on a right tigh corner.

    Waiting for the answer of Fanatec service, there is nothing more i can do 😕

Sign In or Register to comment.