Fanatec Driver 442 (Beta) for CSL, CSW and Podium WB (all wheels)



  • Marcus FehnMarcus Fehn Member
    edited June 2022

    As for the McLaren wheels -- the bootloaderRecovery doesn't even seem to launch.

    And here are the log files.

  • When I try to update my Formula v2.5 x from v43 to v45, this message comes up

  • What is Fanatec planning to do for all the customers who have bricked wheelbases thanks to a failed update with an incorrect label?

    Losing access to a product as expensive as a Podium wheelbase due to Fanatec's inability to release a functional update is unacceptable when couples with multi-week support processes.

    Fanatec needs a cross-ship option, especially for products broken by their own releases. Fanatec also needs to ensure all support tickets are addressed within 24 hours. These are expensive items, and I find it hard to believe your margins don't allow for a proper support staff.

  • I feel most sorry for those with out-of-warranty equipment. Fanatec needs to honor any repairs/replacements that stem from this botched release.

  • Given the issues some are experiencing, do you think it’s wise to downgrade to the previous 439 driver and firmware? Or if our update worked fine should we not be worried about running it?

  • The issues some are experiencing are actually update or downgrade issues and a lot of issues with "bricked" bases actually were caused by downgrading back to 439 (or another older driver) in a wrong order (some bases btw could get resurrected successfully in the meantime with the correct downgrade order).

    So it's currently not a good idea to downgrade if you dont have issues with 442. Just leave it as is if everything is fine.

    The whole downgrade process is planned to be simplified a lot with the upcoming re-release.

  • Oh okay, yeah my dd1 went through the firmware updates perfectly fine. Something I’d like to report that I noticed tonight, about 4 hours of run time into the new driver/firmware, I’ve noticed a VERY slight vibration in my formula v2 wheel. Settings don’t affect it, and it’s constant. I don’t feel it in the dd1 base housing or the shaft even, I only feel it in the grips and face of the formula v2 wheel. It’s almost like the vibration motors in the grip are just ever so slightly getting some power.

  • Check if it's not issue similar to mine, that sometimes vibration in my formula v2 wheel like to "stick" for longer time. As temporary workaround by advice of Maurice i switched off in my settings profile in Fanalab for ACC Rev Limiter Vibrations ..

    "The stucking wheel vibrations are a FanaLab related issue.

    So far this got reproduced but only for the Rev Limiter Vibrations and only for the Steering Wheel, on the pedals it's fine. The issue is under investigation."

  • Thanks for the advice! I actually don’t use fanalab, and I have the SHO setting turned off so I’m not sure if this is another issue but I will mess with it some tonight and see if I have any luck turning off pedal vibrations

  • To feel very faint "vibrations" is normal. What you feel is the motor. More noticable with a small Formula Wheel, less noticable with a big heavy round steering wheel but it's always there on a Fanatec DD.

  • Tbh, I don‘t really care about warranty, I care more about the slooooooow reeeeeespooonse tiiiimeeee here and everywhere else. I for one am just sitting here, not knowing what to do now, no timeframe, nothing. Sent logs, no reply. Am I supposed to just wait for a possible fix, the try again and then wait even longer?

    I was now forced to buy yet another wheel via second hand, just so we can participate in races this weekend… it‘s a total waste of time and money.

  • I don’t feel it in the motor shaft which I would think I would if it was the motor. It definitely feels isolated to the grips on the v2 but I’ll mess with it some more tonight and see how it feels. I don’t recall feeling it before and I’ve had the dd1 for almost a year. I appreciate the responses

  • That's because the motor is more or less disabled when no wheel is attached. You can also click on the FFB test button in the driver UI and it will not activate. Only when a Wheel is attached the motor actually awakes and makes those vibrations (which you also can not mitigate with settings).

  • That makes sense! I did try to feel it through the shaft when a wheel was connected also, maybe there are too many collars and what not in that area that dampen the vibration but it sure feels like the rumble motors are just barely active. Thanks for the help, I’ll spend some more time on this firmware/driver tonight

  • Loving the updates on the DD2 so far but I have encountered the steering angle bug 4 times in the last day. Playing iRacing the steering jumps to a seemingly random angle for about one frame or so and gives a massive jolt through the wheel. Frequency for me is about once every hour, making the base very hard to trust for races at the moment. DD2 lastest firmware and CSW F1 2021 latest firmware. DD2 ITM is set to the Fanatec logo at all times and the issue persists. Unfortunately I do not have video of the issue but it looks identical to the video already posted on this thread.

  • Have you updated the firmwares in the wheel base as well? Or did you just update the driver?

  • As I stated in the post the DD2 (all components) is on the latest firmware. All my Fanatec devices have been fully updated and I am running the 442 driver. I have never encountered this issue before updating.

  • I had no issues updating wheelbase, steering wheels, V2.5 and Podium Hub with Endurance Botton module, and V3 pedals, the only thing I am having is oscillation if I let the steering wheel go.

  • I read how fantastic the new driver 442 was so I decided to give it a try. I downloaded the driver and proceeded to firmware manager. I used the green button to update. The update failed and gave me an error message. At the same time the fan came on 100% and now runs at 100% every time I turn on the wheelbase. I tried again with a different laptop and got the same result. The menu on the base still lights up and works. I can navigate through it no problem, but the wheel is very heavy and when I tried to use in game it did not work at all. The Fanatec control panel still sees the wheelbase, steering wheel and shifter but it won't update the motor firmware. I see on the forum that you stopped allowing downloads of this new driver and provided a quick guide to try and recover the wheelbase. I followed all the steps in the quick guide, but I still have the same problem. I tried going back to Driver 439 and 440 but still I got the same result. Now I believe I have a mix match of firmware. I have attached some of the Fanatec Data logs to the service ticket. I absolutely love my Fanatec products and I would love to get them back to a working state. Please advise on how I should proceed. Thank you for your time!

  • If anyone downloaded the new beta firmware before it was taken down, can you send it to me. Thanks in advance

  • Jonathan you got a pn

  • Good afternoon,

    two weeks ago I had the same issue already (I posted it here on 5th June):

    • Wheel Base Model (product ID): DD2
    • Steering Wheel Model (product ID): Podium Wheel Porsche 911 GT3 R with Button Modul Endurance
    • Driver Version: 442
    • Base FW Version:
    • Motor FW Version:
    • Steering Wheel FW: 6
    • Button Module: 21
    • Wireless QR: 6
    • FanaLab Version: V1.64.5
    • Tuning Menu settings: Fanatec recommended for iRacing
    • Driver/FanaLab installed on C: drive or else? C

    After updating on Friday (3rd June) I still had the following issue in iRacing, which was meant to be fixed now:

    • Fixed rare and brief jump of steering wheel position. Most noticeable in iRacing by a rapid steering angle change only visible for ~1 frame. Could be felt as a jolt like sensation. 

    On the old version that problem occured like around every 6 months. Now after the update I had the problem in the first 4 hours of using it (of course it might be just a coincidence). And now after two weeks it happened again. This is MUCH more often obviously than before the update.

    Following a video of the issue in slow motion:

    Thanks in advance if you fix this please!

  • For those having a problem during the update of their DD, cut off all the other USB peripherals, this was the problem for me, if your base is no longer recognized by the fanatec software turn off the base and turn it on while remaining pressed on the button at the back for 10 seconds a led should flash and launch the fanatec update software, your base is in recovery mode and you can do the update.

    I had a lot of worries that many have had and by doing this the update was done without worries.

  • I apologize I forgot to post these with my original post:

    • Wheel Base Model (product ID): Podium Wheel Base DD1 PS4
    • Steering Wheel Model (product ID): Clubsport steering wheel F1 PS4
    • Driver Version: Currently 440 but I have also tried 339 and issue occurred when I had 442 loaded
    • Base FW Version: 692
    • Motor FW Version: 3
    • Wheel FW Version: 41
    • FanaLab Version: Not installed
    • Tuning Menu settings: NA
    • Driver/FanaLab installed on C: drive or else? Yes installed on C: Drive
    • Note: No other devices connected via USB

  • Wondering if anyone could plz send me the 442 driver if they happened to download it before it got taken down, the wait is agonizing

  • edited June 2022

    Suggest you wait for the new one, cause the UI or user error (like me), either scared a few people until they resurrect the base or bricked their hardware.

    It worth the waiting. 442 was very good.

  • I've never had an issue going through the process before and I haven't missed an upgrade for 2 yrs

  • edited June 2022

    Me neither. I did a mistake for the first time though but thankfully managed to recover.

    Others weren't so lucky and they claimed they didn't do an error.

    I can sent you later the zip when back from work if you want it, but proceed with caution. (if anything happens don't blame me 😇)

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited June 2022

    I think you will need to contact support as they probably need to fix the base.

    I saw you provided the files in another post, thanks

This discussion has been closed.