Fanatec Driver 222 Beta released (Windows10)

We have a new driver available and the package also contains the latest firmware for your device as well.

Here is the full change log for our Fanatec driver version 222:

Supported devices

Wheels:
ClubSport Wheel Base V2
ClubSport Wheel Base
CSR Wheel
CSR Elite Wheel
Porsche GT2 Wheel
Porsche GT3 V2 Wheel
Porsche Wheel Turbo S

Pedals:
All Fanatec USB pedals
All pedal sets which are connected to supported Fanatec Wheels

ClubSport USB Adapter (Handbrake & ClubSport Shifter supported)

ClubSport Series steering wheels:
ALL (released before August 2015)


New firmwares included:
   - CSW V1 base: CSW_Base_V109_rev535_boot_beta
   - CSW V2 base: CSW_V2_Base_V110_rev536_boot_beta


Feature updates:
CSP V3 acceleration vibration can now be used by developers when pedals connected to CSW Base OR by USB. Fanatec SDK (PC & PS4) Updated!

· Windows 10 ready!
This driver should be fully compatible with Windows 10. Please post all possible Win10 related issues into the comments. It would be great if you could try to reproduce the same problem in Win 8 as well to verify the root cause.
· Various minor code improvements and updates


CHANGELOG CSW (V1 & V2) Firmware:

· Optimized initialization process to avoid calibration differences between different rims/wheels.
· Reworked UHX PC mode toggle to solve USB 3.0 issues
· Fan PWM alterations to eliminate fan noise problems
· New UHX PC button mapping – more buttons can be used
· XBO communication refined
· PS3 Mode – The ring of light will always stay white in PS3 mode now (red = PC; green = Xbox One)

Please give me your feedback on the driver and firmware. Thanks.

«13456734

Comments

  • Thanks Thomas for reacting quickly to issues. Can't wait to test.
  • "Fan PWM alterations to eliminate fan noise problems"

    Yes !!! I was so sad but resigned about this issue. I'm so happy you can fixe it with just a new FW ! I was convinced that it need a mechanical intervention. gthanks Thomas I will try this new FW this evening. Have a good week-end  ;o)
  • edited July 2015
    Fantastic work!

    The USB 3.0 was the biggest issue for me since launch. After receiving FW 102 the issue was resolved entirely. Big congrats to Armin, Thomas and the entire team for quashing every bug i could find and therefore essentially silencing me :D (that's no easy task) :p

    My wheel now functions almost perfectly!
    The only issues I experience are related directly to PCars.

    All other titles I have tested on all on 4 platforms work incredibly well, very good stable, robust and essentially flawless firmware release.
  • Darf ich das neue FW auch bei Win 7 benutzen ?
  • Darf ich das neue FW auch bei Win 7 benutzen ?
    Klappt bei mir einwandfrei auch mit Win7 (x64)
  • Super ! Vielen dank ;-)
  • In FM5 with the gear selection set at "manual"  the default gear at the start of the race has become "neutral" in stead of first gear.. can't get the game to recognize the clutch in "manual/clutch" and the default gear was neutral .... restarted the wheel with FM5 and the default gear was now 1st, but still no clutch .... back to FW219 
  • well, after messing with the clutch , it finally was recognized by the game , but it still selects "N" as default gear at the start of the race... 
  • went back to v219/fw94  and gear selection is back to 1st as default at start...

  • Hi Thomas,

    thanks for the update. I implemented it on my CSW V2 for Pcars on PS4. It shows now FW110 on the wheel. Should there be an improvement for Pcars coming with this new FW?

  • edited July 2015
    bump
  • Fantastic work on the fan noise !
    Now I can hear it just 2 or 3 time after playing 15-20 minutes, just during 2-3 seconds each time , but after... It's so quite ! I enjoy  ;o))
  • edited July 2015
    Can't seem to update my V2.
    Got a borrowed Windows Vista 32bit laptop. Every previous update went fine with it!! Removed the older driver first, did a restart, installed the new driver 32 bit version, restarted lap top again, opened up Fanatec app and clicked update tab. Then I clicked connect, my V2 goes in update mode, but in the Fanatec window, text: failed to load the hex file.
    So Thomas...Is the needed hex file missing in the 32bit driver ?

    Ps. I tried with and without XOne hub connected to the base!
  • Can't seem to update my V2.
    Got a borrowed Windows Vista 32bit laptop. Every previous update went fine with it!! Removed the older driver first, did a restart, installed the new driver 32 bit version, restarted lap top again, opened up Fanatec app and clicked update tab. Then I clicked connect, my V2 goes in update mode, but in the Fanatec window, text: failed to load the hex file.
    So Thomas...Is the needed hex file missing in the 32bit driver ?

    Ps. I tried with and without XOne hub connected to the base!
    I have the same problem with windows 8 64 bit.

    Please help.
  • edited July 2015
    This driver update isn't just for Windows 10 Users is it...I thought it was ALSO made for W10
    Thomas...or anyone else...isn't it possible to post the .hex files, 32 and 64 bit, too. So we can just click on 'choose hex file' in the update window...that would make it a whole lot easier to most of us!!!
  • edited July 2015
    This driver update isn't just for Windows 10 Users is it...I thought it was ALSO made for W10
    Thomas...or anyone else...isn't it possible to post the .hex files, 32 and 64 bit, too. So we can just click on 'choose hex file' in the update window...that would make it a whole lot easier to most of us!!!
    Antoine. T asks us to try the new FW in both W10 and W8, if there are issues with W10. It looks like it is meant to be compatible with both. And, Natalie sounds like she got it installed OK. I would assume she is with W8/8.1. I'm going to give it a try tomorrow on W8.1
    Check that. I'll be getting Windows10 next week. 29th or there about. Will check 222 then.

  • I've got issues with Vista !! I've got W8.1 on my pc, but it's kinda ridiculous to carry my rig to my living room to update it there. And I don't feel the need to take the base of my rig again, cause I just build it last week!!!
    And I didn't have problems with updating with that laptop before !!!
    So Fanatec..please just offer me the .hex file and I'll upload it myself, I've got 2 weeks of holiday now to test the hell out of it.
  • Is this just for PC gamers or also XBox One users?

    I got the V2 base with XBox One.

    Which benefit is there?

    Best regards, Alexander
  • It's for the V1 and V2 base, all platforms. Improvements in....read Thomas' post...
  • I got my Windows 10 for FREE! Thanks for the update Thomas.

    Notice it's always the same ones who can't figure out how to get their stuff working? Read into that what you will.
  • I got my Windows 10 for FREE! Thanks for the update Thomas.

    Notice it's always the same ones who can't figure out how to get their stuff working? Read into that what you will.
    Windows 10 is free for most people for the 1st year. So no big deal.
  • im getting windows 10 for free also...Soooo ummmm Yeah carry on... Thats No Big Deal.
  • Instaled in windows 7.1 Ultimate 64, with no problems at all.

    I will test it on PS4 soon my V3 arrive lol 
    :D
  • edited July 2015
    Top of the blog page change for everyone else? Hum? Wonder what's up? ;)
  • edited July 2015
    Top of the blog page change for everyone else? Hum? Wonder what's up? ;)
    ???????

    Okay...after no responce on the Vista not loading the hex file I took my pc to my game room, hooked it up to the base and tried the update again.
    Windows 8.1, ALSO WAITING FOR THE FREE W10 UPDATE ON 29/07/2015, all went well...but didn't anybody notice, WITH XONE HUB, in the function test window, the buttons don't match at all!!!!
    For example: if I press the RB button on the front, 3way button box, I get a blue dot on the on-screen button box on the RB BUT on the TOP button box the blue dot is seen on the Y button.
    Actually...it seems like the only ones that are seen correct are the A button and the LT button!!!!
    And I'm also missing out on the test buttons for the brake and throttle rumble for my new CSP V3's
  • Further testing with XOne hub and fw110.
    Okay...found out...after couple of tests the USB connector has become smart. Unlike the manual says. If the USB is connected to an Xbox One it goes in XOne mode after pressing the double square and X button. When hooked up to a PS3 same button combo makes it go into PS3 mode. The manual says: double squares and B buttons at same time!

    BUT the new fw will only allow me once to switch back from pc mode to XOne mode. I can't switch between pc mode and XOne mode as much as I'd like without restarting my base !!!
  • edited July 2015
    @Natalie, did you try PCars with the XOne hub and fw110 ? Like I found out in the testing window, the buttons don't match anymore...And because the gas and brake pedal also don't work no more to do all kinds of settings in PCars the hub is practically unusable !! For PS4 that is!!!!
  • On Windows 7 the FW does not work. It can't find the HEX files.

    Thomas, as I said a year ago. Get rid of this update procedure. A update via USB stick is platform independent and much easier for the customers to handle.

    And a more detailed change history would be great too.


  • On Windows 7 the FW does not work. It can't find the HEX files.

    Thomas, as I said a year ago. Get rid of this update procedure. A update via USB stick is platform independent and much easier for the customers to handle.

    And a more detailed change history would be great too.


    worked fine for me Windows 7 64 bit
  • Work fine for me too on Windows 7 32bit
Sign In or Register to comment.