Formula V2 wheel on DD1 stops responding randomly

Tony PearceTony Pearce Member
edited April 3 in Steering Wheels

So after a year of nearly flawless performance, the wheel on my DD1 (Official Formula 1 package DD1 and V2 wheel) has randomly stopped responding in all racing titles.

I'll be driving along, minding my own business when the shifters and buttons just stop responding. The display also freezes on whatever gear/revs it was at and the base vibrates constantly. The only way of fixing it is to power down and power back up the base.

Sent a support request to Fanatec. Got a blank email from "[email protected]" with the subject "No Subject".

Not exactly feeling confident

Comments

  • What version of drivers / firmware are you running and what have you tried already?

    Things you could do,

    • uninstall all drivers and reinstall the latest versions and update all firmware
    • check the pins of your steering wheel to see if they are intact
    • check if the bolts from the harnas that keep the pins in place are still tightened
    • use another USB port, disconnect all other stuff that uses an USB port and use a powered usb hub if u use any

    Things like this can be hardware related but it could also be a driver / software issue that is failing after a windows update for example.

  • I’ll give it a go Riend. Not feeling confident but I’ll try it.

    the wheel doesn’t like some USB ports on my system.

  • Tony PearceTony Pearce Member
    edited April 4

    No change at all.

    Uninstalled and re installed drivers and Fanalabs. Flashed BIOS on wheel base, motor, and wheel. Was barely in iRacing for 5 minutes and the shifting and all buttons on wheel stopped. Revs and speed were stuck on and no option but to restart wheel.

    Lodged a 2nd support ticket, got another blank email from Fanatec!!!

  • edited April 4

    Getting an empty email is “normal”, I had the same last 2 times I had to RMA the formula V2 wheel.

    But I’m quite sure they received your email. Not sure where you are from but it’s Easter here in Europe so they won’t respond until Tuesday at it’s fastest... add some days to it.

    if you are from Europe and want to get it fixed asap I would recommend you give them a call next Tuesday (between 2 and 4 when tech support is open for phone calls) Unlike some comments here in the forum I had some pretty good experiences with customer support and after a call everything was sorted out within minutes and the whole RMA procedure wat initiated.

    In the meantime write everything down you already tried and make a video of the issue you encounter so you don’t have to send another dozen of emails back and forth ;)

    I have had enough complains about Fanatec but customer support has always been quick in finding and coming up with a proper solution.

    Something else you could test in the meantime is another USB cable and check if the energy settings inside windows aren’t on energy saving or anything like that.

    Another thing, does the Fanatec wheel property page still show responses from buttons or are these “dead” also?

  • I’m using the braided USB that came with the wheel unit. Swapped it out. No change.

    The wheel inputs do not register in control panel when it dies. Also, I noticed that if it does die and I remove and re seat the wheel on the quick release it works again. There are no miss aligned or bent pins. Definitely either the wheel itself or the connections to it.

  • I just posted another thread on this same subject before I saw this. I am having the same problem with my wheel. I can’t find anything wrong with the pins, and I have the latest firmware. I also have the formula v2 wheel.

  • Hey Tony,


    I had the same issue escalate about a month ago for me. It's the wheel. I contacted support - I suggest you email their customer support to tell them about the issue with your support ticket if you don't hear back within a week. At least this way, you can get in touch with support through them.

    To speed up the process, try taking a video of the problem (try to show the game and your wheel while recreating the issue).

    I wasn't even able to create a support ticket so I had to try to contact another division at Fanatec. It's annoying but you should hear back from them and hopefully get your issue fixed.

    For the record, the pins all seem to be intact for me.

  • I might have a temporary solution that seems to be working.

    Before each session I take the wheel off the hub and put it back on. Hasn’t stopped working since.

    I’m in Australia, so I’m not interested in posting my wheel overseas for a length of time considering sun racing is pretty much the only thing I have in my life that I’m enjoying right now

  • Alex LiAlex Li Member

    I have this issue for a year. Currently I use a set screw in the quick release bolt hole to secure the V2 wheel, it prevents the freezing to occur in my case. Hope this help. https://forum.fanatec.com/discussion/comment/41108/#Comment_41108

  • Heiko GehrigHeiko Gehrig Member
    edited June 5

    Alex, read your responses. What do you mean by a set screw? You mean you put “thread lock” on the screw to keep it secure? Or are you referring to the screw hole where plastic screw was in place to keep the quick release pulled back during shipping?

    All the buttons on my Formula v2 would freeze after some races the steering and pedals work fine. Removing and replacing the wheel on my DD1 fixes it.

    A temporary fix as to take off the wheel, and tighten the connector pin screw (in the middle of the connectors, in the plastic housing, and the 5(?) screws around it (around the plastic housing with the one connecting pin screw). This fixed the freezing for some time, but it’s come back. Just had a freeze recently and checked the screws and they were secure (other times they could easily be retightened, meaning they were coming undone?)

    don’t suppose you have pictures for clarity?


    Cheers

  • edited July 3

    Hi


    Many people have this problem.

    I have already found 3 topics that talk about these problems.



    I too have been having my steering wheel randomly disconnecting since February.

    I've tried everything, but nothing works.


    I have sent them an email but no answer 🤬

  • Looks like this issue is back again. Just randomly stops responding until i take it off and put it back on.

    In lockdown here so I can't do much except sim race. Not looking forward to sending it back and forth.

  • I have been having this issue since I first got my Formula V2 wheel and DD1. Went through a bunch with fanatec support who were very helpful, but ultimately nothing worked except always using the screw to hold the wheel in tight.

    That is, until today, now even with the set screw in place and everything tight, the wheel is doing this often, and most recently, wont even work on startup. This just happened this race, I switched to my 911 wheel and ran the race, so I am about to start debugging to see if I can figure out what is going on. Anyone had any luck besides the set screw?

Sign In or Register to comment.