Fanatec F1 Wheel Buttons Stop Working or Buttons go Crazy


I sent the following support request to Fanatec. I am just wondering if anyone had this problem. Thanks!

This has happened 4 times in the last 2 days. It never happened before then I will be playing iRacing. Everything is fine. Then while driving, I cannot shift and all buttons are unresponsive. 2 of the times this happened, it was like all the buttons were being pressed as fast as possible (I could see this because menus were flipping and voice chat indicator flashed very fast). The other times the buttons just didn't work. All 4 times I could not hit the little OLED menu button and it was locked up on the OLED F logo. In all cases I could still steer with the CSW 2.5 Wheelbase and still brake with my CSL Elite pedals. Powering off the wheel and turning it back on fixes the problem. This has ruined 4 races for me. I have tried a different USB port. I have uninstalled the Fanatec_64_driver_345 driver and reinstalled it. I have re-flashed all 3 firmwares for the wheel again. I have taken the F1 Rim off the wheelbase and put it back on. I never remove the rim, as it is the only one I use. But the pins all look just fine. I have been using the podium paddles on this wheel with no problems for 6 weeks. I have unplugged everything in my office (computer and all other items from the wall outlet. I did install Fanalab on 9/25. I played with it for one night and then removed it since I didn't have time to learn the features. I had races after that with no problems. When the wheel starts up and completes the rotation test, it looks like the F logo is corrupted for bout 3 seconds. I don't remember seeing that before. It eventually looks normal. I am not sure if this is normal. PC Driver: 345 Wheel Base Firmware: 662 Wheel Base Motor Firmware: 22 Steering Wheel Firmware: 28 

I posted on Reddit and someone mentioned a 347 driver.  I don't see a download for that here in the forums.  Doesn't anyone suggest that and have a link?
«1345

Comments

  • In case anyone sees this and has the same problem, go back to the 336 beta driver and all 3 firmwares that come with it.  You can download that from the Podium Advanced Paddle Module download page.  This solved all my problems.  It would be nice if Fanatec had a PSA about this.
  • Hi,

    I have exactly the same problem with my Podium DD1 for PS4.

    I can still steer, break, throttle but no shift and no buttons react and this ruined about 5 races on GT sport :(

    I put the rear off button and on again and everythig works fine...till next and next and next (about 10 times this problem now since about 10 days)

    Tried another game (F1 2019) and same problem

    Falshed the 3 firmwares and reinstall everything… not resolving the problem

    I will try the solutions of Jeffrey Rollete and post again

  • I tried the Beta Driver 336 and 346 (Flashed the 3 firmwares) and the problem still remains the same: It stops and I could still steer, brake, throttle but no shifting and no buttons working.

  • edited October 2019
    im having same problems tried every thing. waiting for reply from fanatec
  • I tried the Beta Driver 336 and 346 (Flashed the 3 firmwares) and the problem still remains the same: It stops and I could still steer, brake, throttle but no shifting and no buttons working.

    you find a solution???? still not working for me
  • Here is exactly what I did.  Maybe I just got lucky.  Just thought I would share.

    Uninstalled drivers and Fanalab.
    Rebooted.
    Installed 346 and flashed all 3 firmwares.
    Rebooted.
    Never installed Fanalab again.

    I have been fine since October 6th.
  • I am on PS4 so no Fanalab for me. All these problems are with the ClubSport Steering Wheel F1® PS4™.

    I changed the Wheel for the ClubSport Steering Wheel Porsche 918 RSR this Week-end and played twice about 2-3 hours without any problem.

    For me the problem is probably coming from the Wheel or from a compatibility between Wheel and PS4 because they made an update recently in order to be able to use all the switches, buttons. I'm still waiting on Fanatec's support.

  • To jeffrey :

    had exactly the same issue on my Formula V2 (CSW V 2.5), afaiac i think it's a hardware problem mainly related to Formula current rims..actually things fixed here using a safety screw tight way...Fact is that i did not face any issue with a previous Formula carbon which had the safety screw ON all the time, on the opposite never used the screw with this one so far. Maybe there's something slightly losing tight contact in the QR/hub/rim'pins whatever assembly when coping with long and heavy duty racing (usually race in 90mns league sessions) dk for sure...
    NEway, Monday 10 mns cool racing stints, every time the wheel went crazy, confirmed is the fact that on/off action restores the functions, today different story : with the safety screw tight on, i was able to run a 90mns endurance test of hard driving the FR-X17 WITHOUT any issue ! ...crossing fingers and lighting a candle lol
  • edited October 2019
    I've had exactly the same issue with PS4 formula rim.

    used it for a month no issues at all.. all of a sudden the buttons would stop working but steering fine.
    I was using fanalab beta 12 and driver 335 since day one with no issues. I have now updated to beta driver 346 and used the securing screw as mentioned above (never used it before)... thought i was ok until 80mins into a 90min race and all the buttons and paddles stopped. Had to restart the podium base in the race to get buttons back but then had to do last 3 laps with ZERO ffb.. was a nightmare. 

    hoping this is a driver or software issue and not a hardware issue, as I cant RMA my unit from this location. any updates? 
  • I'm having simular issues only that with mine I either loose ffb or the buttons don't work! Happens on all 3 wheels I own! Any updates to this problem? Will contact support on Monday
  • I just opened an RMA for my formula v2 on a DD1. I lost all connection to the wheel mid race, no shifts or buttons recognized. Since then my computer will never recognize the fact that the wheel is even connected.

    I have flashed the beta and previous firmwares, uninstalled fanalabs, rebooted etc and nothing works. 
  • Same issues with CSL Elite Wheelbase + Formula V2 happens serveral times per race. Solution mid game, pull out the wheel and put it back. very anoying for a high end product with a price tag that follows
  • I guess I have a similar problem. Just got the V2 wheel + Advanced Paddle Module (on Xbox and PC) Every now and then it looks like the base is loosing contact with the wheel during boot. The Xbox light goes out on the wheelbase (V2.5) and only the Fanatec logo is visible and the Xbox confirming light on the wheel. Buttons don’t work. Someone mentioned the Fanatec logo being a little corrupt, I noticed this too. I only had this problem twice and this was during boot. If the Fanatec logo remains visible then I know I have to power the wheel down. Only possible by removing the power cable. Never had these problems before with the universal hub or McClaren wheel. I hope it’s driver/firmware related.
  • Happend again today. Disconnecting power and rebooting fixed it. Fanatec has to look into this and clearify if this is firmware/driver related or hardware related.
  • Still not found a fix for this.

    Podium F1 - At random intervals the f1 steering wheel will freeze, LED lights and OLED stuck on whatever they displayed at the time and no button presses register in game. I can still steer and receive force feedback however. Happening in Assetto Corsa and iRacing.

    You can restore complete functionality by removing the rim and putting it back on without even exiting the game or by power cycling the podium base.

    Tried new USB cables, different usb ports.

    Uninstalling fanalab and drivers and starting from scratch including flashing base,motor and wheel.

    Tried drivers 336, 345, 346 and 347

    nothing stops it. it happens with or without fanalab.

    Never had a crash with the BMW GT2 rim.

  • I am having issues with my Formula V2 Wheel right now. A recent update to their site and my products are no longer associated with my account. I have no method to contact for warrant or repairs by them outside of $1.99 / minute call.

  • Any comment on this from Fanatec would be much appreciated

  • edited December 2019

    Ive had this issue too, for quite some time.


    it has progressed from where most of you seem to be, in that remove wheel and replace used to fix it straight away, now doing that results in no buttons even if they were working prior.


    this means i cant even hot swap wheels, because no buttons work when i turn it on or swap to a different wheel, yet pressing any button to clear the high torque message works, so the buttons ARE functioning. One of the selling points was that you can swap wheels on the fly if you really want to, but now i have to actually go back to Windows and into properties to get it to actually work. Changing settings in the on-wheel/on-hub menu does not restore function.


    i had .335 from the start, had no issue for weeks, then once it started it hasnt stopped. I had made absolutely no changes to drivers, firmware, or anything else in this time. Im using .345 and the correct associated firmwares with it, none of this affects this issue.


    the way i fix it now is by going into properties, tuning menu, then select setting 2, then back to the one i want to use, and all functions as it should. The one saving grace is that ive not had it occur during a race again.


    this has nothing to do with the screw being in tight or not installed at all, because i have had this occurrence when i finished qualifying and was waiting for race start, i KNOW the paddles worked after qualifying because i used them in menus, and there was almost zero force applied to anything up til after race start.


    this is not specific to any one racing sim, ive had it happen in PC2, AC, rF2, and RaceRoom.


    im going to assume that some of you are using Windows 10, because you cant possibly all be using Windows 8.1 PRO like i am, so this is not going to be a Windows version glitch either.


    its abit of a joke that this even happens with something so expensive as a DD1, and as seen here, NOT A WORD FROM FANATEC. They even told me "we have never heard of that before" in emails. The fact i just found this thread indicates to me otherwise, because a lot of people are obviously seeing this issue.


    if it really was a hardware issue, i doubt we would all be seeing it across various different wheel base models and with different wheels or the Universal Hub. It would almost have to be a software or firmware issue, whether that be something we have done in Windows, or unrelated to this, Fanatec need to pull their fingers out and get to the bottom of this, AS A PRIORITY.


    my rig is as follows:

    Asus P9X79 PRO

    RipjawsX 1600MHz RAM 4x 8gig sticks

    i7 4960X

    Gigabyte Gaming OC 2080Ti

    2x Crucial MX500 SSD in RAID0

    2x WD Green HDDs, 2TB & 3TB

    Seasonic Prime 1300w PSU

    Corsair Obsidian 1000D case

    Windows 8.1 PRO, a REAL bought version

    Microsoft IntelliMouse

    Microsoft Ergonomic KB 4000

    Asus ROG SWIFT PG27V monitor

    Pimax 5K+ VR headset

    DD1 PS4 Podium F1 set

    V3 pedals


    Further of note is the PSU and case are new and replaced an Antec Twelve Hundred & an Antec 850w Quattro. No change.


    now everything is laid out on the table in detail, FIX IT. WE PAID YOU GOOD MONEY, GIVE US WHAT WE PAID FOR.


    Thanks all, and hope we can get some sort of solution soon.

  • I have a couple ideas:


    has anyone tried removing the drivers, and going through the registry completely removing everything Fanatec related, so as to start completely fresh and see if it corrects the issue?


    has anyone tried their unit on another computer to see if the issue follows the wheelbase?

  • Removing everything from registry made no change.


    i have 4 universal hubs, 3 standard shifters, 1 Advanced paddle module. Swapping in any of the 3 standards works straight away. Putting the hub with APM installed and get no paddles until i go to tuning menu tab and back to test tab.


    i also have the F1 wheel that comes with the DD1 and includes APM. Putting this on all works straight away.


    did not test in races to see if the standard shifter hubs still lose buttons as they used to.


    i do recall an instance where i lost all buttons during qualifying, and ALT-TAB to desktop, open properties, the image showed the APM on screen, which i had not used on any hub at that point, only on my F1 wheel.


    another point, after deleting all driver software from everywhere i could find, and clearing all Fanatec registry entries, i still had all settings i had set after i re-installed the .345 driver and plugged the wheelbase back in. Those settings are stored somewhere else, and i have not yet tracked them down.


    does anyone else having this issue have, or previously used, any hub or wheel that has the APM installed? There seems to be a connection to this device.

  • Swapped APM to a different hub, same result.

  • I also suspect the apm to be the cause as I’ve only seen wheels with the apm fitted crashing out.

    I pulled my ps4 f1 rim apart and removed and reseated every ribbon cable. Before my wheel got to the point when it would crash every 5-10mins tops. After reseating all the cables I’ve gone a month without a crash.

  • edited December 2019

    FYI.... fanatec support gave me an rma number for my rim. And also said they have not heard of it before... even though I linked them to a couple of forums posts and also one on reddit all with people having the same issue.


    as I live in South Africa an rma was going to be expensive. Which is why I took the measures I did first. So far I have left the rma as I now can’t replicate the fault, so hope it was just inconsistent connections.

  • edited December 2019

    Mate i can assure you they have heard of it before, from me personally! Told the CEO about it directly, as well as their Australian tech support guy, who i am sure passed it on.


    i would say if i have informed them, others have too.


    My F1 wheel doesnt seem to have the issue, funny enough.


    i swapped the APM to a brand new Universal Hub last night and it didnt change a thing. Cant be 4 faulty hubs out of 4 i own, surely not...

  • edited December 2019

    Cool. Ok so you have isolated it to the apm module then by the looks of it.

    you could swap the one from your f1 rim to confirm... if the problem module also then crashes your f1 for the first time it’s for sure, nearly every case I’ve found is on the formula v2 rim or f1 rim with apm. Your the first I have seen with same fault on the universal hubs.

    i would love fanatec to just confirm if that’s now a known fault.. they did say in one of the emails to me that it could be an issue with either the rim electronics or apm.

    for me and my location it would actually most likely be cheaper to just buy another apm module than ship the whole rim back for rma and having to paying shipping and customs etc. if I know it’s the fix. Plus I get a heap of spare parts and extra carbon shifters etc. anyway, so far It has not come back since a rebuild.. and it’s been a month. but I also completely took,off the apm and reinstalled, so that might have been the fix in my case.

  • edited December 2019

    Ive just ordered a couple new SSDs and i will install Windows 10 to test it all out on a fresh clean Windows install to see if the issue starts in the operating system or follows the hardware, its not going to be a Windows 8.1 thing but ive had a couple other unrelated minor issues lately too.


    Swapping out the APMs between wheels is quite a bit of work, but i have considered it an option too.


    the thing about the APMs is they appear to have no additional circuitry in them, at a glance it looks to be just 2 switches and 1 hall effect sensor per module, so id kinda expect theyll work or they wont, shouldnt be able to be inbetween.

  • I am still on beta 336 and this problem has not reoccurred for me. I am the type of person that likes to stay current on firmware and drivers, but Fanatec have convinced me to be scared. I am pretty heavily invested in the Fanatec ecosystem, but I I looking at selling my gear and getting higher end stuff because they have lost my trust.

  • Youre not the only one there, and its a fair bit to do with the way they run it all. They have the potential to some of the best gear around, but the use of cheap manufacturers and rather poor after sales service that appears to be well under-staffed holds the brand back considerably.


    instead of making good stable drivers that fix all the issues, they tend to keep releasing BETAs that dont often function as they could be reasonably expected to do.

  • So having now tried the device on a different PC, and also a complete fresh install of a different version of Windows using brand new SSDs, the issue follows the wheelbase.


    the settings are obviously stored in the devices themselves, hence the problem follows the device. The V3 pedals also had their exact settings on other machines, but theyre not faulty.


    So whatever is causing this issue is being saved in the wheelbase, hence why we cant get rid of it.


    clearing the device by updating firmware is obviously not clearing everything out of the memory in the device, so there needs to be something added to the firmware or driver to facilitate this


    WHERE ARE YOU FANATEC??? WHAT ARE YOU DOING TO FIX THIS???

  • I have been hanging the same issues, reinstalled everything then it was fine for around 3-4 weeks then I was unable to use any buttons/shifters on the rim. The car would still steer, and if you turned off the base/rim and turned it back on it would be fine again for a while.

Sign In or Register to comment.