Fanatec Driver 442 (Beta) for CSL, CSW and Podium WB (all wheels)

2456722

Comments

  • I'm playing f1 2021 with the podium base and I'm happy with the driver 429 and have no problems either. but since the 442 is supposed to provide a better driving experience, I would like to update the base . Do you think I have to adjust my tuning menu settings or do they feel the same after the update


    Do you think I'll be faster with the new driver?

  • So, when can we expect an adjustable soft-lock setting that all the competitors have currently?

  • Awesome work! DD2 and everything works flawlessly so far

  • Well, it took me an hour to update it with the devicebootloader until it worked.

    • I had issue when updating.

    • Wheel Base Model (product ID): DD1
    • Steering Wheel Model (product ID): McLaren GT3 v1
    • Driver Version: 442
    • Base FW Version: 3.0.0.5
    • Motor FW Version: 3.0.0.2
    • Wheel FW Version: 30 (can't confirm 100%)
    • FanaLab Version: not installed
    • Tuning Menu settings: default
    • Driver/FanaLab installed on C: drive or else? C

    • Clicked auto update in firmware manager. Base and motor updated fine. Removed wheel as part of motor calibration and when I reinstalled it after motor calibration and clicked "update another wheel" it said no wheel connected. I tried a 2nd wheel and got same error. Clicked finished and control panel showed no wheel connected. I was worried base was bricked again as I only got it back this week...
    • I power cycled the base and the 2nd wheel was recognised. I attached the McLaren GT3 v1 and it was also recognised. I then successfully completed the wheel firmware update and everything is now recognised.

    Such a relief to have the update completed. 🙂

  • There's a major problem for 442 on XBOX with F1 2021 its unplayable. Can't increase rotation over 1024 so you can't use on XBOX at all as lock to lock rotation is like 140 degrees.

    SEN 2520 is recommended and is quite frankly the only way to use Fanatec on XBOX since codemasters refuse to fix this bug ever since the beta for 2021 came out and I'm suspecting its in F1 22 as well.


    Also there is no extra set(s) available any more :-( . I had used previously set 2 for only F1 2021 since it needs this stupid level of wheel rotation to even be playable since they won't fix their bug!

    Also can't manually set the rumble motors brake level to go at the level of brake force I used since this setting has been removed completely from the base settings menu :-(

    So any chance of adding at least a second preset, as well as put back all the high rotation angles, rumble motor set point?


    Cheers

    David

  • edited June 3

    Hello dear Fanatec Team,

    now after the update I want to go back to my previous driver 364 which works 3 years without problem.

    Now my base don´t start anymore.

    Fan is by 100%, Windows don´t see the base. Firmware updater with 10sec push the start buttom don´t make anything.

    After push the start buttom the weel goes 180° the fan goes to 100% and the base want a calibration of the weel, the calibration works.

    but the fan ist still by 100%. Windows don´t see the weel. Driver UI don´t see the weel.

    Than, deinstall the driver 346 and reinstall the driver 442.

    The driver UI tells me, that no Fanatec Drive is found.

    All 9 points for suggestion don´t work.

    To force the firmware updater with push the start buttom the 10sec don´t work.

    After push the start buttom again the weel goes 180° the fan goes to 100% and the base want a calibration of the weel, the calibration works, but the fan ist still by 100%. Windows don´t see the weel. Driver UI don´t see the weel.


    DD2

    CS SW Formula V2

    Please help

  • Every driver update has worked perfectly for me. Today I noticed there was a new driver update (442). I went through the same process of turning my DD1 on, deleting the old driver, restarting my pc, installing the new driver where it then restarts my pc again and then takes me to the Fanatec control Panel. I started the firmware upgrade and the first one finished successfully. The second firmware upgrade froze and told me no wheel was connected which is weird because I had my V2 rim connected and the fanatec badge light on it was on. It then shut down the firmware updater. Now my DD1 will not boot up at all. When I press the power button the fans spin to max but the screen does not turn on at all. The shaft is dead stiff and hard to move. The only thing that shows up in the control panel is my V3 pedals that are connected through USB and not RJ12. When I go to press the power button the fan will slow down but as soon as I let it go it speeds up again. The only way it will stop is by me removing the power cable from the base. What should I do?

  • George MurphyGeorge Murphy Member
    edited June 3

    Updated to 442 without issue. The previous update hangs are fixed too so never needed to restart the driver.

    Put it straight on a ItTM screen and drove around bashing this and that. No jolts whatsoever.


    Awesome. Was a long wait but feel now like I finally have the super duper Fanatec product I purchased a year ago.


    Thanks to Marcel for the work and to Maurice for taking the shit from everyone. Hope everyone has a great weekend 👍

  • edited June 3

    That's not an issue with the new driver.

    You just did not read the Highlights of the non-ignorable Changelog of the Firmware Manager and you did not switched into the Advanced Tuning Menu by pressing the Tuning Menu Button for 3 seconds while being in the Tuning Menu.

    Do that and you are in the Advanced Tuning Menu again with all Setups and all settings and SEN can be increased to 2520 again.

  • WAYNE CASTEELWAYNE CASTEEL Member
    edited June 3

    so I deleted the old driver restarted the pc installed this new one and now my fan on my DD1 is at 100% and the control panel doesnt see the base is connected.....any ideas on what to do? or do I now have a $1100 paperweight

  • I wil try the new version tomorrow.

    My wholehearted thank you to the entire Fanatec crew and of course to you Maurice!


    Cheers,

    Thorsten

  • Joel BarsottiJoel Barsotti Member
    edited June 3

    Had issues with updating the firmware update for my formula v2

    Updates fail with message: "Error: Update image failed(No response packet from target device.).

    Update process is stopped by error."


    Got this multiple times, tried updating my McLarenV2 and it worked straight away 1st attempt.

    updating the formulav2 seemed to error out at different times during the update (30%, 42%, 60%, 75%, ect..). Eventually it succeeded, but I must have tried at least 10 times before it worked.

    Base is DD2, the two updates for the base went through without issue.

  • Messages like the ones above make me worried about doing the firmware updates.

  • edited June 3

    is there less oscilation in the wheels now, or am i just tripping?


    or is it this new DPR setting kicking in?

  • WarmRedWarmRed Member

    I always read about such problems from people who uninstall the old version before. I always install over it and have never had problems with any update.

    • - Adjusted strength of damper effect which is controlled by the "DPR" setting of the advanced Tuning Menu. -

    Is this change a decrease in dpr strength at the podium base?

    in-game dpr intensity has been reduced, so it feels like the overall FFB detail has been reduced.

  • DPR strength is increased, FFB detail is increased as well.

  • Hey Maurice,

    Thank you so much! I always just in fanatec CP after the update or in fanalab enabled advanced and that unlocked advanced and you see the 5 setups become available. I didn’t know the holding in the setup button on the wheel as the CP enabled this.

    Thanks again!

    Cheers!

    David

  • so solution for people like me that updater freeze, disconnect all usb other than the wheel.

    the problem for me was my p1sim racing wheel

  • Should CSWv2 users be looking to update firmware to this?

  • Stephen FrithStephen Frith Member
    edited June 3

    I've read the changelog, will i get any better FFB or feeling? My DRI setting feel not as "loose" as they once did.


    Also, its been such a long time between updates for me, is there a guide on how its done again?

  • Hey Maurice,


    Much improved resolution and all about general 'feel' in F1 2021 on XBOX Series X with DD2, I run 70 in the game for higher force. Can actually even correct some deliberate snap oversteer. I'll try other games over the weekend. Thanks once again!


    Cheers,

    David

  • Hello again,

    after deleting all Fanatec entries in the registry, new instalation of the 346 driver/firmware and forced firmware update with pushing the start bottom 10 sec, the firmware 346 was updatet and now the UI works again. The DD2 is back!!

  • edited June 3

    Well, it's 5 people out of currently 4500 who report an issue with updating.. That's 0,11%... So the Chance that something goes wrong is quite minimal. As others have pointed out a freezing update can have several issues like Anti Virus interfering or other USB devices interfering.. Could be a lot of things but for the majority of people the update goes smoothly without issues.

This discussion has been closed.