Fanatec Driver 442 (Beta) for CSL, CSW and Podium WB (all wheels)

1235722

Comments


  • The same issue that I have, only start if I hold the power button, but not connecting to windows. If I release the button the DD1 turn off again.

  • I really hope this fixes my current issue.


    Bought a DD1 in March. I drive daily and never had any issues until today. Doing the Majors 24hr in iRacing and after first fuel stop, wheel base SHUT OFF MID CHICANE. Luckily I was able to stop (HE Sprints via USB). It took 2-3 seconds before the power button started the base back up. Spin its calibration and was good. Next lap... did it again in final chicane. No damage and limped it back to the pits.


    Been messing around with everything trying to find a solution and someone mentioned this driver. I am about to go back out soon and hope it is not a hardware failure. Still screwed our race we were leading LMP2.


    Thanks! If not, I will be doing RMA I guess.

  • This is exactly what I do - I leave a USB cable attached to the pedals but ONLY use it for updating. You must remember to unplug the pedals from the base when you connect USB to your computer to update.

  • edited June 4

    Unfortunately not more than the last reply from me you quoted, no.

    I only know that on a very few bases the Bootloader can fail during an update process. This is a "sleeping" hardware issue which theoretically can happen during any Firmware update with any driver so it's not really a specific issue of this driver and this can only by fixed by contacting the support for a repair or exchange RMA.

  • Joel BarsottiJoel Barsotti Member
    edited June 4

    This was my problem. No single thing seemed to fix it.

    connecting directly to the pc may help. Removing other usb devices may help. Rebooting may help.

    I did all that f those things and still had failures. Then it worked without changing anything.


    good luck

  • Not user error.

    This software, firmware, hardware combination is just fragile.

    I know finding transient software problems is really hard. Software should be deterministic. This is a situation where taking the same action as a user produces different results.

    perhaps it’s as simple as lowering the baud rate of the firmware flashing tool. The random communication errors seem to indicate a transmission error. Lower baud rates are typically more reliable.

    That’s pure conjecture on my part, but something about this firmware updater is not reliable.


  • I can confirm this issue occurs as well. DD1 with CS formula V2 and latest fanalab. Happening in ACC.

    Wheel vibration motors will randomly turn on full and stay that way for some time. This is with only Rev Limiter vibration enabled in fanalab and no other vibration enabled (ABS, engine, etc.)

    Have to turn wheel vibration motor off completely for this not to occur.

  • My base is well out of warranty though, how does that work?

  • edited June 4

    Hello,

    maybe this helps.

    Deinstall all Fanatec driver, with all registry entries with fanatec entries.

    In the device manager delete all unused USB entries.

    Reboot.

    Install a previous version.

    Reboot.

    If you have another wheel, without seeing the new driver, go with this wheel. If not use the wheel you have.

    Go with the DD USB cable to USB 3 (see motherboard manual for USB 3).

    Don´t open the driver UI.

    Try to force the firmware update with pushing 10s the start buttom.

    See if this helps, maybe it works.

    Good luck

  • edited June 4

    Every game I've tried feels so much better especially games that are not sims. WRC 10 feels amazing and 100 times better than before. Grid Legends is another one that is so much better now. FH5 is finally playable without crashes which is awesome and the driving feels great.

    The pedal firmware update made the pedals feels much better especially the brake pedal, I feel i have more control now.


    Very happy with the new Firmware and hope many more improvements to come.

  • edited June 4

    The drivers and firmware updated fine for my DD1 and GT world challenge wheel with the PBME etc.

    Played some AC and ACC, but I can't really say the update is a massive difference for the FFB feel, but at least I did not have any issues.

    If I had to say something, I think the FFB now feels slightly cleaner, more defined and faster.

    Might just be placebo too...

  • Hi Maurice,

    I disagree, it's nothing to do with engine vibrations, it appears to be induced by the suspension when I hit a kerb, it starts an unexplained vibration which lingers on for multiple corners or even laps until I hit another kerb in a similar fashion and then it stops. (It's not a flat spot on a tyre)

    I will try uninstalling all drivers and fanlab and starting fresh to see if this resolves it.

    Please note: I also had the QR issue post installation of the new drivers, and this never happened on previous installs, and I have been updating with each official release. After I rebooted the wheelbase, the wheel was detected, but I did have a few miss shifts which also hasn't happened in the past.

    I'm hoping these bugs can be ironed out quickly, so we can all get back racing at our best.

    Your and the teams efforts and feedback is greatly appreciated.

    Thanks Christian.

  • Correct, I have nothing enabled except the engine revs, and it happens all the time.

  • Good job Fanatec Devs! No, Great job Fanatec Devs. The rewriting of the code has been phenomenal. I own a DD2 and it has improved and fixed most if not all the issues I had with it. The detail and smoothness on track goes beyond words and for me it feels better than its Simicube counterpart. Thank you so much for improving my investment in the Podium DD2!

  • No success, because we can´t do this "Try to force the firmware update with pushing 10s the start buttom.", the base shutdown in that moment we release the button.

  • It may sound stupid, but then just hold down the button until the firmware is on it

  • I play with my own tuning menu settings. Is the feeling different after the update?

    Do I maybe even have to revise the complete settings?

  • Make 73Make 73 Member

    I would try that but because it´s not mine and he don´t dare to try it, can´t tell if it works or not. But thanks anyway for your help!

    But seems that Daniel already tried and no success.

    I think that base is already at bootloader mode because it won´t start.

    Maby RMA is only option.


    Never read any other product which cause so much troubles with fw updating.

  • Make 73Make 73 Member

    What is Fanatec´s official statement if base gone broke when fw update fails?

    Under warranty time and after that?

  • No chance no reaction from windows even if I hold the button and run through the calibration, looks like I have to open a RMA. Thanks for your efforts.

  • Have you double checked your power supply? Do you get a high pitched squeal from it during operation?

    I ask because it sounds pretty similar to what happened to mine. Base would shut off mid lap typically on a really quick and strong FFB signal. My PSU had really bad capacitor whine as well. Fanatec sent me a new one and it’s been rock solid since. Support made it sound like it’s a somewhat common issue.

    I make sure to plug the wheelbase PSU directly to the wall; no surge protectors and definitely DO NOT plug it into anything that provides AVR.

  • Either a user error or cannot update directly to the new one if you are on older drivers.

    managed to do mine today after the scary failed attempts yesterday that for about 1 hour was thinking my base was bricked since bootloader wasnt doing anyyhing and had fan speed 100%

    Today I have Updated first to 434 from 429.

    all went well.

    then from 434 to the 442 and all went well.

    (did the usuall unistalling rebooting installing rebooting procedure as usual).

  • K. 知樹K. 知樹 Member
    edited June 5

    hello.

    With this major update, I'm very happy to feel that the Podium DD series has improved its maturity and maturity more than ever. Thank you.

    Personally, I think it would be a great super great upgrade if we could upgrade from the current 16-bit control resolution of 65,536 steps to the 4,194,304 resolution of a 22-bit signal as a future request. This is equivalent to Simucube 2 Pro! !! Best wishes 👍👍

    It may be unreasonable with FW update 😅

  • After warranty you have to pay. Cost me €170 to get my DD1 fixed after failed firmware update.

  • Good afternoon.

    • Wheel Base Model (product ID): DD2
    • Steering Wheel Model (product ID): Podium Wheel Porsche 911 GT3 R with Button Modul Endurance
    • Driver Version: 442
    • Base FW Version: 3.0.0.5
    • Motor FW Version: 3.0.0.2
    • Steering Wheel FW: 6
    • Button Module: 21
    • Wireless QR: 6
    • FanaLab Version: V1.64.5
    • Tuning Menu settings: Fanatec recommended for iRacing
    • Driver/FanaLab installed on C: drive or else? C


    After updating on Friday I still had the following issue in iRacing, which was meant to be fixed now:

    • Fixed rare and brief jump of steering wheel position. Most noticeable in iRacing by a rapid steering angle change only visible for ~1 frame. Could be felt as a jolt like sensation. 


    On the old version that problem occured like around every 6 months. Now after the update I had the problem in the first 4 hours of using it (of course it might be just a coincidence).

    Following two videos of the issue in two different slow speeds:


    Thanks in advance for your help.

  • After disconnect Rj12 cable and connect CSP V 3 to usb firmware update fail . Now CSP in not working anymore . Need help

  • Hey I've just installed the the drivers and instaled the new 1.34 firmware for the CSP v3 pedals, the firmware seems to be good but, in the control panel i no longer have the ability to change the max brake pressure (with RJ12 connector)


    im not sure this is intended but thought I would let you know


  • Make 73Make 73 Member


    + delivery I suppose.

    Thanks for information, I don´t update fw after warranty is closed.

    But warranty or not, it´s really frustrating when your pretty expensive product is dead and need weeks or months at nowdays to get it repaired!

This discussion has been closed.