Fanatec Driver 442 (Beta) for CSL, CSW and Podium WB (all wheels)



  • what is the difference between low and high torque. is this noticeable on the steering wheel? when starting the base, the message in which I can acknowledge the torque is not displayed. how do I get the message displayed?

  • edited June 2022

    Low Torque = 8Nm Max. In Low Torque Mode the message is not shown at all as it's a High Torque exclusive message. And in Low Torque Mode the FFS toggle is intentionally grayed out and locked to LINEAR now.

    High Torque = 20Nm Max on DD1 and 25Nm Max on DD2.

    For High Torque Mode you need to have the Torque Key inserted.

    Only in High Torque Mode the FFS toggle is available and can be toggled between LINEAR and PEAK.

  • thanks. and how can I use the torque key? sorry but I don't know that well 😖

  • edited June 2022

    All this is explained in the official Quick Guide and Manual.

    You have to insert the Torque Key into the respective Port on the Back of the Base.

    Obviously you do not use the Torque Key, otherwise you would know this.. And this explains why FFS is grayed out for you and missing in the Tuning Menu of the wheel.

  • Thanks for your good work. When my base was new, it had to be replaced due to an error, so I accidentally sent both operating instructions back and assumed that the key was there. In this regard, I turn to the support. Do you think I need the torque key at all if I drive the FF to 60?

  • edited June 2022

    If you only use FFB of 60 in Low Torque Mode then you use your DD1 only with 4,8Nm which is even below the strength of a CSL DD.

    If you like such a low strength then you dont need the Torque Key. But you should maybe consider selling the DD1 and buy a CSL DD which gives you a tiny bit more strength for way less money...

  • Ok I use 60 in F 1, but 100 in GT7 with a bigger Wheel.

    in gt7 i would like to have more torque but i thought that was the max. for f1 the dd pro would be sufficient, but for gr 7 I need the dd 1😄

  • Not sure on "need". For quick short drive strong feedback might be fun, but more then half an hour or even more so in endurance races, it will quickly get too tiresome. On my PS DD1 F1 i use FFB even less then CSL DD at maximum is capable of (20Nm/38% in drivers/60% in game(4.56Nm)). So subjectively higher FFB to compensate larger diameter wheel probably will not be THAT much higher to require dd1.

  • Marcel PfisterMarcel Pfister Member, Administrator

    When the brake was active, did you try doing a pedal calibration?

    After which step did it stop to recognize the base, did you maybe manually downgrade the firmware?

    What do you think which firmware version is currently on the device, still the new one from driver 442, again the older one from 439 or a mix in between?

    Does the base turn on if you keep the power button pressed for 10 seconds? Normally this should force it to do a firmware update if a driver is installed.

  • My heart stopped for a while while updating. It updated the the wheel base firmware (CSL DD) and said that there is no wheel attached, the firmware manager screen wrote that wheel base's fw version is 0 (also picture showed a disabled CSL Elite or something like that). I reflashed, then the same happened.

    Thankfully I've restarted the firmware manager and everything was fine after that, it updated my ClubSport RS wheel firmware and all is OK after calibration. :)

    Is there any ETA when can we expect the new FW for the CSL DD/DD Pro?

  • Andre CibaAndre Ciba Member
    edited June 2022

    I have the same problem. I have the 442 on the base and the steering wheel. as soon as I flash the old driver 429 or 432, the base restarts and the fan runs. However, I can't use the base because it doesn't respond to any button inputs

    the base turns on when I press the power button. The fan then goes off directly and doesn't go off until the base is switched off

  • Marcel PfisterMarcel Pfister Member, Administrator

    Alternatively you can try forcing a wheel base firmware update by starting the base with holding the power button down for 10 seconds.

    Does the firmware manager output an error message when it happens? It sounds like the base tries to re-boot into bootloader mode but then there is no connection to the driver anymore for it to continue with the update.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks for the feedback, it sounds like it could be related to the steering wheel jump which someone also reported isn't 100% fixed yet. We'll investigate this.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Did you get an error message?

    Can you try again while unplugging or turning off the base to see if it makes a difference?

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks, we'll have another look on the lower end deadzone

  • Thanks Marcel that works. No the firmware manager doesn’t give me any error he start to think and instead of give the prompts for the updates the Base turn off and the firmware manager goes to “not responding”.

  • Had the exact same experience with DD2. Everything was all good up until the wheel updating. Firmware couldn’t recognize any wheel attached to update after completing the wheelbase and if I force quit it warned me calibration wasn’t complete.

    Fortunately upon quitting and restarting all went fine after restarting the process and my base was properly recognized while all wheels got updated, but there was a moment of fear and dread I’ve never seen happen before.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Did you get an error message?

    At which point did it fail?

    Does switching a USB port help or plugging it in via RJ12 again?

  • Marcel PfisterMarcel Pfister Member, Administrator

    The 22bit you mention are the specs of the angular encoder which SimuCube uses in their base. However the communication to games is using the Microsoft Direct Input Standard which is limited to 16bit.

  • Hi.

    Am I wrong or the 442 driver/new firmware (working perfectly on my DD1, I tried it on kartkraft) is not compatible with the trayapp/mobile app?


  • Marcel PfisterMarcel Pfister Member, Administrator

    Sounds like feedback which should go into the FanaLab channel.

    There the info would be great in which situations this is happening. Some games like to continue sending rev data even when in the pit, is that maybe the case? Or is it that a vibration gets triggered but not cancelled anymore?

  • just solved the problem. if you want to flash an older driver, you have to downgrade the steering wheel first, then the motor and finally the base.

    it worked without any problems

  • Onthe new 442, the steering wheel is less clamped, cornering is easier and the car hat more oversteer . However, you have less understeer, it's more direct, which means you can't drive as cleanly. I also have much less feedback on the steering wheel. I can no longer feel what the car is doing. then you can no longer take countermeasures. I hope you can investigate this issue. after installing 429 everything was back to normal an I am faster in F1 21.

  • Marcel PfisterMarcel Pfister Member, Administrator

    All of which had to do with FFB or could influence it was re-written, things which didn't have any issues and are separate from other functions were brought over like they were after checking there is no issue with how it was done.

  • Marcel PfisterMarcel Pfister Member, Administrator

    It should not be necessary to remove it but if someone has issues it could be worth trying.

  • edited June 2022

    Good afternoon!

    I installed the driver 442 on the base of the Podium F1 PS with the wheel of the McLaren GT3 v2. In the game Assetto Corsa Competizione on Playstation 5, the steering wheel loses connection with the base and stops responding to button presses. After a reboot, the connection is restored. I decided to return to driver 439. After the update, the base stopped connecting to FANLAB, and the fan worked at full power. After long "dances with a tambourine", I found a way to return to a stable driver 439. On driver 439, there are no problems with disconnecting the steering wheel from the base, but both switches from 1 to 12 do not work correctly.

    I also want to ask why you still don’t make it possible to rename SETUP 1,2,3,4,5 to any name in the Podium databases?

  • Marcel PfisterMarcel Pfister Member, Administrator

    should not take as long as it did for the P DD but I don't like to promise things. It will improve some things for sure but I guess it will be less of a noticeable change in comparison to what it did to the P DD because the P DD suffered from more and more noticeable issues before. For example part of the P DD issues came from it needing to manage whats shown on the base side display which the CSL DD doesn't have.

  • I have an original DD PS4 Podium which has never been updated. Is there a proper sequence to get to 442 or will this updater update it correctly without prior versions?

  • Marcel PfisterMarcel Pfister Member, Administrator

    Could be a positive side effect due to the improved latency and more reliable command forwarding

  • I updated DD1 to 442:

    remove driver 439 completely from pc - reboot

    install 442 - reboot

    connect base to pc

    switch on base

    start fanatec control panel

    upgrade base- motor (calibrate)- F1 wheel

    all finished? close fanatec control panel

    switch off base

    remove V3 brake cover

    disconnect rj-plug from from V3 brake circuit board

    connect usb from base to V3 brake circuit board usb

    start fanatec control panel

    upgrade V3 brake circuit board

    close fanatec control panel

    reconnect usb back from v3 brake cicuit board to base usb

    reconnect rj-plug to V3 brake circuit board

    remount V3 brake cover

    switch on base

    start racing 😄

This discussion has been closed.