Fanatec Driver 455 Release for CSL, CS and Podium (all wheels)



  • I uninstalled the Fanatec driver, rebooted, installed 454 driver and rebooted. Left the firmware as is. Once I connected to my Xbox I could cycle through to Xbox mode. It wouldn’t let me do that with the 455 driver?? I tried about 25 times cycling power and rebooting and nothing with 455. All I know is that it is working now with the new firmware too.

  • you mean Xbox mode at PC? If im correct then every mode have own driver at PC, if happens one is disabled maybe then it not work

  • edited December 2023

    But that is then suuuuuper weird because, as I said, the driver has absolutely nothing to do with Base Modes, that is done exclusively on the Firmware side. That means, even when the base is not connected via USB to a PC or console, you are still able to cycle through the different Base Modes, including Xbox Mode. This does not need a USB connection and therefore no communication to the driver on the PC so I see zero reason why on earth the Xbox mode is not working on a Xbox when someone has driver 455 installed on a PC with the same firmware as 454 as the driver is totally unrelated to the Base Modes... Super weird (and actually nothing I can reproduce, Xbox mode for me is working fine on P DD2, GT DD Pro and CS DD+ with driver 455 installed on a PC...).

  • Why are there no EA WRC presets in Fanalab (game not detected) and why are there no recommended settings like other games?

  • edited December 2023

    Because the game still lacks the basic functionality to disable native game LED and Display support which therefore would always interfere with the Lab. Therefore the game was not added to FanaLab yet.

    However, limited basic support is in development for a January release, however without LED and Display support.

    Anyway, this is not driver related so would be best to further discuss this in the FanaLab thread.

  • Hey Maurice,

    I was on 454 and saw that 455 is latest on

    Like others on DD2 I can't get XBOX mode with a XBOX Formula V2 wheel only allows PC and PC Compat. Its the base firmware.

    I uninstalled 455, re-boopted and installed 454. Went and manually re-flashed the base back and now XBOX mode is available again.

    Definitely an issue with this base FW update in 455.

    Cheers and Merry Christmas

  • edited December 2023

    So you say it is the base firmware but others said it is the driver and Xbox mode is working fine when using driver 454 with the new firmware from 455.......

    What is it now? :D

    Is the Xbox mode working again when you downgrade the driver or when you downgrade the firmware?

    I would say it can only be the firmware as the driver has nothing to do with console modes as console modes work independent from the driver even when no USB connection to the PC is established...

    However, nobody internally could reproduce the issue yet, Xbox mode is working for everyone internally..

    Will need a deeper investigation in January it seems.

  • Hey Maurice,

    I did only first go back to 454 with the updated base FW I did nothing else and no change.

    But makes no sense as what does the PC driver have to do with the base not allowing XBOX mode when there is no PC?

    Despite power down the DD2 several times it only allows PC / PC Compat. The XBOX Formula V2 wheel behaves as normal showing versions, etc on start up.

    Only manual firmware and re-flashing the base and therefore downgrading the base FW fixed the missing XBOX mode.



  • Update on this I was able to try on a different podium hub and the BME worked. Really weird issue as the BME still gets power when connected to the other hub. Has anyone else ran into this before?

  • edited December 2023

    (I was on Fanatec driver 452) Windows 10, up to date.

    Something is wrong this this driver installer (455) 64bit. It got stuck and crashed. Now i can't uninstall, repair or reinstall the driver. It keeps going into a loop and hangs. I have tried both to uninstall via the control panel (programs & features) and via the Fanatec_64_driver_455.msi. I cant go back with the driver release as it thinks its still installed with a later version.

    Any ideas on how to fix this issue?

    Its driver only, as I never got to the firmware update point of the install.

  • edited December 2023

    So. Finally removed the Driver after lots of hours and restarts.

    I had to run in windows safe mode, and then use the "MicrosoftProgram_Install_and_Uninstall.meta.diagcab" to uninstall the driver.

    Then I reinstalled the Fanatec driver 455 (without the tray app) and it fully installed as it should have. Then I reinstalled Fanalab 2.01.21.

    In my opinion the Tray app needs to decoupled from the driver install, as its still a beta and is problematic. I wont be reinstalling this until its release candidate worthy.

    Wow, what a waste of a day. There needs to be a better way when these things occur.

  • edited December 2023

    The TrayApp is not Beta and it is not problematic at all. It is a fully official version.

    Also this driver in general (including the TrayApp) is no longer just a Release Candidate,it is by now fully official since it it released on

    Sounds more like your Windows had some issues, not this driver.

  • so you say 455 is prefect even tho people complain issues?

  • edited December 2023

    I didnt said the driver is perfect.

    Both the driver and the TrayApp are official and the TrayApp in itself is not problematic and not the culprit for the issue of Christian - thats all I said.

  • you say that you uninstall old drivers first and then install new one, maybe he was not doing this and that diggers some weird bug

  • edited December 2023

    Can fanalab be be updated to have more recent game releases added to the game library?

    or if someone knows how to do that I would appreciate it. I want to set profiles for wrc and forza. I’ve added them as custom game on there but any options beyond that are greyed out. Like I want to set rpm led’s correctly and so on.

  • edited December 2023

    This question would be better in the FanaLab Feedback thread as it has nothing to do with the driver 455...

    However to answer your question (in the wrong thread): custom games do not support Telemetry output, therefore of course you also can not change anything but only save and load Tuning Menu settings for Custom Games.

    New games need to be added by a Dev into FanaLab, which takes time, and for the mentioned games there are huge problems to do so as WRC has no option in the game to disable native LED and Display so they would always interfere with the Lab. Limited support is in development for early next year, however the LED and Display adjustment will be disabled for this game because of the game issue. Only vibrations, Dynamic Damping and ITM will be supported, no LEDs (which is what you actually want, so this wont be possible ever until the game does not add the function to disable the native LEDs.)

  • Apologies for it being the wrong thread. In future I shall drill down further into my selections.

    i figured as 455 was the latest issue of fanalab updates it might have been the right place to have asked.

    I will still want all of the other mentioned items to work too so thank you for your response and look forward to next years update.

  • I was able to get all firmware updated on the CS DD by removing wheel from base and the attaching wheel when prompted if I wanted to update an additional wheel (only have one).

    Anyway all looks to be updated but wondering why, and more important , is there anything I need to do as it appears my previous wheelbase is the one recognized.

    Thank you

  • It seems your wheel is in compatibility mode instead of PC mode. Can you cycle through modes (indicated by led color in the power switch)? On pc you should use the PC mode obviously.

  • No need to apologise - the software packages are a confusing mess!

    ITM is available through two apps - the Tray App or Fanalab. One is bundled with the driver package and one is a standalone installer. Fanalab versions are more often than not specific to particular driver packages - but Fanatec insist that they are downloaded separately and discussed in separate sub forums. Why they are not all bundled together is yet another peculiarity of Fanatec logic.

    In other words - your confusion is understandable - ignore the attempts at gaslighting.

  • edited December 2023

    Michael wanted to control LEDs - which is only and exclusively possible via FanaLab and not via the TrayApp. Also he explicitly asked for a FanaLab support topic, not a driver related topic. Sure there is no need to apologize, but in the future the topics should be discussed in the correct threads, otherwise everyone gets confused in these threads.

    The installers of both separate softwares is not bundled because not everyone wants to use the Lab.

    A fusion of both softwares into one completely new big software suite is planned for 2024 or 2025 though.

  • Rather than justifying, then backtracking, you only needed that last line from that post - i.e, you recognise the current state makes no sense and improvement via bundling, exactly as I suggested, is in fact planned.

  • In general yes, but the decision to bundle the softwares is not because you suggested it though.

  • Yes, Maurice - I know that. I said it would make more sense to change them. You said it wouldn't but they are changing them anyway. Logical as ever.

    I didn't they are changing them tp the way I described because I suggested the change - as if Fanatec would ever do something that users wanted! I only suggested that would be the right way to do it. You are unbelievable!

  • I have the same problem on Xbox since update 455, no Xbox mode (green), yesterday it worked by removing the steering wheel then putting it back, but today it no longer works. 😓

    I come back to 454 until this is resolved.

  • Did you just downgradex the driver back to 454 or also the firmware as well?

This discussion has been closed.