Fanatec Driver 455 Release for CSL, CS and Podium (all wheels)



  • Hi,

    I have a GT DD Pro Boost Kit + Formula v2 with magnetic padles +CSP v3.

    for some time now I have noticed hat I could put my wheel base in compv2.5 or PC mode for iracing.

    What is the difference and the best choice ?

  • Comp mode emulates the USB device ID of a CSW V2.5 so old games, which dont support the base natively, see the base as a CSW V2.5 and therefore work.

    For new games (or old games which still get patched like iRacing) the Comp mode is not needed. However you could also use the Comp mode for every game, doesn't make any difference in performance.

  • returned to 454 then flash firmware manually.

    csl dd : 455 firmware base >>> 454 firmware base

    now xbox mode works again

  • Hanyang CaoHanyang Cao Member
    edited December 2023

    not sure if this is a driver issue but this is new after I installed 455. I have a DD2 running with the formula v2.5 wheel

    Every time I launch ACC or AC, the game doesn't register any input (i tried starting without fanalab, or with fanalab loaded with recommended profiles), e.g. the game doesn't register steering wheel, throttle, brake or buttons. I have to map everything manually to get things to work.

    When launching F1 23, the game does register input (i.e. steering wheel, throttle, brake, buttons), but steering wheel turning seems to be misaligned, and ffb feels delayed by half a second.

    I also play GT7 through drive hub, that actually all feels fine. Also in Fanatec Control Panel, everything input shows up fine. So not sure if this is some driver conflict thing

    Tried researching on line and on the forum but couldn't really pin down to the cause of the issue...

  • The issue with this forum and Driver issue is it is impossible to gather any relative information. The 455 driver update isn't working for me, it just says the wheel isn't connected.

    During the process the wheel base on my DD1 is supposed to restart during the update, this isn't happening so the driver can not be installed - wheel is working fine on the previous version.

    Anyone know a fix for this? As it sounds like there are lots of issues?

  • I just got my CS DD and QR2 Pro Hub and everything has been updated and installed. I am still showing Low Torque Mode when trying to use the McLaren V2 wheel. It is the only one I have so I cant test anything else. I have removed the hub pressed the button multiple times like @Maurice Böschen states to do and it does seem to be fully seated. I just spent all this money to get 12nm and now stuck with 8nm that originally had with the GT DD Pro. What gives and how do I fix it?

  • Yep. Same issue for me. XBOX mode disappeared with the latest firmware version. I even tried to reflash the latest firmware version and XBOX mode was still missing. This is how I downgraded:

    • Download 454 driver version
    • Uninstall 455 from your PC
    • Install version 454
    • At this point your wheel base is likely in PC or PC Comp mode since XBOX mode is not available. Switch to the PC mode.
    • Launch Fanatec Control Panel and click on Firmware Manager
    • Select the check in the top-right corner of Firmware Manager that says "Manual Firmware Update/Device Recovery" (or something like that)
    • Then click button next to the Wheel Base item in the window
    • Once the Flash Firmware button becomes enabled, click it.
    • Once the firmware is flashed you'll be greeted with the calibration window that asks you to switch to the PC Mode (note that this step was missing in the latest firmware version; this should have been the first hint that something was wrong with the latest version of the firmware)
    • Complete calibration

    Now XBOX mode should be available again.

  • Hi, I also had to downgrade the 455 firmware to 454 to get the Xbox mode to appear. Happy New Year to all !

  • For people having the "Cannot select Xbox Mode".

    Try powering the wheel completely off and on again,

  • Just leaving this here for anyone else that gets it

    since this driver i intermittetnly get this error

    Fanalabs shows greyed out wheel

    Cycling modes, replugging to different USB, restarting base/pc etc does not fix

    Fanalabs control panel will do one of two behaviors'

    a: Keep asking my to give permission to make a change to my pc, (windows driver install i assume) accepts, close, open, repeat, colose open repeat etc etc ad infinutum

    b. Tell me it detected a problem that will stop my base from working and click ok to fix, it then attempts to install drivers, fails saying it cannot find Fanatec_64_driver_455.msi, offers for me to bro9wse to in, i do, then says that Fanatec_64_driver_455.msi is not Fanatec_64_driver_455.msi and cannot be installed.

    Manual uninstall fails, same error as B:

    boot to safe mode, remove the usb drivers manually with usbdeview, restart pc, reinstall.

  • Hi team, I was running in iRacing last night and during the race the shifters on my BMW M4 wheel (with DD1 base) stopped working. Steering was fine and there were no software errors so I am trying to understand what caused the issue. 30secs later the shifters came back to life and i was able to finish the race. Other than button bashing on the wheel I didn't do anything else to fix it so it's hard to know what might've caused the issue.

    Could it be driver related?

    It's the first time it's happened and I had put quite a few hours on this driver beforehand without experiencing the issue.

  • Just A bit of an update. I did uninstall the 455 driver and then installed the 454 driver. I did not roll back the firmware. I have the Formula V2 wheel. If I start up the base without the wheel and add it after startup, it will then usually allow me to go into Xbox mode. Have to do it twice sometimes to get it to work. Dont want to chance rolling back the firmware so will live with this solution for now.

  • I just got my CS DD yesterday and its acting strangely with random steering inputs either left or right coming from the base in EA WRC. They start happening after a short period of use and happen totally out the blue and make the car totally uncontrollable. Is this the known steering issue mentioned in the patch notes?.

    I have done all the necessary updates with the current versions being

    Driver - 455

    Wheel Base -

    Steering Wheel - 2

    Wireless QR -

  • edited December 2023

    Notices some very strange behaviour/problem on my CS DD but I'm not sure if the problem is related to the driver, FANALED or even the hardware.

    Played AMS2 (BETA) for about 20 minutes and notices that my LEDs on my F1 2021 wheel are "hanging". So several LEDs lighten up but nothing changes anymore. Also the display on the wheel doesn't appear when I press the button beneath the display. But everything other (buttons, wheel, ...) works like it should.

    When I leave the game the LEDs are still on and nothing changes. Changed LED settings in FANALED without any effect. Went to the driver page and seen that the F1 wheel is not displayed anymore ("no wheel attached").

    Detached and attached the wheel and also tried it with another wheel: nothing changed. Driver page still mentions that no wheel is attached.

    Only if I turn off the base and re-turn it one resolves the problem. But if I turn off /on the base during playing the game doesn't recognize the base anymore and I have to restart the game.

    I was able to reproduce the problem again because the problem appeared again immediarely after turn off/on and restarting/playing the game after some time.

    I remember that a new CS DD owner mentioned a similar behaviour a few weeks ago but I cannt find the post anymore.

    @Maurice - is this a known problem or what do you think the problem is related to? Thank you in advance.

  • edited December 2023

    That is a known issue which currently under investigation with critical priority to be fixed ASAP next year.

    It seems like for some (currently unknown) reason the QR shuts off and does no longer communicate to the Base and the wheel, therefore no wheel at all is working anymore when the issue happens.

  • Thank you @Maurice, I'm glad that I'm not the only one having this problem and can wait for the solution next year :-)

  • Hi guys,

    Since driver 452 I'm not able to install recent drivers, whenever I try, I've got this message :

    Roll back to 451 and everything is fine.

    Any tips to solve this issue ?

    Thanks in advance

  • MadDog-ICMadDog-IC Member
    edited December 2023

    Do as the message says and send / upload your "Fanatec Logs" to this forum or "Fanatec Support" so someone may help you.

  • coen vcoen v Member
    edited December 2023

    Got the csl dd and downloaded the driver but can not get the control panel or anything to appear. Tried to repair it and downgraded it to 454 and 451 but none of it worked. I can still use the wheel fine for f1 23 though but not for Forza and the Fanatec app appears in my tray. Any ideas?

  • QR Board of the CS DD Base, so independent regarding the QR Adapter.

  • I do all with Fanated Driver 455

    After three days of a lot of nerves and a lot of worry, I urgently need your help, because I have tried everything, everything, and I have a problem that you have to solve, please. I will try to explain everything in detail in this message so that you can help me please.

    Two three months ago I bought a Podium Base from a guy for Playstation 5, it is the dd1 ps4 podium. I bought it in September, and it was only one year old, so it has 1 year of warranty left. I put it into operation and it worked perfectly, the base was perfect, and so were the steering wheels. Everything turned on and worked perfectly.

    In addition to this base, also buy 4 steering wheels from other users, specifically these:

    ClubSport Steering Wheel Porsche 911 GT3 R V2

    ClubSport Steering Wheel BMW GT2 V2

    Steering Wheel F1 Blue with the podium Wheel

    Steering wheel designed by Polyphony Digital especially for Gran Turismo.

    The base and the ruffles were very good, and everything was perfect. I have played a lot of Gran Turismo and Asetto Corsa games with my PlayStation 5.

    On Monday afternoon, I connected the base to my PC and saw that there was an update, both to the base, the motor, and each steering wheel I had. And since updates are always for the better, I decided to install the latest updates on my base. So I updated the base, the base engine, the Quick release and then one by one all the steering wheels, someone told me that it was not necessary, like the one in Gran Turismo.

    After doing this, these three wheels stopped working:

    ClubSport Steering Wheel Porsche 911 GT3 R V2

    ClubSport Steering Wheel BMW GT2 V2

    Steering Wheel F1 Blue with the podium Wheel

    When you connect them to the base, they do not turn on, and the computer does not detect them connected to the base, it appears as if it had no steering wheel connected. I tested the three steering wheels, one by one, and none of them gummed up. I followed all the steps in the help that appears in the FANATEC DRIVER 455 program and everything was fine, there was nothing strange and nothing strange, but none of these wheels worked. Only this steering wheel worked for me, the worst of the three:

    Steering wheel designed by Polyphony Digital especially for Gran Turismo.

    This steering wheel does work perfectly, it detects it and everything is fine, I can do everything with the base and with this steering wheel plugged in, but the other three, nothing at all.

    Next, what I did was restore each of the three previous Update versions of the Podium database to see if this would solve the problem. And nothing, it didn't detect them either, they are plugged in perfectly, but it doesn't detect them, they are off.

    After many tests and trying everything. It occurred to me to call a friend who has a DD pro base and go to his house to test the wheels, to see if the wheels had broken and his update had caused them to stop working. So yesterday I went to his house to try the three wheels:

    ClubSport Steering Wheel Porsche 911 GT3 R V2

    ClubSport Steering Wheel BMW GT2 V2

    Steering Wheel F1 Blue with the podium Wheel

    And they worked perfectly, everything was fine, they turned on, they ran perfectly, and without problems. I tried to Downgrade the steering wheel update, but nothing can be done.

    So after all the tests, and trying everything, it is clear that the problem is in my base.

    When I got home, I put the steering wheels plugged into the base again, and they still didn't work, they don't turn on and therefore the base doesn't detect them.

    I did a Downgrade to the 2021 base version, and nothing at all, the steering wheels don't work.

    I don't know what else I can do, I've tried everything. I have checked everything, the cables, the pins, the connections, I have tried different versions of the Fanatec Driver, I have tried Flash Recovery, and nothing at all.

    At this friend's house, both the base and the computer detected the steering wheels without problem. On the computer they could see, touch, and do tests with them. That doesn't happen in my house, they don't work.

    I have tried it on two different computers, in every possible way.

    Before updating the base and the steering wheels, everything was going well, the steering wheels worked very well, the base was working fine, perfect and now everything has stopped working.

    The only steering wheel of the 4 that works for me after all is this one:

    Steering wheel designed by Polyphony Digital especially for Gran Turismo.

    This steering wheel detects it perfectly, it works well, I have tested it on Playstation, everything works fine. But the other three nothing at all.

    One thing I have noticed is that when I turn on the base, the nut moves to the right 90 degrees and stays in that position, so the calibration was wrong. I realized this, because when I tested the worst steering wheel, it was miscalibrated and crooked.

    The issue is that I don't know what else to do and why this happens to me. I don't know where the problem is and I'm already desperate, because everything was working fine, and it has stopped working. I understand that if I went before, I will go again and there will be a reason for everything.

  • Your WQR Module got broken during the FW update. This can happen on some older units and it is a sleeping hardware issue which only gets triggered upon the first Base FW update. The hardware issue was fixed on newer units in the meantime, but old units can still trigger the issue.

    You need to contact the support to get the WQR Module repaired / the base exchanged.

  • Thanks so much Maurice, Then its a big problem.

    How could it happen? Because everything was going well until the update. I don't understand.

    And if it had broken, why does the worst steering wheel of the 4 work for me and the others don't? The Gran Turismo steering wheel does work and works well. They are the three others who are not going

  • edited December 2023

    Some wheels still work, some dont. Thats part of this sleeping hardware issue of some few units which gets triggered when updating the base FW.

    As said, you need to contact the support to get the WQR module repaired or the base exchanged.

This discussion has been closed.