Fanatec Beta Driver (324) 326 for ClubSport Steering Wheel F1® 2018 and Formula V2

13468911

Comments

  • Sorry if this is a dumb question... how do you update the wheel firmware... is it done automatically by the fanatec updater? I saw it updating the base.
    Hi David,
    as strange as it sounds, but there is a manual for your wheel (base), for a reason ;-)
    https://www.fanatec.com/download/CSW-V2.5_Manual-EN_01.pdf

    You might want to check it out ... especially page 16 and the following.
  • edited January 18
    Sorry if this is a dumb question... how do you update the wheel firmware... is it done automatically by the fanatec updater? I saw it updating the base.
    Hi David,
    as strange as it sounds, but there is a manual for your wheel (base), for a reason ;-)
    https://www.fanatec.com/download/CSW-V2.5_Manual-EN_01.pdf

    You might want to check it out ... especially page 16 and the following.
    Thanks Armin. I should have read the manual more closely... I guess I was just so excited to get it up and running and try it out! Regards, Dave Edit: actually reading it again, it doesn't specifically say how to update the wheel rim firmware, just the firmware for the base, which I already did to 324 to get the wheel recognised in the first place.
  • Thanks Armin. I should have read the manual more closely... I guess I was just so excited to get it up and running and try it out! Regards, Dave Edit: actually reading it again, it doesn't specifically say how to update the wheel rim firmware, just the firmware for the base, which I already did to 324 to get the wheel recognised in the first place.
    Hi David,

    Yea...I know, because it is a manual for the base. That is the drawback of a modular system that you have all possible combinations and not one single manual for your combination. But I would guess that updating the wheel firmware was pretty much straight forward ;-)

    We are happy that you are on track now. Please make sure to update the wheel with driver 326 again. I guess there was no popup this time to update the wheel. But you can and should still do it via the settings tab.
  • Thanks Armin. I should have read the manual more closely... I guess I was just so excited to get it up and running and try it out! Regards, Dave Edit: actually reading it again, it doesn't specifically say how to update the wheel rim firmware, just the firmware for the base, which I already did to 324 to get the wheel recognised in the first place.
    Hi David,

    Yea...I know, because it is a manual for the base. That is the drawback of a modular system that you have all possible combinations and not one single manual for your combination. But I would guess that updating the wheel firmware was pretty much straight forward ;-)

    We are happy that you are on track now. Please make sure to update the wheel with driver 326 again. I guess there was no popup this time to update the wheel. But you can and should still do it via the settings tab.
    Thanks Armin. I haven't used the wheel since I installed it on Tuesday. I'll update to 326 when I get to use it again tomorrow.
  • I have just tried driver 326 for the new limited formula 1 wheel on F1 2018.
    The bottons problem and the shifting works perfectly but it has completely changed the feelings on the wheel. When on the straights the wheel start to be crazy if i leave it, going right and left and not staying in the position i want. Even in corners i feel that he try to get back to the center and become really heavier, even if i'm using the same settings that i had with other drivers. ( drift mode off or -1 or -2 same problem ). I hope you fix it soon
    Hi Daniele
    I have experienced the same issue and found turning the damping option down in the tuning menu eliminates this>
  • Okay so I just ran into an issue and not sure if it’s because of the new FM or what. Last night everything was working great and then after playing a couple hours tonight now the rev lights on my rim are going crazy lol. Even the flag lights are flickering and such. The rev lights on the base are working just fine but the rim is gone nuts. Everything else seems to work just fine but just the rev lights. Anyone have this issue?
    Haven't heard of this yet, any idea how it could have started and how to reproduce it? Can you please summarize in which situation, game and platform this is happening and can you try the Rev LED test button in the driver UI. If you have the BRF setting in your tuning menu you can also go there and press the b rake to check the Rev LEDs.
    Just to reply back: The support desk had me reflash the firmware and do another test but sadly I will have to send the rim back with an RM they supplied as there is something defective causing the rim LED's to act erratic.
  • edited January 18
    There are still issues with McLaren GT3 wheel with 326 beta driver:

    1. Once updated on the first boot oled display shows SW0000000000000000 at bottom line. Second boot ok, SW 27. Sometimes shows motor revision M0000000000000000000 too and sometimes first 2 rows ok but lower half of the display shows bottom part of F logo.

    2. After update when re-calibrating for the first time it freezes in the setup menu and setup menu button stops working completely. After another reboot works ok, some very brief glitches on the oled display though

    3. Right hand side up/down switch works only one way

    4. Pressing xbox/ps button registers X button (on PS4, don't know what it is on xbox) at the same time.

    5. If disconnected (on PS4) it cannot be reconnected without a reboot, sometimes even reboot isn't enough but have to remove the wheel.

    So definitely a no-go for 326 if you have a McLaren GT3 wheel.

    Tested with CSL Elite PS4
    1. and 2. I could reproduce that and give this information to our developer
    3. So pushing left paddle is up- and pulling it is downshift and this works but on the right paddle one of the actions doesn't work? Both paddles have the same mechanical button for up- or downshifting, so when it works on one side both ways, it should work too on the other side.
    4. and 5. also reproduced, thank you 


    3. Sorry, I meant the red tip up/down switch on the front side on the McLaren GT3 wheel, not the shifting paddles. But it seems rebooting solved this issue and now it is working both ways.

    Happy to help you.
    With a quick test of 328 I can confirm that issues #1 & #2 have been resolved. Issue #3 is not. In fact, with 328 PS4 buttons L2 & R2 do not work at all (that is the two red tip up/down switches). However, all other buttons work nominally, except for the PS/XBOX button, see issue #4.

    Issues #4 & #5 still remain.

    So still no-go with McLaren GT3 & 328 but we're getting there.

    PS. I'd prefer the default settings in SET 1...5 would be equal. Now they are not - there is some minor variation on BRF & FEI (might be other too).
  • Have a brand new GT3 McLaren rim and having issues with up/down shifts in the paddles (either not detecting or shifting multiple times).  I was using V311.  Upgraded to this and same issue.

    Any advice if this is a firmware/software bug or rim bug?  I would think because both up/down shifts are a problem it has to be software related...
  • Have a brand new GT3 McLaren rim and having issues with up/down shifts in the paddles (either not detecting or shifting multiple times).  I was using V311.  Upgraded to this and same issue.

    Any advice if this is a firmware/software bug or rim bug?  I would think because both up/down shifts are a problem it has to be software related...
    Unfortunately, as far as I know the shifting issue is hardware related. You should contact Fanatec support.
  • Hi there,

    I still got issues with the F1 2018 wheel. Updated already the base firmware (326) and the wheel firmware (21). It works fine until it switches into the tuning menu for no reason and it keeps doing this very often. (Game was Assetto Corsa Competizione, but should not be game-related)

    Any suggestions? Thank you.
    Hi, I'm hearing this for the first time.
    - Did you experience that also before those 2 drivers and firmware 21?
    - Does it happen when you use other buttons ore completely on it's own?
    Haven't tested before, updated Wheel and Base to this state and then started testing. It seems, that the Wheel disconnects for a nanosecond and is up nearly instantly. But this short time is enough to not be able to drive flawlessly.
    I centered it again today and tested rFactor2 as well, but same issues. It seems that it doesn't really matter which button you are using and it happens sporadically, but quite often.
  • To all McLaren GT3 Steering Wheel owners!

    Attached you can find the new Firmware V28 to which you should update your McLaren Wheel when using Driver 326!

    Issues that should be fixed with V28 (please give us your feedback if you come across any issues)
    - Freeze when booting the Wheel Base with the McLaren Wheel attached
    - Buttons stop working after some time

    How to update:
    1. Open the driver UI
    2. Switch to the "Update" tab
    3. Choose "Update Steering Wheel Firmware"
    4. press "Connect"
    5. use the three dots "..." to select the file "RMcL_V28_rev31_app.hex" contained in the .zip attached to this post.
    6. "Flash Firmware"
    7. Wait until the process is done and the Wheel Base restarted
    8. Close the Firmware Update window

    Thank you for testing.

    Hi Marcel, I have the update downloaded but having trouble opening it. I have unzipped the file and extracted all, but when I click to install I get a popup box stating how would you like to open, am I missing a step?


  • To all McLaren GT3 Steering Wheel owners!

    Attached you can find the new Firmware V28 to which you should update your McLaren Wheel when using Driver 326!

    Issues that should be fixed with V28 (please give us your feedback if you come across any issues)
    - Freeze when booting the Wheel Base with the McLaren Wheel attached
    - Buttons stop working after some time

    How to update:
    1. Open the driver UI
    2. Switch to the "Update" tab
    3. Choose "Update Steering Wheel Firmware"
    4. press "Connect"
    5. use the three dots "..." to select the file "RMcL_V28_rev31_app.hex" contained in the .zip attached to this post.
    6. "Flash Firmware"
    7. Wait until the process is done and the Wheel Base restarted
    8. Close the Firmware Update window

    Thank you for testing.

    Hi Marcel, I have the update downloaded but having trouble opening it. I have unzipped the file and extracted all, but when I click to install I get a popup box stating how would you like to open, am I missing a step?

    No Worries, All Sorted!



  • Have a brand new GT3 McLaren rim and having issues with up/down shifts in the paddles (either not detecting or shifting multiple times).  I was using V311.  Upgraded to this and same issue.

    Any advice if this is a firmware/software bug or rim bug?  I would think because both up/down shifts are a problem it has to be software related...
    Unfortunately, as far as I know the shifting issue is hardware related. You should contact Fanatec support.
    Armin told us it is an firmware issue ;)
    I'm also having the double shift issue. I thought it was my wheel.
    Sorry guys, we are working on it with our highest effort. Be assured that it is a FW issue. We can reproduce the issue with units that are already verified to be perfect in terms of hardware functionality. 

  • Have a brand new GT3 McLaren rim and having issues with up/down shifts in the paddles (either not detecting or shifting multiple times).  I was using V311.  Upgraded to this and same issue.

    Any advice if this is a firmware/software bug or rim bug?  I would think because both up/down shifts are a problem it has to be software related...
    Unfortunately, as far as I know the shifting issue is hardware related. You should contact Fanatec support.
    Armin told us it is an firmware issue ;)
    I'm also having the double shift issue. I thought it was my wheel.
    Sorry guys, we are working on it with our highest effort. Be assured that it is a FW issue. We can reproduce the issue with units that are already verified to be perfect in terms of hardware functionality. 

    no, Armin meant the F1 2018 LE Wheel with this statement - not the McLaren one. The McLaren one seems to be hardware related issue afaik.
  • edited January 19
    Have a brand new GT3 McLaren rim and having issues with up/down shifts in the paddles (either not detecting or shifting multiple times).  I was using V311.  Upgraded to this and same issue.

    Any advice if this is a firmware/software bug or rim bug?  I would think because both up/down shifts are a problem it has to be software related...
    Unfortunately, as far as I know the shifting issue is hardware related. You should contact Fanatec support.
    Armin told us it is an firmware issue ;)
    I'm also having the double shift issue. I thought it was my wheel.
    Sorry guys, we are working on it with our highest effort. Be assured that it is a FW issue. We can reproduce the issue with units that are already verified to be perfect in terms of hardware functionality. 

    no, Armin meant the F1 2018 LE Wheel with this statement - not the McLaren one. The McLaren one seems to be hardware related issue afaik.

    Ow damn, I hoped (and thought) it was the same for the McLaren. So to be clear if anyone has an problem with the McLaren wheel regarding the shifting problems they should contact support and it will not be fixed with an updated firmware? @Armin Habermann could you confirm this?
  • When is the off center issue going to be resolved?! It is actually very annoying and didn’t buy a fanatec wheel to have problems with it.
  • I just wanna let you guys know Mclaren rim works without any issues with fw v28 so far (CSW2.5 on PC). Thanks for the quick fix!
  • Does the. McLaren wheel issue that I saw with 324 losing the SET 2 screen persist?
  • I am testing the new driver 326 with fw 28 on the McLaren GT3 Wheel (PS4 Elite Base), it worked without any problems the last 2 Days in several Races and Games.
    But today i was in the middle of a Race in iRacing, and suddenly i could not shift anymore, steering and Pedals were still working.
    Whilst driving i pulled out the wheel and put it back on, and then it was working again.

    Its not a good feeling when and error appears so late, this means every update we have to test several Days, before we can be sure the error is gone.(it was the same with v326 and fw 27 with mclaren wheel, it worked a few Races , and then suddenly the buttons were not working)



  • Reporting an issue that goes back to the first driver update that allowed the LE 2018 F1 rim to work with my CSL PS4 base. I have had the McLaren rim since last April and all the button work perfectly, it wasn't until I did the base update to allow the F1 rim to work that I lost half the functions of the toggle switches. The up positions on both toggles will now not function. I have tried going back to the driver/firmware for the McLaren and the only change is not having fuctionality for the F1,but the toggles still will not function fully. I mainly run RaceRoom and this is where the issue is, on Assetto Corsa Competizrione everything works great so not sure if it's a driver/firmware problem or what. With D326 FW28 I still have an issue where when powering on the base with the McLaren the LED screen will freeze up and the on screen text will merge with the Fanatec logo. When going into the wheel options while in game and on track the wheel functions will freeze and not operate, I just experienced this last night while in game (Raceroom). The only way to resolve is to power off the wheel and restart, sometimes this will cause a loss of function in game so that will need to be shut down also and restarted What information is need to document and address this issue? When having to go through this in VR it makes evenig running a race not worth it and not confident in even signing up for a race and hope this can be resolved soon and not an issue I will have with my DD2 pre-order when it comes.
  • edited January 20
    I am testing the new driver 326 with fw 28 on the McLaren GT3 Wheel (PS4 Elite Base), it worked without any problems the last 2 Days in several Races and Games.
    But today i was in the middle of a Race in iRacing, and suddenly i could not shift anymore, steering and Pedals were still working.
    Whilst driving i pulled out the wheel and put it back on, and then it was working again.

    Its not a good feeling when and error appears so late, this means every update we have to test several Days, before we can be sure the error is gone.(it was the same with v326 and fw 27 with mclaren wheel, it worked a few Races , and then suddenly the buttons were not working)
    I have the same issue! I updated from v311/SWFw 25 to v326/SWFw28. Is this a known bug or is it new? I had a race today and had to restart the base to get Wheel back to work.
  • Quick report on the McLaren Firmware.

    I am one of those who had a single button quit working on me randomly.  I just updated to the 326 drivers and the new wheel firmware and the results were not good.  I hopped into rfactor2 and out of the pits ALL buttons on the rim quit working, including the shift buttons.  The base seemed to be working fine (FFB, steering), and the pedals were working fine also.  I reset the wheel and it worked until I cycled back up to 5th gear and all buttons dropped out again (this included the wheel menu button).  I coasted around in 5th gear where everything kicked back in for a few seconds before the buttons dropped out again.  Also when this dropped out the LCD froze with a 5 on it (for gear).

    I loaded up Automobilista and the same thing happened.  Didin't have time to test things out more, will probably do so later today.
  • edited January 21
    I am one of those who had a single button quit working on me randomly.  I just updated to the 326 drivers and the new wheel firmware and the results were not good.  I hopped into rfactor2 and out of the pits ALL buttons on the rim quit working, including the shift buttons.  
    Hi Fred,

    if your McLaren is not working nicely with any FW...you should contact support. There was no known McLaren Issue before we where working on this beta. If you had issues with the previous official FW...then it might be a hardware problem. Please get it fixed getting in touch with our support team.

    @ Everybody helping to test this SW
    Please mention only issues which are FW related. Issues which are present on EVERY FW might be no FW issues. Cross check with other FWs to make sure the issue is related to the latest software. Of course this is not possible with the F1 2018 wheel, so feel free to mention every found issue with the latest driver/firmware, as an exception.

    @ Bernd and Daniel
    Same...please cross check your McLaren with other firmwares. If you have ALWAYS been suffering from such an issue...please get in touch with our support. If there is another software version which does not show such a problem. Switch to this version again...for 2-3 days, or even a week. Make sure the issue is gone. Then switch back to this new version again and let us check if the problem re-appears. We need to isolate the root cause. 

    THX!
  • @ Bernd and Daniel
    Same...please cross check your McLaren with other firmwares. If you have ALWAYS been suffering from such an issue...please get in touch with our support. If there is another software version which does not show such a problem. Switch to this version again...for 2-3 days, or even a week. Make sure the issue is gone. Then switch back to this new version again and let us check if the problem re-appears. We need to isolate the root cause. 

    THX!
    After the buttons were not working in 326 with fw27, i switched already back to my previous driver 312 ( also flashed back the base & Wheel to older firmware again).
    And  it worked with 312 without a problem until i tried the new fw28 (installed 326 again , flashed base firmware and then fw28), where the problem came up again, in both  cases it could drive one or two days and several races before i had the problem.

    before that i was using v312  without big problems
    I am driving quite a lot and i mainly use the mclaren Wheel,  a few hours a day probably 5-7 days a week,
    i can only remember one time when i have a similar Problem (could not shift anymore) with drive 312 , but it happens only once , and it worked many weeks before and after that happened.

    i did not tried the new driver because i had a problem with v312, everything was working normal for many weeks.
    i just like to have and test new driver and functions, so every time a beta driver is available, i test it.
    Right now i am already back to 312 and old firmware


  • edited January 21
    Hi Armin,

    I can replicate what Fred wrote about the buttons stopping to work with the V28 firmware for the McLaren rim. When I rolled back to V311/V25 everything was working again. I haven't tested the V311/V28 combination though, maybe worth a try to isolate the problem further.
  • I am one of those who had a single button quit working on me randomly.  I just updated to the 326 drivers and the new wheel firmware and the results were not good.  I hopped into rfactor2 and out of the pits ALL buttons on the rim quit working, including the shift buttons.  
    Hi Fred,

    if your McLaren is not working nicely with any FW...you should contact support. There was no known McLaren Issue before we where working on this beta. If you had issues with the previous official FW...then it might be a hardware problem. Please get it fixed getting in touch with our support team.
    Thanks for the reply Armin,

    The only problem with the McLaren rim that I had was the occasional button not working (and then sometimes fixes itself). It was very infrequent so it was hard for me (and for you all likely) to pinpoint the cause.  I DID NOT have the shifting issue that others have had with the wheel. Shifting on my wheel has been perfect from the get go.

    I had opened a support ticket with customer service but that was a while ago.  From the discussions I was told that it didn't look like it was a hardware issue (and no offers to do an RMA), and that it was likely a software/firmware problem.  Since I didn't have much time to do any further troubleshooting I was just waiting for a newer FW to see if things got fixed.  I just found out about this new FW and decided to give it a try.

    I'll contact support again to see what they think the next steps should be.
  • Been using the CS V2 F1 along with the CSW 2.5 base for a couple of hours now and so far everything seems to be working fine, shift issues gone and rotary knob on pulse mode also ok. Below are the drivers and firmware I used:

    PC driver: 326
    WB FW: 592
    SW FW: 21
  • Scratch my previous post, I also have issues with Mclaren rim(CSW2.5/PC, v326, fw28), buttons quit working after sometime randomly. Rolling back to v312, fw25.
  • Been using the CS V2 F1 along with the CSW 2.5 base for a couple of hours now and so far everything seems to be working fine, shift issues gone and rotary knob on pulse mode also ok. Below are the drivers and firmware I used:

    PC driver: 326
    WB FW: 592
    SW FW: 21
    Are you sure about WB FW is 592? I have 594. I'm asking to maybe test this FW because I still got the issue, that the wheel is going into the tuning menu randomly. I just made a new test in AC:
    Approx. 8-10 minutes the wheel was working fine. Then it switches into the Tuning menu again. I recalibrated it and it works another 8-10 minutes. Going on (with no recalibration) it worked 2-3 minutes, and then 1-2 minutes. So it seems that the time between the random switches is decreasing.
  • Been using the CS V2 F1 along with the CSW 2.5 base for a couple of hours now and so far everything seems to be working fine, shift issues gone and rotary knob on pulse mode also ok. Below are the drivers and firmware I used:

    PC driver: 326
    WB FW: 592
    SW FW: 21
    Are you sure about WB FW is 592? I have 594. I'm asking to maybe test this FW because I still got the issue, that the wheel is going into the tuning menu randomly. I just made a new test in AC:
    Approx. 8-10 minutes the wheel was working fine. Then it switches into the Tuning menu again. I recalibrated it and it works another 8-10 minutes. Going on (with no recalibration) it worked 2-3 minutes, and then 1-2 minutes. So it seems that the time between the random switches is decreasing.
    Yep, WB FW is 592. I tried to force an update but a pop up showed up saying I have the latest WB FW so I couldn't update to 594. Maybe 594 is for another WB, I guess.
This discussion has been closed.