Fanatec Beta Driver V328 for CSL and CSW Bases (all wheels) - Release Candidate!

245

Comments

  • Driver Version 328 CSL E Base FW 629 McLaren RIM FW 30 I can confirm the notchy feeling while driving with this base-FW even with DRI off. Tried it in PCars2. While in Fanatec-CP turning the wheel from left to right slowly with DRI-settings smaller than 3 (damping) it feels like the wheel is loose. Takes like 10° left or right for the damping to kick in. Downgrade base-FW to Version 593 and everything is fine again. I can also confirm what Akeem Dorset has written above: In terms of DRI FW 593 is by far the best version for the CSL-E base.
  • edited February 24

    Has something changed with the calibration process? No matter how many times I reboot and press the two joy sticks it will not calibrate.

     

     

    Wheel Base Model (product ID): CSW v2

    Steering Wheel Model (product ID): Porsche 918

    Driver Version: 328

    Base FW Version: 627

    Wheel FW Version: 627

    OS: Windows 10 64bit


  • Has something changed with the calibration process? No matter how many times I reboot and press the two joy sticks it will not calibrate.

     

     

    Wheel Base Model (product ID): CSW v2

    Steering Wheel Model (product ID): Porsche 918

    Driver Version: 328

    Base FW Version: 627

    Wheel FW Version: 627

    OS: Windows 10 64bit


    Are you in the tuning menu when you press the buttons to center the wheel?
  • Has something changed with the calibration process? No matter how many times I reboot and press the two joy sticks it will not calibrate.

     

     

    Wheel Base Model (product ID): CSW v2

    Steering Wheel Model (product ID): Porsche 918

    Driver Version: 328

    Base FW Version: 627

    Wheel FW Version: 627

    OS: Windows 10 64bit


    Are you in the tuning menu when you press the buttons to center the wheel?

    Not sure what the problem was. Pulled the power then came back a few hours later and it worked first time..

  • edited February 25
    Hello.

    I have just got the mclaren wheel for the csl elite wheelbase.

    i have a issue with the up-shift does not work sometimes, and it instantley goes 2 gears down when downshifting. 
    all the newest drivers is installed (v311) will this update help?

    does anyone know what it could be?
    Normally the shifter problem should be resolved with WHEEL fw 30, but it's best to update the motor fw (only CSL E PS4) and base fw too.
  • Hello.

    I have just got the mclaren wheel for the csl elite wheelbase.

    i have a issue with the up-shift does not work sometimes, and it instantley goes 2 gears down when downshifting. 
    all the newest drivers is installed (v311) will this update help?

    does anyone know what it could be?
    In this topic you see, as first post, the LATEST driver V328 and firmware V629 or V630, depends on which CSL E base you've got. Install that one on your base, update the wheel firmware too, and if you've got the CSL E PS4, update the motor fw too. Normally the shifter problem should be resolved
    Question: How and where do we find the latest Motor FW??? How do we know that we have the last one??? When I try do update the Motor FW I only reach a Dialog where it demands me to load an Hex file but it show only "Default" .. Nothing else...

    My wheel is the European Fanatec CSL ELITE PS4 and I only have the base wheel and Rim that comes with the package...


  • Hello.

    I have just got the mclaren wheel for the csl elite wheelbase.

    i have a issue with the up-shift does not work sometimes, and it instantley goes 2 gears down when downshifting. 
    all the newest drivers is installed (v311) will this update help?

    does anyone know what it could be?
    In this topic you see, as first post, the LATEST driver V328 and firmware V629 or V630, depends on which CSL E base you've got. Install that one on your base, update the wheel firmware too, and if you've got the CSL E PS4, update the motor fw too. Normally the shifter problem should be resolved
    Question: How and where do we find the latest Motor FW??? How do we know that we have the last one??? When I try do update the Motor FW I only reach a Dialog where it demands me to load an Hex file but it show only "Default" .. Nothing else...

    My wheel is the European Fanatec CSL ELITE PS4 and I only have the base wheel and Rim that comes with the package...


    There is no - and there never was - a new motor firmware available for the CSW v2.5 or CSL E PS4. So no need to even try to update. V18 is the latest (and only one ever released). IF there is a new motor firmware sometime in the future, you will get a popup in the driver menu which tells you to update. If you don't see any automatic popup, there simply is no new motor firmware.
  • edited February 25
    My fault indeed. You see the motor fw number at the first page of the update page. If there's nothing next to it written in red.. You've got the latest. And "flash (firmware)" is the button to click ;)
  • No Comment!
    We are in constant contact with Codemasters and try to make it happen.


    IMO it feel like the total FFB output has been reduced i always used 50% on wheel FFB but Now i must use 65% on wheel FFB to get the same wheel strength....but this is Not a Bad thing because the wheel feels better than ever... the Center of wheel FFB seems to be Much better and FFB ramp up seems Smoother/Better...Ex: wheel does Not Go from Limp to Strong FFB all of a sudden.... Games tested PC Pcars2, Race Room, ACC & AC <--- Very Suprising AC FFB feels better than ever and is a Sim I would Actually play Now ---> AC FFB has always felt very Much like a Rubberband with No Real Road Feel or Curb Feel.
    FFB strength/scaling has only changed on Xbox and was not touched in any other mode of the wheel bases. Only things that got changed as well where the drift mode behavior, but if you use negative values there or OFF, there is no difference.

    Hello.

    I have just got the mclaren wheel for the csl elite wheelbase.

    i have a issue with the up-shift does not work sometimes, and it instantley goes 2 gears down when downshifting. 
    all the newest drivers is installed (v311) will this update help?

    does anyone know what it could be?
    Like Maurice said, try with 311 and 328, if it happens with both you should contact support.


    Just updated to V328, and seem to be having a small issue.
    After about 20 minutes to half an hour of driving the wheelbase starts to feel like the bearings inside go 'notchy' when turning the wheel from the FFB, and progressively gets worse. Only happens when driving the car or when sitting in the garage, but when returning to menu when no FFB is used it feels smooth and normal again. Game is rFactor2.
    After turning the wheelbase off then back on again it returns to normal, until another 20 minutes or so then it starts again.
    Does it with both the F1LE steering wheel and the McLaren GT3 wheel. This concern started with the V327 update and is still present with the V328, and seems to be with the wheelbase driver/firmware as it happens with 2 different steering wheels.

    Keep up the good work and hopefully we get a full release driver package soon!

    Wheel Base Model: Clubsport V2
    PC Driver: 328, Base Firmware: 627
    Steering Wheel Model: F1 LE
    Wheel Firmware: 30
    Steering Wheel Model: McLaren GT3
    Wheel Firmware: 22
    i also can confirm this. It is like feeling "gears" inside the wheel.
    Game is also rFactor2, when closing the game it is back to normal. (also had it with driver V327)

    Is it correct that the + values driftmode settings aren't speeding up more as it used to?
    I feel DRI +1 to 3 is a bit damped, like a negative value. When i turn the wheel it stops immediatly. The "off" setting is even less damped.... I can only feel the motor speeding up a tiny bit on +4 and +5.
    So i downgraded back to V311 to test and it was like it used to be. Now running V328 again.

    Wheel Base Model (product ID):Clubsport V2.5
    Steering Wheel Model (product ID): BMW GT2
    Driver Version: V328
    Base FW Version: 628
    Wheel FW Version: ....


    Just tried in iRacing, and can confirm issue still happens. Exactly the same as in rFactor2. Tried changing setting on the wheel with drift/ffb etc and nothing changed the 'notchy' gearing feel.
    Also tried reverting back to driver V311, and leaving wheelbase firmware V627 (Clubsport V2), and problem still remained. Narrowing it down to a possible firmware issue.
    Hope this helps.
    Very weird, please try to compare old FW with new FW to nail it down.


    Driver Version 328 CSL E Base FW 629 McLaren RIM FW 30 I can confirm the notchy feeling while driving with this base-FW even with DRI off. Tried it in PCars2. While in Fanatec-CP turning the wheel from left to right slowly with DRI-settings smaller than 3 (damping) it feels like the wheel is loose. Takes like 10° left or right for the damping to kick in. Downgrade base-FW to Version 593 and everything is fine again. I can also confirm what Akeem Dorset has written above: In terms of DRI FW 593 is by far the best version for the CSL-E base.
    Ok thanks for the information I'll try to find out more about it
  • Hello.

    I have just got the mclaren wheel for the csl elite wheelbase.

    i have a issue with the up-shift does not work sometimes, and it instantley goes 2 gears down when downshifting. 
    all the newest drivers is installed (v311) will this update help?

    does anyone know what it could be?
    In this topic you see, as first post, the LATEST driver V328 and firmware V629 or V630, depends on which CSL E base you've got. Install that one on your base, update the wheel firmware too, and if you've got the CSL E PS4, update the motor fw too. Normally the shifter problem should be resolved
    Question: How and where do we find the latest Motor FW??? How do we know that we have the last one??? When I try do update the Motor FW I only reach a Dialog where it demands me to load an Hex file but it show only "Default" .. Nothing else...

    My wheel is the European Fanatec CSL ELITE PS4 and I only have the base wheel and Rim that comes with the package...


    There is no - and there never was - a new motor firmware available for the CSW v2.5 or CSL E PS4. So no need to even try to update. V18 is the latest (and only one ever released). IF there is a new motor firmware sometime in the future, you will get a popup in the driver menu which tells you to update. If you don't see any automatic popup, there simply is no new motor firmware.
    Thankyou Maurice!! (Very much) for the clarification! :)
  • @everyone that was talking about weird FFB in rFactor2, please try to reproduce this also with other sims, not only iRacing and try to explain it in a bit more detail or maybe film the situation (if possible). We've not made any changes lately that would make sens to cause such notches of the FFB, please also try different DRI or FEI settings if they make a difference. It's weird that it mainly happens with rFactor2 which to me was in the past known for some harsh or spiky effects. Not that in the end it just was a flat spot or something like that.
  • Wheel Base Model: CSL E PS4

    Steering Wheel Model ): Mclaren
    Driver Version: 328

    Base FW Version: 630

    Wheel FW Version: 30

    OS: Windows 10 64bit


    I updated the driver and firmware. When I restart the wheel shows me no firmware (not on the Mclaren rim). If I open the Property Page the pop-up for the firmware update for the mclaren rim shows up and the top right shows SW FW: 0. If u do the flash, everything is working. But after the next restart I have to go over the whole prozess again.

    I went back to Drv 311 with its firmware and wheel 25 and its working.
    Tried it on a CSL E Xbox Base and Mclaren rim with Drv328 FW629 and SWFW 30 and i also not getting that problem.
  • edited February 25
    Is it possible, that since the new WB FW the "startup calibration" became very loud and rougher and longer than before?
    And the Fans going off after a while now again! Have had this "Fans goiing off" with  FW 311 don´t know which WB FW came with it, 324 seemed to be OK and also not that noise at Startup. Possible or just Imagination?


    Wheel Base Model (product ID): ClubSport Wheel Base V2 Servo
    Steering Wheel Model (product ID): ClubSport Lenkrad Formula V2 ClubSport Lenkrad BMW GT2
    Driver Version: 326
    Base FW Version: 586
    Wheel FW Version: 21

    Don´t know how to go back to an older WB Firmware to cross check.
  • Is it possible, that since the new WB FW the "startup calibration" became very loud and rougher and longer than before?
    And the Fans going off after a while now again! Have had this "Fans goiing off" with  FW 311 don´t know which WB FW came with it, 324 seemed to be OK and also not that noise at Startup. Possible or just Imagination?


    Wheel Base Model (product ID): ClubSport Wheel Base V2 Servo
    Steering Wheel Model (product ID): ClubSport Lenkrad Formula V2 ClubSport Lenkrad BMW GT2
    Driver Version: 326
    Base FW Version: 586
    Wheel FW Version: 21

    Don´t know how to go back to an older WB Firmware to cross check.
    This thread is about driver 328, you say you are using 326...?!
  • Confusing! 
    Yes, wrong Thread, it´s so hard to read.
    Using Driver 326.
    Is it possible to move this post over or to delete it?
    But at least, the question is the same.
  • Confusing! 
    Yes, wrong Thread, it´s so hard to read.
    Using Driver 326.
    Is it possible to move this post over or to delete it?
    But at least, the question is the same.
    Can't be moved, no because the thread for driver 326 is closed because that driver is outdated. You should install driver 328 to see if your issue is still there. BTW, fans should always go off after calibration and when in idle, that's normal... Boot of the v2 was always noisy when the motor is calibrating itself when the wheel rotates to the right side in the calibration process.
  • Thank You for your help!
    Have this Thing for years now, just wondering about the noise these days, seems to be louder and longer now, 
    Will try newst driver.
    Again, Thank You!
  • @everyone that was talking about weird FFB in rFactor2, please try to reproduce this also with other sims, not only iRacing and try to explain it in a bit more detail or maybe film the situation (if possible). We've not made any changes lately that would make sens to cause such notches of the FFB, please also try different DRI or FEI settings if they make a difference. It's weird that it mainly happens with rFactor2 which to me was in the past known for some harsh or spiky effects. Not that in the end it just was a flat spot or something like that.
    Can confirm also feels notchy in Assetto Corsa, as well as iRacing and rFactor2.
    It is mainly when driving down the straights and turning slightly left to right from one side of the track to the other.
    You can feel you are fighting against the motor as you turn the wheel. When you stop on track and turn the wheel you can still feel it but not as bad. In the garage when no FFB used wheel feels smooth again.
    Reflashed back to V311 with 473 firmware, and maybe there very very slightly but probably over thinking it. Felt normal as it used to be. Reflashed to latest releases again and issue returned, very noticable. Gives the feeling/sensation that the bearings have detents in them, or 'gears'. When turning a sharper corner not really noticable, but then onto straights when turning off centre very noticable and notchy.
    Changed settings spring and damper to OFF, No change. Tried all drift settings, no change. Changed setting shck.vib to OFF, improved feeling slightly however still present.
    Very hard to film as cannot see visually it is all felt through the wheel.
    Hope you can make some sense of this! Not sure what may have changed but I feel there is definately something different., especially when back to backing the driver/firmware from V311/473 to V328/627 on Clubsport V2 Wheelbase with the McLaren GT3 wheel.
    Hope this helps!
  • @everyone that was talking about weird FFB in rFactor2, please try to reproduce this also with other sims, not only iRacing and try to explain it in a bit more detail or maybe film the situation (if possible). We've not made any changes lately that would make sens to cause such notches of the FFB, please also try different DRI or FEI settings if they make a difference. It's weird that it mainly happens with rFactor2 which to me was in the past known for some harsh or spiky effects. Not that in the end it just was a flat spot or something like that.
    Can confirm also feels notchy in Assetto Corsa, as well as iRacing and rFactor2.
    It is mainly when driving down the straights and turning slightly left to right from one side of the track to the other.
    You can feel you are fighting against the motor as you turn the wheel. When you stop on track and turn the wheel you can still feel it but not as bad. In the garage when no FFB used wheel feels smooth again.
    Reflashed back to V311 with 473 firmware, and maybe there very very slightly but probably over thinking it. Felt normal as it used to be. Reflashed to latest releases again and issue returned, very noticable. Gives the feeling/sensation that the bearings have detents in them, or 'gears'. When turning a sharper corner not really noticable, but then onto straights when turning off centre very noticable and notchy.
    Changed settings spring and damper to OFF, No change. Tried all drift settings, no change. Changed setting shck.vib to OFF, improved feeling slightly however still present.
    Very hard to film as cannot see visually it is all felt through the wheel.
    Hope you can make some sense of this! Not sure what may have changed but I feel there is definately something different., especially when back to backing the driver/firmware from V311/473 to V328/627 on Clubsport V2 Wheelbase with the McLaren GT3 wheel.
    Hope this helps!
    Very hard to judge, for example you say it got better with reducing shock but this setting doesn't have to do anything with FFB so definitely placebo in this situation (the setting adjusts the strength of the vibration motors that are rarely used by games, not in AC, iR or rF2 yet). We will keep trying to reproduce the issue.
  • Hello, I have a problem with the left analogic stick. 
    There is a problem of sensitivity when one moves it to the left, it makes a jump from 50% to 75% instead of being linear and no longer has sensitivity on the end of the race. 
  • edited February 26
    Hello, I have a problem with the left analogic stick. 
    There is a problem of sensitivity when one moves it to the left, it makes a jump from 50% to 75% instead of being linear and no longer has sensitivity on the end of the race. 
    Platform? Wheel Base? Firmware version of Wheel Base? Steering Wheel? Firmware Version of Steering Wheel? Which driver? Which game? Double checked with older driver/firmware if the issue is still there?
  • @everyone that reports a "notchy" feeling

    When I'm using the V2.5 and I'm outside of the game and turn the wheel slowly left and right when drift mode -5 is selected I feel something. Otherwise I don't feel anything yet. I've gone through several old firmware versions and it happens with everyone and feels the same. Tried with 2 V2.5s and it's the same on both. Was this maybe there all the time and you just discovered it now? Drift mode OFF I feel nothing as well.

    Can you please try to rotate the wheel against the drift mode -5 and tell me if that's what you are feeling?
  • edited February 26
    Hello, I have a problem with the left analogic stick. 
    There is a problem of sensitivity when one moves it to the left, it makes a jump from 50% to 75% instead of being linear and no longer has sensitivity on the end of the race. 
    If you move the stick to an end position and then rotate it a couple of times, is it linear then? On the very first inputs I can recognize that it's not linear, but then it calibrates it self after some movements over the complete range.
  • I think they're talking about the V2 Marcel, if I remember right
  • Is it correct that the + values driftmode settings aren't speeding up more as it used to?
    I feel DRI +1 to 3 is a bit damped, like a negative value. When i turn the wheel it stops immediatly. The "off" setting is even less damped.... I can only feel the motor speeding up a tiny bit on +4 and +5.
    So i downgraded back to V311 to test and it was like it used to be. Now running V328 again.

    Wheel Base Model (product ID):Clubsport V2.5
    Steering Wheel Model (product ID): BMW GT2
    Driver Version: V328
    Base FW Version: 628
    Wheel FW Version: ....


    I have exactly the same. - values are o.k, also OFF is o.k., But + values are not displayed as + values anymore (they are displayed as 001 to 005 now) and 001 to 003 feels damped.
    001 feels the same as -02, 002 feels like a -01.5 (between -02 and -01) and 003 feels like -01. 004 and 005 are speeding it up a little bit.
    I will check the old firmware tomorrow evening.

    Wheel Base Model (product ID): CSW V2.5
    Steering Wheel Model (product ID): CS Formula Carbon
    Driver Version: 328
    Base FW Version: 628
    Wheel FW Version: ....
  • Is it correct that the + values driftmode settings aren't speeding up more as it used to?
    I feel DRI +1 to 3 is a bit damped, like a negative value. When i turn the wheel it stops immediatly. The "off" setting is even less damped.... I can only feel the motor speeding up a tiny bit on +4 and +5.
    So i downgraded back to V311 to test and it was like it used to be. Now running V328 again.

    Wheel Base Model (product ID):Clubsport V2.5
    Steering Wheel Model (product ID): BMW GT2
    Driver Version: V328
    Base FW Version: 628
    Wheel FW Version: ....


    I have exactly the same. - values are o.k, also OFF is o.k., But + values are not displayed as + values anymore (they are displayed as 001 to 005 now) and 001 to 003 feels damped.
    001 feels the same as -02, 002 feels like a -01.5 (between -02 and -01) and 003 feels like -01. 004 and 005 are speeding it up a little bit.
    I will check the old firmware tomorrow evening.

    Wheel Base Model (product ID): CSW V2.5
    Steering Wheel Model (product ID): CS Formula Carbon
    Driver Version: 328
    Base FW Version: 628
    Wheel FW Version: ....
    The new behavior of the drift mode is on purpose because before it lead to too many problems with oscillations, wheel turning endlessly left and right or in general overreacting. I would say it was always written as 003 and so on because there is no + that can be shown with an 888 display.

  • The new behavior of the drift mode is on purpose because before it lead to too many problems with oscillations, wheel turning endlessly left and right or in general overreacting. I would say it was always written as 003 and so on because there is no + that can be shown with an 888 display.
    Ah o.k., thanks for clarifying that. Then everything is just fine here ;).
    And you're right, of course a 888 can't display a +. It seems my thoughts were already in bed when I wrote that xD

    It's just kinda strange for me, that the first + values are feeling like they would be - values.
  • I just want to say on behalf of GT Sport players. Going from driver 311 to the 328 BETA feels night and day better. More response , more track feedback and my lap times have improved. Only down side is the red toggle switches on the McLaren rim no longer work. But I can deal with that because of how much better it feels.
  • Now when I have driven 328/627 some miles in few games/sims have to say that otherwise everything works with my CSW v2/CSL Elite LC pedals and stuff(hubs, different wheels etc), but drift need fixing. Basically it's not usable now 'cause even setting "1" feel way too jerky and it hinders your driving too much. Before with 292/(fw whatever with that), drift settings 1-2 were ok to use, settings 3 was more like setting 1 now with 328/627.
  • I like.how the drift setting feels. I have it on -4 . I'm on driver 328
This discussion has been closed.