Fanatec Driver 410 for CSL, CSW and Podium WB (all wheels)

1235789

Comments

  • edited August 19

    You can always apply to become a betatester through the beta application form on the website ;-)

    Then you can help us to find all issues way in advance so we will only ever release completely bug-free software in the future :)




  • Hi Marcel,


    on v684 the 918 wheel switch correct to high torque, driver 410 and firmware 684 also workjs but if i update to 686 my 918 wheel is detected as simplyfied qr


    i tried to update with mclaren and 918 wheel connected, both the same

  • edited August 19
  • edited August 19

    Just some info for the team regarding small issue when updating.


    So I updated the Drivers, Firmware and Fanalab for my DD1, Podium Porsche GT3 wheel with PBME.


    Started by uninstalling drivers, then fanalab then rebooting. Installed drivers and rebooted, opened Fanatec Control Panel and ran the Firmware manager and it proceeded to update my DD1 to 686. All went well and the update finished on the DD1 with Wheel flashing CAL (as expected).


    This is where the small issue arose, Firmware update manager showed "Please Wait" with hour glass symbol and I expected it to start the next update for the podium hub but it just sat on Please Wait and didn't progress. BTW V3 CSP were plugged in via wheelbase while updating so not sure if this is what caused the hang.


    So after some minutes waiting (10 or so) I closed the Firmware Update Manager with Task Manager and then restarted Fanatec Control Panel and this time rather than click the green Update button I selected the Manual Firmware Update button and did the Podium Hub & Podium BME manually and it worked perfectly.


    No idea why the updater hung after the DD1 updated to 686 but it was an easy fix to update the others manually and all working as intended as well as all features of Fanalb working as intended.


    Cheers

  • Filled in that form multiple times, never heard from them since so I think they have enough?

    Bug free software is an illusion but some of these bugs should have come out with a regression test and if not it should have been found by one of the beta testers.

    Above could mean 2 things, there aren’t hundreds of beta testers who are actively participating to the beta program OR the spread of used devices in the beta testing program is not enough… aka all beta testers are on a DD1 with a McLaren V2 wheel 😉

    In both cases there is room for improvement. It would. Ever lead to bug free software (I’m fixing more bugs on a daily base than building new stuff and was a beta tester for Native Instruments for years before I even started developing so I know the drill) but the most obvious ones can be fixed before a release.

  • Unfortunately I have a problem when updating the firmware for the DD1 PS4. 

    Have done everything as described, but after about 1h update time of the firmware I have manually canceled the update. 

    Now the base can no longer start, if I press the power button only the fan starts to run, if I leave it off the fan stops again.


    Mfg Tommy

  • LOL, Although I don't know much about the history of GT3, I don't think that's a great analogy. GT3 has never existed - it's vapour ware, nobody is invested in it.

    I do know a little about managing complex development programmes though and understand the real life importance of sharing delivery roadmaps, managing expectations and the importance of 360 feedback. Not providing customers with anything until you deliver " the product" is absolutely NOT how you should approach this.

    Like I said earlier - Fanatec really need to invest in this side of the business as it is letting the company down. It might look to those in charge like low level nagging and moaning in the background while they are blinded by recent growth and the new shiny things, but longer term it will impact growth. It needs fixed now. There is a blog - that could be used to describe the work that your army of talented developers are doing and what the longer term aim is. It won't stop all the moaning but it is worth the effort ...

  • I have the same problem with my DD1 + Porsche 918 wheel. Mclaren with the metal QR is working fine..

  • Maurice Böschen are you still clearing the Sensor Calibration on the DD with this new version?


    Cheers

  • hello, I read that several people complain about losing the hi torque on DD2 with the bmw gt2 and 918 rsr steering wheels. is this a wish of fanatec (however it is not marked in the changelog) or is it a bug? What is certain is that I will stay in 402 and wait for a working driver.

  • edited August 19

    Obviously it's a Bug for a very few amount of people which for now nobody internally can reproduce at all. It's one if this super weird issues affecting 0,1% of the users..

  • Ok, if I'm motivated, maybe I'll test tomorrow. Whether it works or not I will come back and say it


  • Hi Maurice,


    As requested, I performed a manual installation of the Wheelbase firmware from 684 to 686. YES the pedals became non responsive 10 minutes or so in to an AC drive.


    ADDITIONALLY, I noticed the following problem, both with and without the host PC turned on, the wheel keeps oscillating;




    I have again uninstalled 410 and reverted to 402 with wheelbase firmware 684. Fingers crossed your developers can resolve this issue soon.

  • The vibrations are a side-effect of the Motor Calibration.

    You can try to erase the motor calibration which should fix the vibrations.


  • Marcel,

    Yes, the pedals are connected tot he base, I wasn't using Fanalab, just the UI from the driver and just on my laptop as that is how I tune my break pedal for the best feel/performance.

    I will say the new driver works great, kept all of my previous settings and the difference in the feel through the steering wheel is top notch.

  • The 410 update has fixed a few issues


    I have noticed that on the CSL elite with no LC the BRK.LVL rumble I have on my V2 rim IS weaker I can hardly feel it any more which is a same bar that I have no other issues yet will know when I have my endurance race on my ps this weekend.

  • I went from the 402 to 410 driver on a DD2 base, for the moment no problem with my 918rsr, Bmw gt2 and formula v2 steering wheels and the V3 pedals, to be continued

  • BMF CoandaBMF Coanda Member
    edited August 20

    I use to run my setup this way however I changed after v402 as it mentioned the following..


    • Improved smoothness of the load cell / brake pedal signal. Pedals need to be plugged in via USB for the firmware update. Never connect pedals via USB and RJ12 at the same time! In case you want to compare old and new or revert to the old one -> change Firmware Manager to manual update, open the Updater and then use the 3 dots to select version 1.30.


    I thought I would mention that after the wheelbase firmware update (DD2) it proceded to the wheel rim update and hung for 10 min. I had to kill the firmware manager and kick off the process again starting at the wheel rim. No issue the second time around..

  • I filled in that form multiple times (and just did it another time especially for you 😉), never heard anything since. And bug free software is an illusion but last releases were followed by a bunch of hotfixes filled with fixes for bugs that should have come out of regression. Apparently none of those hundreds of beta testers did find this "low hanging fruit" which makes you wonder, are there really hundreds of testers that are actively participating (which i doubt) or are all beta testers testing with a similar hardware setup (that would be an easy fix).

    I did beta testing for Native Instruments (also a German company by the way) for years. Did a lot of hardware integration testing while testing Traktor DJ and and all of those midi controllers that came out somewhere between 2005 and 2010. Had a review site back then so always fresh hardware to test with. So i know a tiny bit about beta testing 😉

    But if they need more beta testers, Fanatec should have my contact details somewhere since i filled in that form multiple times.

  • Marcel PfisterMarcel Pfister Member, Administrator

    According to the log files you have a ClubSport V2.5 base which is currently not yet supported by the new UI. This is also mentioned in the first post of this thread.

  • edited August 20

    I tried to update my DD1 PS4 from 402 to 410. I Installed the new Driver an started the Update Process. Unfortunately the Process stopped an the Window closed it self after a few Minutes. Now my DD1 is basicly bricked.


    When I tur on the Wheel, the Fan spins like Crazy, the Wheel is not recognized any more and the display stays black. I tried to roll back to 402 but nothing changed here.

    Can I somehow hardreset my DD1, so i can restart the whole process?


    I tried to reflash the Firmware by holding the Power Button at startup by several seconds, and the flash Process startet, but then i only got this:


    Podium Direct Drive Wheel Base detected

    Device connected

    Selected firmware V684 has been loaded successfully.

    Flash Erased

    No Response from the device. Operation failed


    Thanks

    ____________________________________________________________________________


    Und nun nochmal in deutsch..


    Ich habe heute versucht von Treiber 402 auf 410 zu updaten. Beim flashen der Firmware hat sich das Flashprogramm dann leider aufgehangen und nach einer Weile von selber geschlossen. Nun scheint mein DD1 leider nicht mehr erkannt zu werden, nur der Lüfter geht an und dreht wie wild, das Wheel schlägt leicht nach rechts ein, aber das Display auf der Base bleibt schwarz.


    Ich habe versucht wieder auf den 402er Treiber zurückzuwechseln, leider aber ohne erfolg.


    Kann ich mein DD1 irgendwie resetten, damit ich den Prozess nochmal neu starten kann?


    Vielen Dank.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thank you for the information, some others seem to also found out it works with one PC while doesn't with the other.

    We need to investigate on the difference of each PC, could you please export the DxDiag information of both as a .zip file and name the one which works and which doesn't work accordingly? This would help us to maybe find what might be causing it. Also are there any significant software differences like Anti-virus or else?

    How to get DxDiag:

    https://support.microsoft.com/en-us/windows/open-and-run-dxdiag-exe-dad7792c-2ad5-f6cd-5a37-bf92228dfd85

  • Marcel PfisterMarcel Pfister Member, Administrator

    Hi Mark, I've downloaded your log files but couldn't open the zip and an error message appears. Can you please check and re-send them, thank you.

  • Marcel PfisterMarcel Pfister Member, Administrator

    We had some more tests and still weren't able to reproduce the issue, really weird thing. We'll continue looking into it.

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited August 20

    Do you know during which update it happened (Base, Motor, QR, Wheel)?

    Diid the Firmware Updater show an error?

    Can you try pressing and holding the power button for 10 seconds, it will force a Firmware Update again.

    If the problem stays you need to contact support through the "My Products" page in the shop.

  • Marcel PfisterMarcel Pfister Member, Administrator

    I've said several times that we are still working on it including information on why it's taking so long.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Only the pedals? Do you use the RJ12 cable to the pedals which came with the PDD or the one which came with the CSP V3?

    Does it make a difference if you are using FanaLab or not?

    Does it make a difference if you are pluggin in the pedals through USB? (don't plug USB and Rj12 in at the same time)

  • Marcel PfisterMarcel Pfister Member, Administrator

    Can you unplug the USB, re-boot the base and then re-test the BLI vibration and let me know if its then working better as when later plugging it in again.


  • Sorry Maurice and with all respect, that’s not an appropriate answer at all!!!

    Actually I'm kind of disappointed about the ongoing approach Fanatec is taking for Software topics and the way of implementation. Of course you can argue that the published drivers are beta drivers but most of the time those drivers are just beta and no official ones. It seems that the development/testing of the Fanatec/Fanalab software are outsourced to paying customers and users than internal Fanatec but paid employees.

     I have been buying four DD1 and also one DD2. I'm a DD user since long time and I remember the road and how we came to the 4.02 official drivers. It has been painful to get it running.

     I had been hoping that this kind of approach might change since the previous releases which had caused frustration and anger by a significant number of Fanatec customers which are paying for a product and not get paid for the development.

     Some of the answers I'm reading are just not in the right manner, they are kind of aggressive, "shut up", “take it or leave it” style.

     It's a matter of fact that some issues are here forever, like the jolts thing, it's just not professional to handle it the way it is.

     I'm not a specialist but a "one for all driver packages" (for all Fanatec products) is not only making the development more complicated but also slowing down the process. Why not splitting driver packages for different products? DD1 package, DD2 package, CSL DD package, etc.

     Fanatec has excellent products and the customer service is great and they doing their best to get problems solved, but concerning software it just doesn't match.

     Too much trial and error and outsourced development activity to users which let people getting sad and disappointed. Since people taking time writing lengthy comments and your suggestions asking people to be beta testers with such a smug tase, isn't right.

    From the limited outside view I have, I would not recommend to install the new driver 4.10 packages to existing DD1 and DD2 users, what for? There are no improvements and this would help users and yourself avoiding headaches, it would just need a short info that this driver package is mainly/only necessary for the new CSL DD.

This discussion has been closed.