Formula v2.5 X not connecting to CSL DD

edited November 2021 in Steering Wheels

Hello guys!

I got my CSL DD yesterday and set up all the drivers and firmware and it worked perfectly fine. Today as i woke up and wanted to drive, my steering wheel wasn't working because i had to do an update. The update was finished but my DD was stuck with the blue light. After half an hour i decided to turn off the wheelbase and try to restart it. After that i always got this message (see in screenshot). I tried to reinstall the drivers a few times but nothing helped. Also if i plug my Formula V2.5X on the wheelbase no devices get found but if i take it off the wheelbase my Pedals and Wheelbase are found.


  • Peter CsonkaPeter Csonka Member
    edited November 2021

    Clearly you are not the only one:

    Their Software is a bit of a catastrophe to say the least.

    Sounds like the Wheel is bricked now as it also happened to me here and to a bunch of other people.

    Really your best shot will be opening a Support Ticket.

  • Jeff VivasJeff Vivas Member
    edited December 2021

    I am having this exact same issue. So add me to the list. I was driving and out of no where it wouldn’t shift up (was playing f12021) and I tried shifting few more time and like 5 seconds later it said the controller was disconnected on my screen. Wheel turned to 8 o’clock and would not stop vibrating from the left side of the wheel, and mode light turned yellow by itself (I always have it green as I play on Xbox). I powered it off and tried to restart it but it goes back to pc mode (red light) calibrates completely different and goes back to 8 o’clock and continues to vibrate from the left side. It used to calibrate left to right and center back up. When I try updating it will not recognize any devices Unless I remove my wheel. When I remove wheel my everything updates perfectly fine. When I connect wheel it tries to update over and over again for 30 plus minutes. Idk what else to do. And it will not switch modes. Light only turns yellow and red. I get no more green. My wheel has been working perfectly fine for about a month now. Zero issues. Then this randomly happened in the middle of a race

Sign In or Register to comment.