Fanatec Driver 380 Release Candidate for CSL, CSW and Podium Bases (all wheels)



  • Hi,

    what's up with my system?

    Use DD2, V2 Wheel/APM and UHub/BME/APM on XBox One, playing ACC.

    After experienced first freezes with V2 on 380, I started to downgrade drivers/firmware. Have gone to 346, 352, 365, 373 and finally to 380 again and tested both wheels on each driver (UHub with BME not on 346, of course ;)) while using different USB ports of XBox.

    Always the same, misshifts and V2 freezes occured within 20 min on each driver/firmware, buttons and APM didn´t work, steering and V3 pedals were still fine.

    To restart I've to switch off the base or remove the wheel and attach it again.

    The Hub runs more stable (tested 30 min), but sometimes misshifts occures and on 380 was a freeze,too.

    Very weird. Got the base since release 07/2019 and everything was fine for a long time while gaming AC. Have heard so much about the freeze issue but it never happened to myself. First time I experienced it was after introducing 365, with the Hub and not with the V2, surprisingly. It happend only 2-3 times over the month and was nothing I worried about. It became a real problem after releasing ACC on console and using 372/373. First sporadically then more and more often misshifts and freezes occured. Mainly the V2 is affected, but also the Hub, means it just takes longer. These days gaming isn't possible without these things.

    Would appreciate some help.


  • Hi all,

    i update my setup.

    CSL Elite Wheel Base + (PS4)

    ClubSport Steering Wheel F1 2020 LE

    CSL Elite Pedals LC.

    Everything seems to be fine, no problems.

    Only want to share one thing: before this update V380, on V373 on the Wheel base only appear 2 modes: RED PC MODE and BLUE PS4 MODE. Now it appear a 3rd option Green XBOX it’s normal?

    sorry the thumb questions, but before that never appear to me that option.

    Best Regards.


  • Myles EllerbyMyles Ellerby Member
    edited November 2020

    Yes my CSW V2.5 has had the same issue. Commented on the 29th about this and sent in a support ticket on the 30th asking for their advice on wether I should continue to use my wheelbase or not. Rolling back to previous Drivers and Firmware does not resolve my the problem. It is now so bad it now wont turn on, or if it does it wont stay on for more than 5-10 minutes. I assume something hardware has been damaged as a result of the V380 driver.

    I warn anyone with CSWV2.5 to remain on V328 OR V373, both of these seemed to work for my WB with no obvious issue.

    Very angry at the situation and will be raising a new warranty/RMA support ticket, all software work arounds have been explored, with no solution.

    Please Fanatec do not release V380 in it's current state to replace V328.

  • Do you have a second wheel you attached to the base to access the XBOX mode? Usually you shouldn't be able to switch to XBOX mode with the LE wheel.

  • Seems totally fine on my end. Just used my csw 2.5 for a few hours & fans are working normally.

  • No I don’t have. The hardware I have it’s what I wrote.

    Thats why, I share here because it’s never appear to me.

  • Testing goes on and today there were no problems during 2h gaming with the Universal Hub on 380.

    There's a significant improved function for the d-pad stick of BME. In set up mode there are no faulty side inputs and rotation inputs . Much better than on drivers before.

    On property page is a little cosmetic thing. APM of Hub is only shown when pulling the clutch or handbrake pedal. Otherwise there is BME with the normal pedals to see. Nevertheless the blue testing indicator appears for all pedals.

    Not so important but want to report.


  • Can we swap bases, I'm so annoyed my entire rig has just become an ornament whilst I wait for support to get back to me :(

  • Marcel PfisterMarcel Pfister Member, Administrator

    We'll investigate this now, I would suggest to use a previous driver if the fan isn't running even though it should.

  • I reinstalled v380 and all seems to be working now. Very strange. I will keep an eye on it for awhile. Thanks guys.

  • Myles EllerbyMyles Ellerby Member
    edited November 2020

    Hi Marcel, thanks for getting back to Michael, does give me some reassurance.

    I have made a detailed post on the R/Fanatec. Would you mind checking out the details/videos I provide to help diagnose a potential issue with the V380 driver/firmware. Any questions I'll answer as best as I can.

    If you would like me to post in the report an issue format I can also edit this post.

    Thanks :]

  • Marcel PfisterMarcel Pfister Member, Administrator

    Please install driver 346 and downgrade the FW as well to see if the problem is also happening there

  • Marcel PfisterMarcel Pfister Member, Administrator
  • Marcel PfisterMarcel Pfister Member, Administrator

    Please check the quick guide of your steering wheel for the button combination which switches modes and make sure you are not using these at the same time accidentally. I remember one report where the user accidentally switched modes because he had push to talk and another an in-car adjustment on the same buttons that switch modes.

    • Wheel Base Model (product ID): CSW 2.5
    • Steering Wheel Model (product ID): Porsche & F1 Black Rim
    • Driver Version: 380
    • Base FW Version: 679
    • Motor FW Version: 22

    So far, so good. No weird sounds coming from the base. No chirping. No high pitch noise. While turning or when the wheel is in a certain position. Great. Fan is also working. Personally wish I knew how to change the fans for more silent / better BFM ones, tho.

    Will reply when I experience issues.

  • In case anyone else also just had the latest Windows 10 v.2004 update. It does screw up the driver. I had to reinstall after the update to get it even recognised.

  • That's the case for every big Windows 10 update since forever.^^

  • lol, yeah I figured. Its my first update with Fanatec equipment. Will definitely keep it in mind in the future.

  • I just updated my driver and base firmware with the wheel and PBME not connected to the base.

    After connecting wheel and PBME to the base, I got notifid that there is a fw update for the PBME available.

    On the popup I clicked yes and the DD1 base shut off immediately and fw update showed me a connection failure.

    Have tried it 5 times in a row and I was still not able to perform the fw update on the PBME.

    Any ideas what is going wrong here?

    Tested what you have suggested to no avail.

    Even the rotation on D pad is no longer working.

    Up/down and left/right works fine, but no input when rotating

  • is it working with older drivers? If no, then your BME probably died and you need to contact the support.

  • edited November 2020

    Hi Maurice and Marcel,

    I have done as you requested (although I wasn't too comfortable messing around with firmware flashes backwards and forwards) and reverted to 373 with the older firmware (674, i believe it was). I installed the McLaren GT3 wheel and it did NOT power the CSW 2.5 down.

    I have now reverted successfully back to the new 380 (with 679 firmware). I can remove and connect any of my wheels without issue until (as was the subject of the thread) I connect the McLaren wheel. As happened when i first updated to 380, connecting the McLaren wheel now instantly powers down the base.

    Now that I am slightly more comfortable with the backwards process, I confirm that I completed the same exercise a second time, with the same results.

  • I did manage to perform the fw update on the PBME by connecting base to a different machine with installing fanatec driver for the first time.

    Rotation on D Pad is back working and all parts have been updated to latest availalbe firmware

  • No issues at all here with a CSW V2.5 and a Formula V2 on it, installed the v380 driver on the day it came available and raced a few hours last week and everything is running fine as it also did with the previous driver.

  • I see, do you also own the Shifter/Handbrake?

    My problems never started until I made these purchases and upgraded to V380. To try and shortlist things, I believe either the software has killed some cooling hardware, or maybe my power brick (which has a constant whine when on) can not sufficiently power everything? I would need a more professional opinion on this but it might be as simple as the power brick = dead.

    Maurice/Marcel would you consider the power brick to be a potential area of fault?

    Here's a short clip of my exact issue for anyone else who is in the same boat.

  • I did as mentioned and changed driver to 346 and WB FW 662. Problem stays, so maybe it's an issue from Raceroom.

    Because of the wheel changing back to PC-Mode I can drive normally. There is just one small moment when loosing connection becaus of PS4 Mode.

  • Goodmorning everyone

    I tried the 380 drivers .. before I had the 373 which I was comfortable with.

    now with these new drivers the volant has become drier, almost as if the filters are not working at their best ... drier changes of direction ... very dry curbs and holes ... I state that I first uninstalled the old 373. ... done cleaning .... uninstalled fanalab .... done cleaning .... and then put everything back by reloading the profiles of fanalab .... did it happen to you too?

    steering wheel dd2

    podium porche steering wheel with relative kit

    game assetto corsa

    ffb dd2 50% - in game 55

    ndp 10

    nfr 5

    nin 0

    int 10

    fei 100

    for-spr-dpr- 100

    bli off

    sho 100

    dampening overlay .... off ... I don't know how to use this ... do you use it? i dont understand if it is better on or off

  • Hi. Running 380 with no issues. However for some time now I have been unable to map hotkeys in Teamspeak.

    I have read that it is because the Fanatec wheel does not send a button release signal. Do when trying to map a button in Teamspeak the mapping exercise won't conclude until you press a mouse or keyboard button.

    It will recognise that you have pressed a button on the wheel but won't recognise that you have released the button.

    Is there anything that I can do about this?

  • Marcel PfisterMarcel Pfister Member, Administrator

    In all our tests with the CSW V2.5 the fans started running correctly if the temperature raised and then effectively cooled the base.

    You can see the motor temperature on the wheel display with the following button combination: Both shifter paddles + R2 + Square (at the same time). If you don't have PS4 butt caps look at the quick guide of the wheel, here an example.

  • I have the Fanatec CSL elite for Ps4. With the previous beta driver 373 in ACC for PS4 pro I had my V3 pedal board only with brake pedal vibration. Uninstalling the beta 373 and reinstalling the latest original driver ie v328 in ACC for PS4 now only the vibration of the accelerator pedal works and no longer that of the brake. With this latest beta 380, do vibrations both work for both the brake pedal and the accelerator pedal? Excuse my english. Thanks

  • Nope, not running a shifter or handbrake, just the CSL Elite pedals (without load cell), CSW V2.5 and the Formula V2 steering wheel.

    Power brick had some coil whine since day one when i picked it out of the box and had it in my mind to change it while i had a new CSW V2.5 send because of a faulty bearing but forgot to exchange it (also, i always play with headphones so i don't hear the coil whine).

This discussion has been closed.