FanaLab 1.57.4 Download (Previously 1.57.2) - Post your Feedback here



  • Marcel PfisterMarcel Pfister Member, Administrator

    So far people with high resolution displays or tripple screen are experiencing this and it seems to do with the graphics card having issues with the type of UI at high resolution. There was a post on the nvidia forum as well regarding other types of software which have the same type of user interface as we use. Someone said he fixed it successful by changing a driver setting regarding onboard sound but I can't find the post anymore.

    Do you have nvidia? Could you try using an older driver or lower resolution in case you have a high one to see if it makes a difference.

  • Marcel PfisterMarcel Pfister Member, Administrator

    In the first posts of the driver or FanaLab is a link to the compatible version of each. Also when out of testing phase the product pages should list both the latest driver and latest FanaLab version.

    I'm also putting links in the .zip of FanaLab now which link to the compatible driver, the discussion about FanaLab and the discussion about profiles:

    I'm open for more suggestions.

  • eeeeeeeehm... :D

    Yes the profiles are more on the strong side (in corners usually around 10-12 Nms with Peaks of up to around 15Nm depending on the car and physical steering wheel used) but I am definetely no pro arm wrestler or the Hulk or something like that :D

    Which profile in particular did you tried? And did you adjusted the in game settings according to the included txt files?

  • Hehe well it was the Porsche 911 GT3 R. I adjusted the max Nm setting (to somewhere around 54 I believe) and left the rest as it was in iRacing so maybe I need to make the rest of the changes also.

    Overall the profiles are a pretty good starting point and saved a lot of time since only some minor personal adjustments were needed.

  • edited September 2021

    Look at my comment on 23rd August. Found a solution

  • edited September 2021

    I am having an issue where no matter what I do F1 2021 doesn't work with fanalab.

    I have no other apps running, the game is fine, the UDP packets are sent just fine by the game.

    It does work with the F1 2020 profile though, it doesn't with the F1 2021 profile and either UDP format (2020/2021).

    What seems to happen (verified by running netstat) is that Fanalab never starts listening on the configured port.

    • Fanalab 1.57.4
    • CSW 2.5 / Clubsport V3 / McLaren GT3 v1
    • PC driver: 411 | WB FW: 686 | SW FW: 32

    /cc @Marcel Pfister

  • I just got back from a business trip, downloaded Fanalab, PC Driver 411, and associated Firmware for my DD1 and Formula v2 Wheel. Now, the Fanalab Main and Tuning Menu do not register my DD1 and my setup is unusable. I've read that some other people have had this issue, but all the resetting, uninstalling, installing older drivers/versions of Fanalab, reinstalling, re-flashing etc. have been unsuccessful. To boot, when I try to submit a support request it just deletes the whole thing and says please fill out a subject and message! Talk about frustrating. Any help is greatly appreciated (cough cough Fanatec Support). Thanks guys,


  • Continued...also tried deleting Fanatec and Podium folders under appdata and Program Files and starting over. Also tried the Hotfix v1.57.3 and experienced the same result. No Tuning Menu available. I deleted everything so I don't have a profile to load, but it was saying something about the Base being different and asked me if I want to continue anyway. I have the Xbox Compatible DD1. I don't know if that matters, but I saw some mentioning that they had the PS4 compatible one.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Have you already tried to enable the telemetry again through FanaLab and making sure it listens to the correct port?

    Under settings is a "View Telemetry Feed" function, does it show anything coming in?

    The file responsible for the configuration is the hardware_settings_config.xml under C:\users\*username*\Documents\My Games\F1 2021\hardwaresettings\ maybe you can find a clue there if its set correctly?

  • Marcel PfisterMarcel Pfister Member, Administrator

    We are working on a fix for the P DD being in compatibility mode, maybe thats the case where the issue happens for you as well?

  • Yes, the game is configured correctly and it's outputting the telemetry data just fine.

    I can confirm this by running, bass shaker, dashboards, and other softwares (not at the same time).

    It's fanalab that's not listening on that port, I can confirm this by using netstat.

    On the telemetry panel nothing comes in, and in the main fanalab page it says telemetry uninitialised, and it shows a "!".

  • edited September 2021

    Strange then, can u explain how u get the data for Fanalab. Do u use a UDP Relay or UDP Forwarding?

    netat seems not to list this, even on my computer where all works totally fine

  • are you running Simhub by chance? Did you configure the port forwarding to Fanalab and ingame?

  • To avoid any clash, I have tried by closing everything, simHub, NLR v3 app, etc and run only the game on the default port.

    Fanalab seems just not to listen at all. Pretty sure the game is sending the data just fine, because once I open simhub the data comes in.

  • Eventually, I'd relay that using SimHub. At the moment I am just sending it directly from the game in a chance to make it work in the most basic way possible.

  • please try a different port for example 20888 or 20999, also if you indeed use Simhub try the port forwarding. Otherwise Fanalab can in fact not read the data.

  • Marcel, hmm not sure exactly. I am familiar with switching modes between Xbox, PC, and CSW v2.5, but one of these other modes worked either. Fanalab just doesn't recognize it at all at that point. The control panel notices when not in PC mode, too. Hope this helps you troubleshoot. Let me know if you want me to try anything to help drill down on a solution. Thanks!

  • edited September 2021

    Make sure you use the UDP Format 2020 and not 2021 because FanaLab currently only works with the 2020 data, therefore cant be used Together with other tools which require 2021 UDP data Format - as described in the instruction popup you get after you clicked on "Enable Telemetry" Button in FanaLab where you also set the FanaLab UDP Port.

  • In that case disable Game Detection in simhub. Simhub reads 2021 und forward 2021 Format. Fanalab needs atm 2020 Format. So u Need to choose f1 2020 in simhub manually. Then the Port forwarding should work

  • Thank you for your suggestions. Unfortunately I have already tried all that has been mentioned. Sim hub and different port have nothing to do with it. As well as the F1 UDP format, for the simple reason that I know exactly what I am doing :) and I have very clear how it is supposed to work.

    Fanalab doesn’t start the UDP server listening on whatever port whatsoever. I am not sure what’s the trigger for that, I assume it should start when Fanalab detect the game and activate the profile.

    Also in the fanalab logs there’s no useful information available. Is there any way to get fanalab to output some more verbose logs so to troubleshoot it properly?

  • OK, I found the issue.

    There's definitely a bug in Fanalab 1.57.4.

    Whenever I load the F1 2021 profile, it does say to use port 20777 (or whatever you set), but in fact it always starts to listen on port 20888 instead.

    Not a coincidence that when I was using F1 2020 the UDP port in Fanalab was set to 20888, indeed.

    I reckon someone has been crossing some wires in the source code to redirect the F1 2021 profile handling to the F1 2020 processing code but they have forgotten to load the correct settings for the new F1 2021 profile.

    I suppose most of the users stick to the default port or did not have F1 2020 therefore they are not seeing this issue.

    At least now we know :)

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks for the information, yes there was a change to use the F1 2020 port because F1 had some issues with 2021 telemetry and the one for 2020 worked better.

  • Where is fanalab reading the port setting from? I have looked into configuration file and windows registry but couldn't find it.

    I'd like to avoid having to re-install F1 2020 just for changing the Fanalab port from the UI.

  • Hello Fanatec,

    Coming from the Elite 1.1, Fanalab software had very little benefits (no tuning menu support) so I have ignored it. Now that I got the CSL DD, I thought I give it a go. So far I have no real issues. Everything works from what I have seen and tested so far. There are, however, two things - I searched here in this forum and have not found anybody complaining about it - so maybe it is just my setup:

    NVidia 3070 + 49" 5120 x 1440 @ 120 Hz

    1. Why is the font in Fanalab so bloody small? This app looks like a dotNET app (WPF) and I know from experience it does not scale very well. On my 49" 5K screen it looks downright awful. OK, my eyesight is no longer 20/20 but here I have to stick my nose onto the screen to recognize the game images on the game profile tab, let alone reading the red font on a black background. Jeez, who's idea was that?. Give us at least a scaling option in the settings, please. C'mon it's 2021...
    2. Another thing (a nice to have) if you could combine Fanalab with the new Fanatec Control Panel app (which is quite nice actually)

    Any thoughts or hints?


  • I also have a 49" Ultrawide and have sized it to 2560x1440 in the middle which looks absolutely great.

    There is currently no intention to merge both the very complex Driver UI and the also very complex FanaLab tool into one software. It might come sometime in the (far) future but nothing this or next year for sure. For that both tools are too complex on its own already and Fanatec is much more flexible for releases when both are seperate.

  • Hello Maurice,

    Are you saying you run ACC, AMS2 etc in 2560x1440 (full screen) as well?


  • edited September 2021
  • Ah, OK. Well, even running the app in a window split (using MS PowerToys) of 1920x1080 does not scale the font size up.

    At any rate, maybe you will pass the scale up idea to your software development team and who knows maybe we all will get something out of it.


This discussion has been closed.