FanaLab 1.57.4 Download (Previously 1.57.2) - Post your Feedback here



  • No real big issue, but under Assetto Corsa Competizione's Game Profile tab, the Enable/Disable LED Support instructions are reversed.

  • edited September 2021

    What do you mean? You have a pic? Or maybe you got confused? ;)

    For me its correct. Pressing the "Enable FanaLab's Game LED/Hardware Support" Button correctly shows the hint that you have to disable the Fanatec LED option in the game to enable FanaLab support and the "Disable FanaLab's Game LED/Hardware Support" Button correctly shows the hint that you have to enable the Fanatec LED option in the game to disable FanaLab support. So everything correct and nothing reversed here.

  • Marcel PfisterMarcel Pfister Member, Administrator
    1. A function to change the font type is planned, I'll give it another push.
    2. The driver and FanaLab have two completely different purposes, one you open maybe once to change some fundamental settings, calibrate it and check the function, the other you have running all the time to customize your experience for each game. There are plenty people which would be overwhelmed by the complexity of FanaLab implemented into the driver and they prefer to keep it simple. Also it will make the development to have everything compatible even more complex when driver and FanaLab are merged so close together which would lead to even more refinment loops before everything is worth a release. I think at some point we can link from one to the other so its easier to switch between both and also making sure to have compatible versions installed but I'm not sure if they will ever be all in one. For example Nvidia also has a quite old control panel which you use to set basic and classic graphics settings and then they have a new UI with more modern features and shadowplay. Nvidia has this for years maybe for a similar reason and it doesn't seem to change so far.
  • Marcel PfisterMarcel Pfister Member, Administrator

    It's intended like this:

    "Enable FanaLab...." makes sure the game is not sending commands which conflict with FanaLab:

    "Disable FanaLab..." lets the game send commands again in case FanaLab isn't used anymore:

    I know it can appear a bit confusing because the green button is disabling it in the game or at least showing the instructions for it and the red one es re-enabling them for the game. But in the perspective of FanaLab it makes sense that the first one is green and "positive" and the second one is red and "negative" to make sure the first one gets used so there is no conflict between FanaLab and the game.

  • Hi, testet F1 2021 right now, but telemetry does not work even with newest 1.57.4 update... upon getting to the race track leds shorty flashes but no output while driving...

    fanatec led support is deactivate of course in game... telemetry i enabled and port etc set correctly, also set telemetry mode to 2020...

    in f1 2020 telemetry is working btw...

    deactivating udp telemetrie and use fanatec led support does work ....

  • To me telemetry on F1 2021 works fine, now.

    I had MAJOR issues to get F1 2021 and F1 2020 to recognize correctly the CSL DD + Formula F1 2021 LE steering Wheel, in PC mode basically nothing worked, in compatibility mode many important buttons were not working or mappable... but... after working on steam setup and clearing all old profiles in the game, it seems to work fine, now... fingers crossed........

    The big issue now is that I'm FORCED to use the 2020 telemetry mode in F1 2021, in order to use the revLED, BUT the program that I use to manage my bass shaker instead work with the proper 2021 telemetry mode (It accepts the 2020 mode only in F1 2020)... so due tu the LIMITATION of Fanalab that STILL doesn't support the 2021 mode, I can't use my bass shaker (or i can use them but then I've to give up revLED)..... so, in the end... 2021 telemetry mode support by Fanalab is strongly needed, for me.... I hope we'll have it soon...

  • edited September 2021

    I use iRacing, have a DD1 and the Porsche Cup Car wheel with Endurance Button Module along with the V3 pedals. Since updating to Driver 4.11 and FanaLabs 1.57.2 button module ITM display doesn't register any information (but the legacy mode shows the gear changes). Also, the rev lights don't work right and they only go up 2/3s of the way when the car hits the limiter. The ITM issue isn't a big deal as I rarely look at it, but the rev lights not working right is really a bummer as I use that information regularly for shifting.

    When I start iRacing, FanaLabs seems to quit. The icon will be in the system tray but when I mouse over it, it disappears. When I try restarting it nothing happens. It starts loading and then just quits again. Any fixes for these issues?

  • You want to be using Fanalab,

    I have the exact same setup using Driver 412 and Fanalab and it works perfectly.

  • I absolutely agree. 2021 telemetry mode is very important and needed as soon as possible. I also cant use both my programms because Fanalab only supports 2020 mode and F1laps (tracking of F1 2021 stuff) only works with 2021 mode in the F1 2021 game. So please, dont make me decide between Fanalab and other programms. Get the 2021 mode out :S

  • You can use FanaLab v1.57.2 which uses the F1 2021 Telemetry. Because if issues with the F1 2021 Telemetry where LEDs, Display and Vibration stuff gets send in menus it was changed to 2020 only in 1.57.4 until the issues with the 21 Telemetry are fixed.

    But at least you still could use Fanalab with all other Programms with 21 Telemetry with the proper version.

  • Julian WolfJulian Wolf Member
    edited September 2021

    Ok thanks, will do that until then. Where do i find the download of v1.57.2?

  • Great, thanks. I'll try that out. I didn't realize there were newer drivers available in the forums!

  • the car ahead and behind gap indicators on ITM display don't do anything in iRacing. Tested with an AI race with Dallara P217 and while the lap readout works the gaps are always 0

  • Please have a look at the included ITM Feature pdf file where supported Telemetry data for ITM is listed.

    You can see that car ahead and car behind is NOT supported by iRacing so there is no way FanaLab can show this data.

  • Marcel PfisterMarcel Pfister Member, Administrator

    We should be able to solve the 2020 2021 telemetry conflict in the next version

  • Hi,

    I got virus alert Fanalab 1.57.4

    Virus: Gen:Variant.Bulz.711101 (A Motor)

    File: PodiumrFactorPlugin.dll

    Folder: D:\Program Files (x86)\Fanatec\FanaLab\Control\plugin

    It was, with the 1.57.3, too. I got same message. I am using G-Data Virus Protect.

  • Hello,

    don't know if this was already mentioned or if i'm the only one with the following problem/behavior:

    Base: DD1

    Wheel: F1 V2

    Fanalab Version:

    Simulation: rFactor 2

    Within rF2 my wheel shows me yellow flags, blue flags, green flag and other information with the side LEDs on the wheel.

    When in Fanalab i could only configure Pitlane and Pitlimiter LEDs. When hovering over the other LEDs, i get the message "Not available on Game". In telemetry feed i can see information like "Is Track Yellow - Yes/No" , so the information is available and when driving, i have more LED Information than inPit and Pitlimiter.

    Is this a fault only on my side or is there any other person with the same behavior?

    Is it possible to deactivate single LED symbols (for example never show DRS activated) or bring the single led symbols to a manual sorting like the information in the small wheel display?

  • edited September 2021


    My BME seems to get stuck on tunning menu if I press the tuning menu button since I upgraded to the CSL DD. It works fine on my other rig with a CSW V2.5. I can page thru settings and change things but when I push the menu button to return to ITM screen nothing happens and some of the buttons won't register input. The only way to get out of the setup menu is to open Fanalab and reset all tuning menu presets. Any suggestions welcomed. All drivers and firmware have been updated to latest version.

    Base is

    WB Motor is

    BME is 18

    Wireless QR is

    PC Driver 415



  • Hi,

    Will this latest FanaLab update (1.57.4) allow for multiple Windows user accounts to maintain their own unique Fanalab settings?

    We have 2 users with separate windows accounts, and I know that profiles will allow each of us to maintain our own default settings. For us, it would be more convenient if we could simply change setups (1-5) from our button module endurance while in-game.

    If this update doesn't have this capability, I'm wondering if a workaround would be to get a 2nd SSD and setup a dual-boot and have separate installations of FanaLab?

  • The settings on my system are in


    and therefore user specific.

  • Hi There,

    Am i doing something wrong with settings - the profile in the load/save line on the game profile page randomly (seemingly) changes to the second profile on my list - so i may have a profile or car loaded, and when i go back to fanalab i see the profile ready to be saved/loaded has changed - which is super frustrating as it means i overwrite the active profile all the time by accident. Happens in iracing, not sure if I have ex0plained it well enough.

    Alos, is there step by step instructionms anywhere on how the save/load functions and tickboxes work? I try and use them yet I am never sure which boxes I should have ticked when trying to save or load just parts of a profil on to the actibve one.


  • That's normal. Fanalab always changes back to the top profile of each game when a game starts. Once you know you can prepare yourself to have a look before you overwrite anything ;)

  • Thanks Maurice, what this means is that everytime you change a session in Iracing that it resets - seems like a strange choice to make this happen, perhaps a setting could be introduced to stop this behaviour?

    I have been using your profiles for a year or so, after updating to the latest firmware/fanalab they feel nothing like how they did - now there is massive recentering force (which I hate as it feels so unnatural) and turning just feels like pushing against a dead lump of force. Any ideas on where I should start looking?

    Im on DD2/porsce endurance wheeel and also a FV2 wheel.

  • Yaaseen SheikYaaseen Sheik Member
    edited September 2021

    Hi all,

    Bit of a stupid question. I have recently purchased the Fanatec Podium Racing Wheel F1 bundle for PS4 and PC. Fanalab detects the wheelbase, steering wheel and clubsport v3 pedals, however, Fanalab shows that I have the standard DD1 and the Clubsport Steering Wheel Formula v2 (closed bottom) connected as opposed to the DD1 PS4 and the Clubsport Steering Wheel F1 for PS4. Is this normal or is there something I can do to ensure that the correct wheelbase and steering wheel are displayed?

    I am using Fanalab V1.57.4 as well as the latest compatible driver.

  • That's normal.

    You can choose the picture of the Formula v2 with the Grey dropdown arrow on the Main tab though.

  • Hi Stefan

    I have the same issue. My kit is the same as yours except I have the CSW 2.5 Base.

    I use rF2 exclusively and for the first time those 'new' features have semi-worked with this Fanalab version although nothing was mentioned about it in the feature description. To change colours and functions, open Fanalab when rF2 is not running and you will be able to access the LED functions from the LED tab. Save your rF2 profile, then start the Sim. I think this may be a WIP feature at the moment as I have found that the LEDS work differently at different tracks e.g. you can get a yellow flag when there isn't one, and DRS sometimes works and sometimes doesn't. I've kept quiet about it as I've been waiting for this feature for a long time and hope that it gets fully sorted soon 😉



  • A complete uninstall of fanalab and drivers and a reinstall after reboot seems to have fixed my problem with tuning menu hanging on my PBME.


  • Hi Graham,

    thank you for your information and the help. I've loaded the rF2 Settings without rF2 started.

    But even so i can't configure all LED's. Maybe u're right and this is a WIP feature. Hopefully they check it soon and we got the full functionality. :)

This discussion has been closed.