Fanatec Driver 452 (Prev. Release Candidate) for CSL, CSW and Podium DD WB (all wheels)



  • edited November 2023

    Can we make that if we double click the icon tray, it opens the control panel, right now you have to right click the icon > Fanatec Driver > Open Fanatec Control Panel

  • edited November 2023
  • Hi Marcel,

    Pc Driver 452...WB Firmware Motor Firmware release Firmware

    Laptop Acer Nitro AN515-54 x64 Based PC

    Wheel CSL P1 V2....Base CSL DD with boost kit....Game EA Sport WRC

    When you use the PC Mode the wheel vibrates violently and it will only start to operate normally when you switch to Clubsport wheel base V2.5 Compatibility mode, however randomly you have no steering input or gear changes.

    Can you say what might be the problem or anyone else in this forum.

  • "(We will now apply the fix for the CSL DD as well)"

    I'm reading this for more than a year now, will we finally have a fix for this in next november update? Or i'll keep reading this for another year?

  • edited November 2023

    No. Unfortunately the fix will take some more time...

    It is still high on the priority list though and it is still planned to fix it, but most likely not this year anymore unfortunately.

  • I had a bit of a nightmare getting the Wireless Quick Release firmware updated on my DD2, and resorted to drastic measures. All the firmware updater was telling me was "Power OFF the base" or something to that effect...

    The drastic measures are as follows:

    • Disconnected the devices, and used NirSoft USBDeview to delete everything with VendorID 0eb7
    • Uninstalled the driver
    • Used Windows to stop Fanalab from starting at windows startup
    • Rebooted
    • Installed the driver, and rebooted when prompted
    • Plugged in devices
    • Opened Fanatec Control Panel
    • I got 2 UAC prompts, which I clicked 'yes' for
    • Opened firmware manager
    • Clicked update
    • Waited the required time, and pressed okay

    and then it all worked.

    I only started down this path because I needed to update my pedal calibration and the previous driver got stuck in that UAC prompt loop. I have no idea what the issue was, but it's all fixed now.

    Hopefully if someone else has the same issue they'll find this and be able to resolve it.

  • Hello, not been on here for over a year (due to illness and my brain is soup) I'm confused,(as always) the public release for the driver is exactly the same as this one? I have downloaded both, but which to install?

  • I had the same exact error but could someone tell me if the following screen shot indicates that actually all is fine and updated?

    Thank you,

  • Thanks for confirming and ran some laps and had no issues.

  • I would like to know this too. I am always confused if these are Betas that get more updates or if they are Final when uploaded here. And if there are updates the Versions are changed? 453 etc? Or would it be 452 in this case and just uploaded again?

    Often i see people being sent here to get the "latest" Driver, but the Fanatec Page still has the previous driver for Download. Then when they do go to that page the only difference I see is the Folder Names.

  • Is it still necessary to update the firmware on CSP v3 pedals via USB if they are connected via RJ12 to the wheelbase?

    Thank you

  • edited November 2023

    Button flickering: I was writing a message after seeing the same thing on my M4 wheel and I'm happy to see that it doesn't come from the hardware.

    On my wheel this happens on 3 buttons (both on the back and the one at the bottom left of the front) if it can help.

  • It's been a long time since the previous driver release. I'm disappointed that the "steering jump" issue is still unresolved. I've been patient yet continue to have to use my DD2 in the low torque mode in order to avoid injury. Even then, I still feel random small torque impulses from the wheel.

  • edited November 2023

    hello, what are the new ffb settings rfactor2 with the 452 driver and the latest update of the game for a dd1 with high torque.

  • edited November 2023

    Dear all,

    After some hiccups (really not a problem-free firmware update, I was scared at times I might had bricked my CSL DD 8 Nm), I ended up with my unit degraded to... 6 Nm.

    Has anybody suffered the same problem? Is Fanatec aware of that?



    EDIT: I went to Tuning, change modes from advanced and back, and my unit is back to 8 Nm.

  • Yeah when you use FFS LINEAR, like in your Screenshot, ehen a CSL DD is limited to 6Nm Max, that would be correct... Only I FFS PEAK it can go up to 8 Nm.

  • DD1 here and experiencing this now as well where I had not ever noticed before, it auto corrects but the jolt mid turn doesn't inspire confidence. Also, I am not running the ITM

  • I was expecting an update with changes for FM 8, will there be the possibility to see rpm leds work on xbox series x?

    Csl elite - Formula v2.5

  • A Xbox SDK is in development but no ETA when its going to be released. Once released, the games would also need to implement that SDK in order to enable those enhanced features.

  • Ah thanks I did not know, After the multiple scares of the upgrade I thought that was one more.

  • Goodmorning,

    I am trying to download the latest driver onto my Windows 7 PC (up to date), and I am not having any luck. The following messages I receive are shown in the pictures below. I have restarted my PC multiple times.

  • Windows 7 is not supported by the drivers since some years (since Microsoft ended official support).

    Only W10 and W11 are supported.

  • Unfortunately there are still steering lashes....less...but there are.

    It is impossible to play since at any moment it ruins your racer.

    Change all the sofware engineers and hire someone who knows how to do it someone from Moza,Logitec....

    Fix Drivers Fanatec.......again😡

  • edited November 2023

    Hi guys, I've been trying for days to update to 452 but unfortunately I can't, I've tried everything.

    When I enter in control panel and open the firmware manager the application seems to crash, I tried to uninstall drivers, restart, tried everything but it doesn't work, 451 drivers work very well, and I can easily enter the firmware manager without crash, please someone help me, thanks.

    (windows 11, fanatec dd1, pedals v3)

  • What are your devices? Please see first post how to report issues, its quite important to at least know what devices someone has and also how the devices are connected (eg Pedals connected to Base or via USB etc).

    Can you please zip the whole C:\Users\Public\Fanatec Logs folder and send to us here with 452 installed and at least one crash happened?

    Also, please try:

    • uninstall current driver package on your PC
    • check if "C:\Program Files\Fanatec" still exist afterwards
    • if still existing after uninstall, delete it manually
    • re-install driver 452

    Can you also send us the following folder? Just copy-paste %LOCALAPPDATA%\Endor_AG_Fanatec in the File Explorer and press enter like this:

    Copy and zip all the content of that folder and upload here.

    Then Close Control Panel UI, delete all the content of %LOCALAPPDATA%\Endor_AG_Fanatec and try opening Control Panel UI if it still crashes.

  • Did the update for 452 on my DD1 last sunday, played for one hour then turn off. On tuesday night, i tried turn on again but unfortunately the DD1 not recognize my wheel anymore e show this massage.

    I did everything it was possible did downgrade old versions no success .My dd1 became a paperweight of 10 Kg, I opened a ticket support and i'dont have any expectations, cause my base Out of Warranty already. Sad about this for losses a expensive goods because of the simple update.

This discussion has been closed.