Fanatec Driver 456 (prev release candidate) for CSL, CS and Podium (all wheels)



  • Between the red and purple CS DD+ has a light blue mode.

  • For Gods sake, you still haven't enabled sequential shifter function with Podium Button Module Rally. I bought this bleeding wheel 3 months ago, how can the flagship Rally module be the only product that CAN'T use sequential shift?

    Then in the new driver update, with this a known issue, it's not even addressed.

    It beggars belief...

    I can also second the reports of infinite update loops (going through the update process, completing, then stating not updated, prompting the update process again - ad infinitum) for:

    Podium Hub

    McLaren Wheel

    Universal Hub V2

    GT DD Pro

    Shifter Sq1.5 connected via base

    Latest Firmware / software, this driver version (456)

  • ScSc Member

  • Can the known issues list in 1st post be updated.

    And is the issue 'not an issue' or does the issue mean downgrading to 455.

    All buttons seem to work fine in the drivers gui,wheel,tuning etc but have not tried on track yet.

  • The issue is "not an issue". Just ignore the FW v0.

    Known issue list might be able to get updated next week, or maybe we will bring a hotfix driver, lets see.

    However we can not list every known issue in the first post, then the list would be endless as internally we know about a lot of more known issues which we cant list all...

  • ClubSport DD(+) Firmware Improvements

    • Potentially fixed wheel communication freezes after some time of driving.

    Still present, not fixed, just happens again. see my bug report post above. But my base lost the ffb too if this happens. Games: Project Cars 2, WRC Generations if important.

  • Same here with the DD+ with the extreme wheel I just set up. I left my base turned on for a few hours and when I came back, the wheel functions like the display were unresponsive. I hope this is being given high priority to fix. This is very concerning.

  • I updated the GT DD Extreme drivers and fw yesterday no problem with 455 on windows 10.

    So today I did the exact same thing with 456 and the wheel is now bricked.

    Had trouble when updater crashed doing the QR2 FW with wheel off, but wheel FW was already updated successfully.

    Then reinstalled wheel and it is dead. Not detected by base or control panel.

    And in the Firmware updater there is no option to repair in the manual update section like it shows in the explanation.

    SO that sucks, Wheel worked perfect all day yesterday for many hours.

    I have the metal QR2 installed I'm not sure if that makes a difference.

    Any help would be appreciated. Anything else I can try besides the driver repair? That didn't work. Not sure about manually updating the firmwar4e, no option for wheel and crazy warning about permanent bricking something with base and QR fw.

  • BWX 232BWX 232 Member
    edited February 24

    I installed QR2 Lite onto WRC wheel and it's also dead when connected. Can I manually reinstall QR FW?

  • Hristo GoshevHristo Goshev Member
    edited February 24

    Yes, reboot the base and manually reinstall the QR firmware, with no steering wheel attached to the base.

  • Hi, same problem for me too. I hope it gets resolved soon. Thank you.

  • Yeah I did that like 5 times.

    Here's what I did that finally ended up working:

    I tied a bunch of times to reinstall QR2 FW and it would not finish, kept getting errors, data transmission - transferdatarequest response failed..

    SO I uninstalled everything fanatec, rebooted, reinstalled the 456 package. Then tried again, sometimes QR2 FW would go to 1%, sometimes 80%, etc, and fail. So then I manually reloaded base FW, then tried QR2 FW again, same problem. I kept trying, same thing. Kept trying like 7 times, eventually it worked and now wheels are working.

    I just kept trying and eventually the QR2 FW updated but it was buggy and sketchy the whole time. I tried different USB ports too, no change.

    These pics might not display in chronological order but anyways, this is what I had to keep doing and somehow it finally worked.

  • I definitely did that first, fourth, ninth and 17th times. LOL I tried the normal stuff before I got concerned. I'm just glad it's not bricked bricked.

  • I had similar problems with my DD+ and 455. Using the original USB cable in an USB 3.0 port of my PC‘s motherboard without any extension inbetween worked for me. Therefore I had to dissamble my rig to put my wheel base close enough to my PC. Everything that worked before with my DD Pro didn’t work. It even didn’t work with the original USB cable of my DD Pro.

  • Base: Clubsport DD +

    Steering Wheel: GT Alcantara on clubsport xbox universal hub v2

    Platform: PC

    Driver: 456


    Steering wheel: 2



    I installed the Podium advanced paddle on a Clubsport Universal Hub v2 for XBOX

    Upshift, downshift and the analogue clutch buttons work perfectly.

    The small paddles at the top however don't seem to work.

    The same Podium paddles disassembled from the XBOX hub v2 and reassembled on the F1 wheel works perfectly.

    Brought back to the XBOX hub and the upper paddles still don't work.

    Are there any compatibility problem?

    Thank you

  • That's a known issue currently under investigation to get fixed in an upcoming firmware update.

  • Hi, the rotate function of the funky switch on my formula rim is counting as 2 inputs when only rotating once, this is happening both ways, in all sims. Yet in fanatec software it only inputs once, and is also fine in tuning menu, any help is appreciated, thanks

  • edited February 25

    As I noted in another thread. I was just playing GT7 for abt 45 minutes and at one of the menu screens after driving, the display (really rpm meter) and buttons froze on the dd extreme wheel using the DD+ base.

  • Hi, had a wheel communication freezes again but this time the FFB went out aswell

    • Wheel Base: CS DD+
    • Steering Wheel: V2.5X
    • Driver Version: 456
    • Base FW Version:
    • Wheel FW Version: 47
    • FanaLab Version: V2.01.28

  • Ah and no button on the Wheel is working with this freeze. So no FFB and no buttons, just steering and pedals. Maybe a 2nd log can help too. This happened just 2 min ago

  • I ran into it doing a lot of short 1 minute races like the license tests in GT7. I haven’t done any long races yet. Just musing if it may happen more going into and out of races more frequently. Anyway I hope the firmware developers can find a solution since it is annoying.

  • Fanatec Its products are all bugs,Even products that have been released for two years

  • edited February 25

    X2 this issue. Same exact happened to both my 2.5x and Extreme wheel. I updated to 456 yesterday. Since then it has happened 5-6 times in both ACC and iRacing using 2.5x and GT Extreme wheel. FFB goes out completely with all functions of wheel. Fanatec Control Panel shows no wheel is connected.

    Only resolution is to turn off the base and restart it. Sometime also have to quit game and restart. During a race session, this is a big no no.

    How do you get Fanatec Diagfile generated to upload? I guess the more they have, easier they can fix this? Definitely looks like software/firmware issue if people getting same exact issue.

  • Gökhan OgulGökhan Ogul Member
    edited February 25


  • Exactly same here if happens. Taking a look to the driver shows „no steering wheel“ and WQR Version But most of time it works fine.

  • Hoping not but this is looking like another Fanatec failure. I have been hesitant to power up and test my Extreme. When I do I am only going to try the Extreme wheel. If I get any failures its going back for a refund and I will keep using the GT Pro. Its been working fine with V2.5X on all 3 platforms with firmware 451.

  • It's a known Firmware issue to be fixed in an upcoming firmware update.

  • Ok good, hope the patch comes quickly! Because racing is so much a matter of luck!

This discussion has been closed.