Fanatec Beta Driver V373 (372 before) for CSL, CSW and Podium Bases (all wheels)



  • Quan NgoQuan Ngo Member
    edited August 2020

    Any help possible??

    I have the F1, PBME & a 2nd Podium Hub both failed during each of their FW update. F1 wheel updated after downgrading & then updating the driver. Was able to use the bootloader to update the PBME after hours & many retries, but no way to update the 2nd Podium Hub (doesn't have it's own bootloader). The Universal Hub was the first to update after installing the Driver 372, & it went flawless.

    My PBME does not appear in the properties menu after FW completed at 100%. It does turn on & light up, but is unresponsive. Does not show up on Fanalab either. At this point I would rther not downgrade the PBME as it will require hours with the bootloader.

    • Wheel Base Model (product ID): DD1 PS4
    • Steering Wheel Model (product ID): Podium Hub
    • Driver Version: 372
    • Base FW Version: 674
    • Motor FW Version: 40
    • Wheel FW Version: 35
    • FanaLab Version: 1.47

  • You should contact the support, looks like a bad connection between Base and Wheel (maybe damaged cable in the Base Quick Release or so).

  • Quan NgoQuan Ngo Member
    edited August 2020

    Hi Maurice, it had all worked for driver 356 & 365, albeit time spent on the bootloader for the PBME each time. I will contact support.

    I was able to connect the PBME to the 2nd Podium Hub & update, it too is unresponsive. If the PBME was able to update, wouldn't the Podium Hub also be updated? as the PHub alone is still not detected (No wheel attached in fanalab & Wheel property page)

  • ClubSport v2.5

    pc driver 372

    wheel base motor firmware 22

    steering wheel firmware 35

    i have ClubSport v3 pedals and the rumble on brake and throttle will not activate since update

    ps I uninstalled and reinstalled and still not working

  • I am still getting the knock as well on my DD1 but it is very faint now too.

  • I'm on CSL Elite on PS4. Upgrading the firmware was pretty easy, just make sure you remove the old driver first and I also had to restart my machine after that.

    Very pleasant improvement on the FFB details seems like so I'm happy with this. No issues so far after a few hours of use.

    Thanks guys

  • Alex FournierAlex Fournier Member
    edited August 2020

    Do you use VRS telemetry and/or IrFFB with iRacing !?

  • Rinus HuismanRinus Huisman Member
    edited August 2020

    Goodday Marcel,

    Do you have a clue why 365 and 372 does have lots of noise on the CSW 2.5 (loud 'chirping' noise and a loud/stuttering fan) while 347 is completely silent. (Fan is not as loud as on 365 and 372)



  • Is it possible to roll back to previous firmware?

    Where would we go to get the previous files?

  • Daniel HaynesDaniel Haynes Member
    edited August 2020

    Podium F1 user.

    finally!! A flawless driver for me... I’ve been plagued by formula v2 freezes for nearly a year making that rim unusable, i would just use the bmw wheel which always worked perfectly. V2rim was even returned for rma and a new one provided but it didn’t help. Only reason wheelbase was not returned was my remote location, massive shipping cost and the COVID lockdown. I was just on the verge of shipping it, But recent freeze firmware fixes provided fixed the issue 90% with only very occasional freezes so I had faith it could be resolved.

    this firmware installed perfectly first time (last update eventually required a full windows reinstall it was that bad) everything updated perfectly and I especially got excited when I saw a ‘wireless quick release firmware’ update for the first time. That sounded exactly my issue.

    raced the wheel all day yesterday with the V2. And it feels literally perfect. So perfect I ran the iRacing Road America 6hr last night with the V2 and got a podium finish. Not a single knock, or issue. No shifters freezes or anything. Absolutely perfect first time.

    also the fanalab update is not too shabby... looking MUCH nicer!

    Obviously more hours will be spent in the next few weeks to confirm the freezes are 100% stopped but for now....


  • I noticed the patch notes said the MPS buttons on the McLaren rim have been fixed for the CSW 2.5 base. Is there any hope that this will be fixed for other bases? I’d love for my MPS dials to work for ACC on my DD1.

  • What do you mean? MPS on every base are working fine in ACC. Just set them to Constant select the the preset of the McLaren in game and then the left one controls TC and the right one controls ABS.

  • 365 driver was installed with its firmware

    Installed 372 driver

    Updated base firmware

    Updated the motor firmware

    I started updating the steering wheel firmware and an error occurred by 41%, I attach a screenshot

    After that, the base does not see the steering wheel

    Rolled back to 365 driver and its firmware - does not help

    Rolled back to driver 346 and its firmware - does not help

    On another computer, the same thing, in principle, what's the difference if I turn on the base without a computer and it does not see the steering wheel

    Installed windows on the main computer from 0 - updated to the latest version - installed the driver 372 first, updated all the firmware - everything is the same

    I attach the second screenshot with the current state of the driver, Wireless Quick Release - 0 when the update button is pressed, the device disappears from the list and nothing happens

    No steering damage

    There is no other rudder to check

    Everything is fine with the steering wheel and the mechanical clock, the steering wheel stopped being detected after an error during the firmware



  • Just download a previous driver, install it and overwrite the firmwares.

  • edited August 2020


    after update driver to v372, i'have this message

    "Your CSL Elite Wheel Base PS4 firmware is not the latest one! Do you want to update now?"

    but when i clic yes, the base led become purple and nothing more come

    any idea ?

  • Did you also update the Wireless Quick Release (V6)? It says "0" on your screenshot... ?

  • Greetingshat's normal because your angle where the damping is working is much too small with 15° so 7.5°. To each side. Of course I the transition is then extremely harsh. Increase the working range to 100° or so

    Hi Maurice,

    thx for the fast answer. I like your work here and your fast and calm answers. And you know fanatecs products very well. Great!

    Think i found a bug with fanalab or the driver 372.

    I tried your solution and sometimes it works, sometimes not. 2 times i started ACC and F1 2020 and the damper works, the steering gets much tougher and oscillation where gone, after reaching the minimum speed. But after i deactivated the function and reactivate it again, it was like i wrote before. The damper comes late and it feels like a metal klong. Something like the wheel isnt attached properly to the base....

    Maybe a problem with the steering angle issue? Sometimes the angle is right sometimes not! And after i changed from auto to manual 1080 degree it was gone...but only for one time! Dont know...

    Neverthelss, wasnt the speed sensitive damper introduced to damp oscillation on straights (to stretch your hands in along race) and not to make the wheel heavier and more damped in curves, where your hands should stay on the wheel and oscillation is no problem? In the earlier version i set it to 15 degrees and it worked perfect.

  • edited August 2020
    • Wheel Base Model (product ID): CS_WB_V2.5_EU
    • Steering Wheel Model (product ID): CS_SWFORM_V2X
    • Driver Version: 372
    • Base FW Version: 674
    • Motor FW Version: 22
    • Wheel FW Version: 35

    After installing the beta driver I start up the base and the OLED screen shows a glitched Fanatec logo on startup. Is this something I should be worried about? The wheel works well (only tested it shortly) and I don't think anything is wrong with the wheel. I also had the same issue with the previous beta drivers. When using the official 328 drivers on the CSW 2.5 page I do not have this issue. I am able to enter tuning menu and adjust everything. The attached image shows what I mean with glitched logo. IT will look like that for a few seconds then go to the normal looking logo. Also, I uninstalled all firmware, reboot, install firmware without wheel attached, attach wheel, install wheel firmware. I just forllowed the steps in the recent video by Boosted Media on youtube.

  • Now I am also getting that when I go to the properties page, it sees my Formula V2 wheel as a CSL Elite Steering wheel P1 and random buttons are firing.

  • Please contact the technical Support, your Formula wheel is broken.

  • edited August 2020

    Oh, that is a pity, it works with the standard drivers just fine. (I have downgraded to the standard drivers that are on the main page for the base for now) But I will get in touch with them.

    Seems like this is more of a software issue no? Seeing as it is the beta driver that is doing this and not the official driver on the site.

  • Hi all, after installing the new driver I had some issues with pc start. So in this case I start invesigating a littel while and figured out that every time when I start the wheel base v2.5 with V2 wheel the system interruption in task manger increases to 4% or more. At some point after starting I had system interruption of 100% with a very noticeable slowdown in the entire system! Do someone know a solution for this?

  • Thanks for the reply Maurice. I hadn’t noticed any presets for wheels on console, but I’ll check again. Glad it’s a simple fix. Cheers.

  • ah on console its a different thing. MPS on Xbox will never work because Microsoft only allows a certain number of buttons (10 or so) and the MPS are buttons 48-70. Nothing Fanatec can fix, its Microsoft who needs to update their Xbox Code to allow more buttons, LEDs and Display information etc.

  • Ah! I’m on PS4 and my F1 2020 rim works great on ACC, but I’d love to get my McGT3 rim fully functional. Is it a similar issue on PlayStation?

  • On PS4 there is noch such limitation and when the MPS of the F1 2020 Wheel is working, then the McLaren will also work fine.

  • Great! When I get home from work tonight I’ll set them to constant and finally get this sorted. Many thanks for all your help. It’s much appreciated.

  • Hi

    Could do with help after trying to install the new firmware. The base fw went fine as did the motor fw, but during the quick release fw it stoped at about 50 percent with an error message. Now none of the wheels I have work when attached to the base and none of them show up in the control panel. It's a PS4 podium that I have with the rim it came with, also have BMW rim and another rim with the button module.

    I went back to the previous driver/firmware and it still won't recognise any of the rims. So I tried an even earlier driver but still the same problem.

    I also uninstalled drivers before downloading new ones.

    Thanks for help in advance 🙂

  • Hi,

    i have still freezes with my DD1 and V2. Is there any Wheel where i can be safe to dont get this freezes?


  • ClubSport v2.5

    pc driver 372

    wheel base motor firmware 22

    steering wheel firmware 35

    i have ClubSport v3 pedals and the rumble on brake and throttle stopped working after The update. How to fix this?

This discussion has been closed.